37 Responses to “Minor update of the PHP 5.2.9 packages”

  1. Phil

    Hi, these packages are built with an old client api version:

    Client API library version 5.0.67
    Client API header version 5.0.51a

    Reply
  2. endre

    Am I supposed to be able to build the dotdeb etch sources on Etch? It isn’t easy for me at the moment, mainly because of conflicting dependencies (libmysqlclient14-dev when etch has 15 and dotdeb has 16, libdb4.2-dev when apache depends on 4.4 so installing 4.2 removes apache devel packages, and so on) and missing sources (php5-memcache has no source on dotdeb.org)

    Reply
  3. endre

    Really quick answer, thank you. Would you please point me to the php5-memcache source on dotdeb too? apt-get source can’t find it.

    Reply
  4. endre

    Thank you very much, now I’ll be able to build php from dotdeb packages, but seeing that you removed sigchld support, I probably won’t need to :)

    Reply
  5. Matt

    I agree with Peter, can we get the php-mysql module updated to 5.1.34 of mysql? Or can someone provide instructions on how to do that?

    Reply
  6. Guillaume Plessis

    @peter @Matt : Compiling PHP modules against MySQL 5.1 would cause more pain than it brings features : In fact, there will be issues when MySQL5.0-linked Apache modules (such as auth_mysql) and MySQL5.1-linked PHP extensions are loaded together.
    Segfaults will occur as soon as a MySQL function is called.

    This behavior has changed with mysql PHP 5.3 (preview) packages as mysql native driver has replaced libmysqlclient in all the MySQL-related extensions : http://docs.php.net/manual/en/mysqli.mysqlnd.php

    Please be patient.

    Otherwise, if you want to build PHP against MySQL 5.1 (at your own risks), follow these steps :
    apt-get install libmysqlclient-dev (ensure that it’s the 5.1 version)
    apt-get source -b php5

    Good luck.

    Reply
  7. Matt

    Thanks. Do you see any stability issues continuing to use the mysql API compile for 5.0.51a? phpMyAdmin is crying about the API being an older version than the actual mysql server version. I was told to upgrade it but I’m not convinced it’s needed. I know Apache modules for 2.0 worked with 2.1 fine but then when Apache 2.2 came out, you were told to compile new modules. Your advice is greatly appreciated!

    Reply
  8. Guillaume Plessis

    @Matt: There is no stability issue with these build options.

    I have >400 web servers at my company and a 7 years experience in building PHP packages that ensure a minimum stability. If you encounter any issue, contact me and be sure I’ll do my best to fix it quickly.

    FYI, the PHPMyAdmin message is just a warning and something visually annoying :)

    Thanks for using Dotdeb.

    Reply
  9. Matt

    I killed off the error in phpmyadmin. Thanks a lot for the help.

    And thank you for dotdeb.org!

    Reply
  10. Hakan Kaya

    I am trying to install APC but when I submit the “phpize” (or “phpize5″) command, I get this error:

    /usr/bin/phpize5: line 198: syntax error: unexpected end of file

    I tried removing php5 and reinstalling it, but to no avail. How could I possibly fix this?

    Thank you very much for your valued efforts.

    Reply
  11. Hakan Kaya

    @Guillaume : thanks for this hint, I did not realize APC was available from Dotdeb.

    Keep up your wonderful work.

    Reply
  12. Hakan Kaya

    There is one thing that still troubles me: if I install php5-apc the previously installed php5-common gets substituted and after that phpmyadmin won’t install unless I accept php5-apc to get removed again.

    Reply
  13. Guillaume Plessis

    @Hakan Kaya : I think you’ve got a mixed distrib. Check your sources.list, it should have the Debian-related lines + the Dotdeb ones. If you’ve got additionnal lines about repositories containing dotdeb, make sure all your PHP-related packages come from Dotdeb (think about running “apt-get update” first).

    Reply
  14. z33k3r

    Sorry; note this isn’t a PECL issue, but it seems to be a break down in communication between the libraries?

    Reply
  15. Mr. Foo

    Hello there,

    I have got a problem with installing php5-imap.

    Apt likes to downgrade all Dotdeb packages I have installed. Problem is that php5-imap requires libapache2-mod-php5filter [5.2.6.dfsg.1-1+lenny3 – even though that its availible from Dotdeb.

    My sources.list seems to be correct, isnt it?

    deb http://ftp.debian.org/debian lenny main non-free
    deb-src http://ftp.debian.org/debian lenny main non-free
    deb http://security.debian.org/ lenny/updates main non-free
    deb-src http://security.debian.org/ lenny/updates main non-free
    deb http://packages.dotdeb.org lenny all
    deb-src http://packages.dotdeb.org lenny all

    Reply
  16. Phil

    I had the same problem with other PHP packages from Dotdeb (Can’t remember which ones now).

    Some of them don’t work with Ubuntu 9.04 because their built against older libraries than Ubuntu 9.04 uses.

    Easiest work around is to comment out the Dotdeb sources then install the version from your distro, not had any issues doing this with Ubuntu, should think it’ll work with Debian as well provided the version of PHP they provide isn’t too much older.

    Reply
  17. Guillaume Plessis

    @Mr. Foo : please run apt-get update (or its equivalent under dselect, aptitude or so on…) before selecting and installing a package.

    If it does not solve your problem, tell me if you have any pinning in /etc/apt/preferences.

    Reply
  18. Phil

    @Guillaume – I realise their intended for Debain but dor the most part they work perfectly with Ubuntu (as it’s esentially modded Debian anyway) :)

    Unfortunately Ubuntu seam to have a lame attitude to updating their PHP/MySQL versions, so latest from Dotdeb with the occasional hickup vs old Ubuntu packages is far perfered imo!

    The minor PHP versions don’t usually contain very many important bug fixes, but the last couple of MySQL 5.1 updates have had numerous fixes for replication. Considering we use replication on some of our MySQL servers I would consider this a must, Ubuntu however seams to disagree as they’re latest version on Jaunty is still 5.1.31! Thanks to Dotdeb, no source compilations needed as we can just apt-get update :)

    Reply
  19. Mr. Foo

    @phil
    I cannot use the Distro version – because it would deinstall all Dotdeb packages.

    @Guillaume
    For sure I run an update before I try to install any package.

    So that can’t be the problem – but I have some entries in the preferences:

    Package: *
    Pin: release a=stable
    Pin-Priority: 700

    Package: *
    Pin: release a=unstable
    Pin-Priority: 600

    Reply

Leave a Reply

  • (will not be published)


four − = 2