Posted by & filed under PHP.

The PHP 5.3.3 packages for Debian 5.0 “Lenny” (amd64/i386) have been updated. Here are the changes :

  • php5-fpm should now work out-of-the-box. Some unset parameters prevented its launch. Thanks to Daniel Hahler for the patch.
  • PECL/APC has been upgraded to 3.1.4
  • PECL/memcache has been upgraded to 3.0.5

69 Responses to “PHP 5.3.3 packages get a minor update”

  1. kevin

    Was this the issue w/ spaces at the end of lines in the fpm conf that kept it from restarting?

    Reply
  2. Guillaume Plessis

    @kevin : no such issue has been reported. The update now sets the pm.start_servers, pm.min_spare_servers, pm.max_spare_servers and pm.max_requests to some default values.

    Reply
  3. Kasper Schoonman

    I installed PHP 5.3.3 and MySQL 5.1 from this repo but PHPMyAdmin show an warning:

    “Your PHP MySQL Library version mysqlnd 5.0.7-dev 091210 – $Revision: 300533 $ differs from your MySQL server version 5.1.51. This may cause unpredictable behavoir.”

    Everything seems to work fine, but indeed also according to the PHPinfo()-command the PHP MySQL binding seems to be 5.0.7 instead of 5.1.51.

    Will this be updated in a next release?

    Reply
    • Guillaume Plessis

      @Kasper Schoonman : as said many times on this blog, don’t worry about that delta between the client side and the server side, it does not affect the PHP behaviour. The version of the mysqlnd client library PHP was built with is different to avoid some duplicate symbols and then segfaults. And after all, mysqlnd will have better performance than the regular libmysqlclient library. Here is why : http://www.php.net/manual/en/mysqlnd.overview.php

      Reply
  4. Kasper Schoonman

    @Guillaume Plessis : Thanks.. Another probably stupid question I got these warnings about timezone issues when using date/time related functions. I tried adding/changing line 950 of /etc/php5/apache2/php.ini to:

    date.timezone = “Europe/Amsterdam”
    date.timezone = Europe/Amsterdam

    But none worked out, finally I changed it through a VHOST setting in Apache, but I think I should be able to do this via the PHP.ini, right?

    php_value date.timezone Europe/Amsterdam

    Reply
  5. Guillaume Plessis

    @Kasper Schoonman : no problem here in France. This line in php.ini avoid the warnings (after a Apache/FPM/whateveryouuse stop-then-start) :
    date.timezone = ‘Europe/Paris’

    Reply
  6. Richard

    This minor update sure takes a while. So afraid it will break my box. Luckily it didn’t.

    Reply
  7. terii

    Tried to install “php5-fpm” and got “E: Couldn’t find package php5-fpm”. Is it just me?

    Reply
  8. Guillaume Plessis

    @terii : be sure that :
    – you have the php53.dotdeb.org repository in your /etc/apt/sources.list
    – you ran apt-get update or equivalent to update your packages list

    Reply
  9. terii

    Uww… dude. I forgot to “apt-get update”. I have this automation script does a new server install for me… fixed! Thanks for pointing out. :)

    Reply
  10. adrian

    Hello,

    I can’t upgrade my PHP to 5.3. I did it like described in “Instructions” but after executing aptitude update dotdeb mirrors are fetched but no upgrades are available. The gpg key has been imported as well. What’s wrong ? :)

    I tried to add another dotdeb mirrors, they were fetched successfully but there were still no upgrade packages available.

    Thanks for any hint.

    Adrian

    Reply
  11. Guillaume Plessis

    @adrian : First, be sure to add the php53.dotdeb.org repository to your /etc/apt/sources.list.
    Then update your package list by running “apt-get update” or something equivalent. The PHP 5.3 package will be available.

    Reply
  12. adrian

    @ Guillaume

    yeah, I’m wondering as well, but I did it already; here’s my cut from sources.list:

    deb http://packages.dotdeb.org stable all
    deb-src http://packages.dotdeb.org stable all

    deb http://php53.dotdeb.org stable all
    deb-src http://php53.dotdeb.org stable all

    aptitude update:


    Hit http://packages.dotdeb.org stable Release.gpg
    Ign http://packages.dotdeb.org stable/all Translation-en_US
    Hit http://php53.dotdeb.org stable Release.gpg
    Ign http://php53.dotdeb.org stable/all Translation-en_US
    Hit http://packages.dotdeb.org stable Release
    Hit http://php53.dotdeb.org stable Release
    Ign http://packages.dotdeb.org stable/all Packages/DiffIndex
    Ign http://php53.dotdeb.org stable/all Packages/DiffIndex
    Ign http://packages.dotdeb.org stable/all Sources/DiffIndex
    Ign http://php53.dotdeb.org stable/all Sources/DiffIndex
    Hit http://packages.dotdeb.org stable/all Packages
    Hit http://php53.dotdeb.org stable/all Packages
    Hit http://packages.dotdeb.org stable/all Sources
    Hit http://php53.dotdeb.org stable/all Sources

    aptitude upgrade:

    gold-eck:/home/adrian# aptitude upgrade
    W: The “upgrade” command is deprecated; use “safe-upgrade” instead.
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Reading extended state information
    Initializing package states… Done
    Reading task descriptions… Done
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Reading extended state information
    Initializing package states… Done
    Reading task descriptions… Done

    No php upgrades available.

    Regards,

    Adrian

    Reply
  13. adrian

    Hello Guillaume;

    gold-eck:/home/adrian# apt-cache policy php5
    php5:
    Installed: (none)
    Candidate: 5.3.3-0.dotdeb.1
    Version table:
    5.3.3-0.dotdeb.1 0
    500 http://php53.dotdeb.org stable/all Packages
    5.2.14-0.dotdeb.0 0
    500 http://packages.dotdeb.org stable/all Packages
    5.2.6.dfsg.1-1+lenny9 0
    500 ftp://mirror.hetzner.de lenny/main Packages
    500 ftp://mirror.hetzner.de lenny/updates/main Packages
    500 http://ftp.uni-bayreuth.de lenny/main Packages
    500 http://security.debian.org lenny/updates/main Packages

    Regards,

    Adrian

    Reply
  14. Stephen

    I was just about ready to hit the FULL UPDATE to get PHP 5.3 installed, but I noted that SQLITE & SQLITE3 is going to get removed.

    Can’t have that as a few of the services on the machine require SQLite for internal fast database management.

    Why does it want to remove, and can I re-add it later?

    Reply
  15. Guillaume Plessis

    @adrian : regarding to apt-cache policy, “apt-get install php5″ should install PHP 5.3.3 from Dotdeb. Strange. No more message about conflict or something?

    @Stephen : perhaps you can take care of the dependency problems with a more verbose package manager (such as aptitude or dselect).

    Reply
  16. Stephen

    With dselect it tells me:
    php5-sqlite depends on libsqlite3-0 (>= 3.5.9)
    php5-sqlite3 depends on phpapi-20060613+lfs
    phpapi-20060613+lfs does not appear to be available

    Searching for anything to do with phpapi yeilds no results.

    On the Instructions page, I’ve added both sets of servers to the sources.list and looking in Adept Manager after a refresh, (I’m using Ubuntu 8.04) it shows me:
    php-sqlite3 -> Installed – No change
    php5-sqlite -> Upgradeable – Remove
    php5-sqlite3 -> Installed – Remove

    Reply
  17. Guillaume Plessis

    @Stephen : Dotdeb is not made for Ubuntu. It should work but you may encounter such conflicts.

    If you want to install PHP from Dotdeb, install all your PHP-related packages from Dotdeb => install php5-sqlite from Dotdeb, not php5-sqlite3 from Ubuntu.

    Reply
  18. misko

    Hello,
    I have upgraded from etch to lenny + php 5.3, after this i have noticed that some scripts are reserving memory, but on ending they are not releasing it.

    Can some one help me what could it be ?

    Reply
  19. jtexier

    Hi,

    I’m trying to install mongodb pecl extension on a Lenny/dotdeb php5.3.3 install.

    It currently fails because phpize is missing and I can’t install php5-dev because of :

    The following packages have unmet dependencies:
    php5-dev: Depends: libssl-dev but it is not going to be installed
    Depends: libtool but it is not going to be installed

    Any suggestion ?

    Thanks.

    Reply
  20. Kissifrot

    Any of you tried APC upload progress with this version? I can’t make it work anymore :(
    apc_fetch() always return false.

    Reply
  21. Kristoffer

    Hi,

    I tried installing the new php5.3.3 package on a Deb Lenny. It install just fine – but my apache stopped processing php files. I have php5, php5-cgi (and sli) + more installed.

    It seems the libapache2-mod-php5 package doesn’t bite – any recommendations?

    Reply
  22. Guillaume Plessis

    @Kristoffer : be sure to have php5 enabled by running these commands :

    a2enmod php5
    /etc/init.d/apache restart

    Be sure to have the appropriate lines in /etc/apache2/mods-enabled/php5.conf :


    AddType application/x-httpd-php .php .phtml .php3
    AddType application/x-httpd-php-source .phps

    Then take a look at your logfiles

    Reply
  23. Mostafa

    Thank you for your greate work.
    Dotdeb provide us :
    - MySQL
    - php
    packages, I think if you add these 3 ones, it will become to 1st debian internet server mirror :
    - apache2
    - nginx
    - lighttpd

    Specially apache2 is important! Because its version on deb packages is very old.

    Reply
  24. Bob C

    Since upgrading my Ubuntu 9.10 install of PHP 5.2.6 to dotdeb PHP 5.3.3 I am unable to install php5-dev, which I need to install certain critical PECL packages.

    I get the following error:

    php5-dev: Depends: libtool but it is not going to be installed

    When I install libtool using the normal ‘sudo apt-get install libtool’, it installs a version that php5-dev doesn’t like any better, and still refuses to install.

    I really need help with this, I don’t know what to do. I need 5.3.3 and don’t want to revert to 5.2.6. But I need to get libraries like pdflib to compile, and can’t do it without phpize that comes with php5-dev.

    Reply
  25. Bob C

    Guillaume:

    Yea, going to a lesser version of libtool did the trick. :)

    I got the instructions for installing PHP 5.3.3 on ubuntu 9 using the dotdeb distribution from a blog. I’m shocked to hear it might not have been true! ;)

    I’m glad I went through this exercise though… learned alot more than I knew before about many aspects of package management.

    It doesn’t always ‘just work’!

    Reply
  26. Adam

    I am trying to rebuild the php 5.3.3 packages so I can remove the suhosin patch but I cannot get the dependencies to be met.

    I get the following when trying to install the libraries

    The following packages have unmet dependencies:
    apache2-prefork-dev: Depends: apache2.2-common (= 2.2.9-10+lenny8) but 2.2.15-3 is to be installed
    Depends: libaprutil1-dev but it is not going to be installed
    libapr1-dev: Depends: libapr1 (= 1.2.12-5+lenny2) but 1.4.2-3 is to be installed
    Depends: uuid-dev but it is not going to be installed
    libpcre3-dev: Depends: libpcre3 (= 7.6-2.1) but 7.8-3 is to be installed
    libsnmp-dev: Depends: libsnmp15 (= 5.4.1~dfsg-12) but 5.4.2.1~dfsg-5+b1 is to be installed
    Depends: libsnmp-perl (= 5.4.1~dfsg-12) but it is not going to be installed

    Reply
  27. Guillaume Plessis

    @Adam : you should skip the “apt-get build-dep” step and install the build dependencies manually (they’re listed on top of the debian/control file) to avoid the distribution-specific conflicts.

    Reply
  28. Adam

    That’s what happens when I install them manually. The build-dep doesn’t work at all so I did a ./configure and then installed manually but I get that error list.

    Reply
  29. Guillaume Plessis

    @Adam : the steps…

    1. apt-get source php5
    2. install the build dependencies manually
    3. remove suhosin from debian/patches/series
    4. edit debian/control to ajust the dependencies (some are distribution-specific and hardcoded)
    5. run “./debian/rules binary” instead of debuild or ./configure
    6. install the resulting packages. If there’s still conflicts, repeat from step 4.

    Reply
  30. Adam

    I get this now

    Sorry, I cannot run apxs. Possible reasons follow:

    1. Perl is not installed
    2. apxs was not found. Try to pass the path using –with-apxs2=/path/to/apxs
    3. Apache was not built using –enable-so (the apxs usage page is displayed)

    Is that something I obviously don’t need and can bypass?

    Reply
  31. Adam

    If i try to install that I get

    apache2-prefork-dev: Depends: apache2.2-common (= 2.2.9-10+lenny8) but 2.2.15-3 is to be installed
    Depends: libaprutil1-dev but it is not going to be installed

    Reply
    • Guillaume Plessis

      Getting rid of this strange apache 2.2.15 dependency is the key to your problem.
      Use a decent APT-wrapper, such as dselect, aptitude or synaptic to resolve that conflict and to install apache2-prefork-dev

      Reply
  32. kevin

    aptitude instead of apt-get is almost a given these days, especially in situations such as these.

    Love your repositories Guillaume ! And I must say I’d also like to see nginx added! Its a chore to have to compile new updates each time. versions of apache and lighttpd would also be nice, but I don’t use them much personally.

    Reply
  33. Adam

    @ Guillaume it’s acutally building now once I used aptitude to get prefork-dev installed.

    Thanks for your help!

    Oh btw….when i upgrade to your repo to update php5.3.3 I had this initial error

    Unpacking replacement php-pear …
    dpkg: error processing /var/cache/apt/archives/php-pear_5.3.3-0.dotdeb.1_all.deb (–unpack):
    trying to overwrite `/usr/share/php/XML/Util.php’, which is also in package php-xml-util

    Uninstalling php-xml-util fixed it but should this happen?

    Reply
  34. Adam

    The build keeps failing here

    /bin/sed: can’t read /usr/lib/libgmodule-2.0.la: No such file or directory
    libtool: link: `/usr/lib/libgmodule-2.0.la’ is not a valid libtool archive
    make[1]: *** [ext/enchant/enchant.la] Error 1
    make[1]: Leaving directory `/root/php5-5.3.3/apache2-build’
    make: *** [build-apache2-stamp] Error 2

    Reply
  35. Adam

    I fixed the libgmodule installing a newer libglibmm but now I am really stuck on this one .

    make[1]: *** [ext/snmp/snmp.lo] Error 1
    make[1]: Leaving directory `/root/php5-5.3.3/apache2-build’
    make: *** [build-apache2-stamp] Error 2

    But slowly getting there :)

    Reply
  36. Adam

    The suhosin patch really causes a problem with my server. Is it possible for you to release a suhosin free build? I can’t get the build working myself and I tried going back to 5.2.6 but no luck with that either.

    Reply
  37. mYkon

    Hello there!
    I try to use php on cli…

    php -v
    PHP 5.3.3 (cli) (built: Nov 24 2010 15:15:38)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

    php -m
    Core
    ctype
    date

    PDO
    pdo_sqlite

    SQLite
    sqlite3

    But no mysql!

    If i try to load my /etc/php5/apache2/php.ini and add there the line:
    extension=mysql.so
    i’ve got an error:
    PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/mysql.so’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0

    When I use:
    extension=/usr/lib/php5/20090626+lfs/mysql.so

    This Error:

    PHP Warning: Cannot load module ‘mysql’ because required module ‘mysqlnd’ is not loaded in Unknown on line 0

    What should i try? phpinfo() with apache is everytrhing ok! (mysql, mysqli, …) loaded successfull

    Reply
  38. mYkon

    Found the problem :D

    which php is /usr/local/bin/php instead of /usr/bin/php

    have to change my alias :)

    Reply
  39. Gerhard

    I ran into some php package conflicts with debian squeeze and had to pin them to fix the problem. I didn’t find anything in the documentation about it so here is how I fixed it in case someone else has the same problem:

    I created /etc/apt/preferences.d/dotdeb
    containing:
    #——————————-
    Package: *
    Pin: origin php53.dotdeb.org
    Pin-Priority: 900

    Package: *
    Pin: origin packages.dotdeb.org
    Pin-Priority: 900
    #——————————-

    Then I ran apt-get update
    and no more package conflicts.

    Reply
  40. mathieux

    j’aimerai savoir si vous compter mettre le dépôt pour php5.3.4, et si oui auriez vous une date en tête ?

    Reply
  41. mathieux

    espérons une publications rapide du patch, une info sur la sorti de celui si ?
    une date même approximative ?

    Reply
  42. mathieux

    Suhosin Patch 0.9.10

    suhosin-patch-5.3.4 – 69683b97f1e8d8c7ad01eebcbb8a56fa – sig

    celui si ?

    Reply
    • Guillaume Plessis

      @mathieux : il est en effet disponible depuis hier soir. Encore un peu de travail de mon côté, un peu de temps CPU et le tout devrait être prêt pour la nouvelle année.

      Reply
  43. Guillaume Plessis

    @Andre : the Suhosin patch has been published last week. Then I built the PHP 5.3.4 packages after fixing some annoying issues. They’re now available on php53.dotdeb.org. I’m currently writing a note about it.

    Here are the news. Thanks for asking.

    Reply
  44. Enderson

    Hello!

    I’m trying to install PHP 5.3.3 packages for Ubuntu “Hardy”. Where I can find those packages?

    Reply

Trackbacks/Pingbacks

  1.  Install PHP-FPM 5.3.3 on Ubuntu 10.10 (Maverick Meerkat) | Constant Shift

Leave a Reply

  • (will not be published)


seven − 5 =