Posted by & filed under MySQL.

MySQL 5.1.54 packages are now available on Dotdeb in amd64/i386 flavours for Lenny and Squeeze.

As usual, please read the Changelog of this maintainance release before upgrading.

Now, about MySQL 5.5 (I was asked on Twitter or in the comments here), it will be available on Dotdeb as soon as it is in Debian Sid or experimental. Please be patient. If you don’t need some 5.5 specific features, such as semi-sync replication, and if you just need to boost your InnoDB performances, you really should take a look at your /etc/mysql/my.cnf file and enable the InnoDB plugin.

19 Responses to “MySQL 5.1.54 is available”

  1. bros

    Hello,

    i have add in /etc/apt/sources.list (debian lenny):

    deb http://packages.dotdeb.org stable all
    deb-src http://packages.dotdeb.org stable all

    and after upgrade, i hve this warning in phpmyadmin :

    “The version of your MySQL library (5.0.51a) differs from the version of your MySQL server (5.1.41). This may cause unpredictable behavior. “

    with :
    # dpkg -l | grep mysql : >> i see :

    ii libmysqlclient15off 5.0.51a-24+lenny2 MySQL database client library
    ii libmysqlclient16 5.1.41-1.dotdeb.1 MySQL database client library
    ii mysql-client-5.1 5.1.41-1.dotdeb.1 MySQL database client binaries
    ii mysql-common 5.1.41-1.dotdeb.1 MySQL database common files (e.g. /etc/mysql/my.cnf)
    ii mysql-server-5.1 5.1.41-1.dotdeb.1 MySQL database server binaries
    ii php5-mysql 5.2.11-0.dotdeb.1 MySQL module for php5

    how i can remove libmysqlclient15off ??

    Reply
    • Guillaume Plessis

      @bros : as said many times on this blog, don’t worry about that delta between the client side and the server side, it does not affect the PHP behaviour.

      The version of the MySQL client library PHP was built with is different to avoid some duplicate symbols and segfaults. Then, removing libmysqlclient15off is impossible.

      Reply
  2. Emil

    I hope it’s 5.5.6 – I’ll be looking forward – as I’m waiting for the ability to use variables limit values in stored procedures :)

    Reply
  3. Jan

    @ Guillame: I understand, thanks for reply anyway. I’ll keep an eye on dotdeb webpage.

    Reply
  4. Pedro

    Missing ha_innodb_plugin.so:

    [ERROR] Can’t open shared library ‘/usr/lib/mysql/plugin/ha_innodb_plugin.so’ (errno: 0 cannot open shared object file: No such file or directory)

    ls /usr/lib/mysql/plugin/
    ha_example.a ha_example.la ha_example.so ha_example.so.0 ha_example.so.0.0.0 ha_innodb_plugin.a ha_innodb_plugin.la

    Thank you

    Reply
  5. Pedro

    Sorry, I thought apt-get update & apt-get upgrade was enought.

    uname -a
    Linux www11 2.6.26-2-amd64 #1 SMP Wed Aug 19 22:33:18 UTC 2009 x86_64 GNU/Linux
    cat /etc/debian_version
    5.0.7

    dpkg -l mysql-server-5.1
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=================================-=================================-==================================================================================
    ii mysql-server-5.1 5.1.39-0.dotdeb.1 MySQL database server binaries

    ——————————

    deb http://packages.dotdeb.org stable all
    deb-src http://packages.dotdeb.org stable all
    deb …/debian/packages lenny main contrib non-free

    Reply
  6. Xavi

    Trying to update in a several Ubuntu 10.04 boxes, I get this error:

    The following packages have unmet dependencies:
    mysql-client-5.1: Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2ubuntu3 is installed.

    It seems that the requested library is not yet in the ubuntu repositories?? I’ts an alternate way to fix it?

    Reply

Leave a Reply

  • (will not be published)


5 × eight =