Posted by & filed under MySQL.

MySQL 5.1.57 packages are now available on Dotdeb :

  • for Debian 6.0 “Squeeze” and Debian 5.0 “Lenny”
  • for the amd64 and i386 architectures

The corresponding Pinba storage engine has also been rebuilt (Squeeze only).

And, as usual, please read the Changelog of this maintainance release before upgrading.

 

18 Responses to “MySQL 5.1.57 is out”

  1. edd

    Hi,
    before upgrade to php5.3.6 my /etc/php5/conf.d/memcache.ini was:

    extension=memcache.so
    memcache.dbpath=”/var/lib/memcache”
    memcache.maxreclevel=0
    memcache.maxfiles=0
    memcache.archivememlim=0
    memcache.maxfilesize=0
    memcache.maxratio=0
    session.save_handler=memcache
    session.save_path=”tcp://127.0.0.1:11211?persistent=1&weight=1&timeout=1&retry_interval=15″

    after upgrade:
    there is only one line:

    extension=memcache.so

    Looks like all settings in /etc/php5/conf.d/*.ini were reset…

    Reply
  2. Guillaume Plessis

    @edd : please post this as comment of the PHP 5.3.6 note.

    No configuration file should be overwritten by APT without confirmation. Anyway, backup file should be available in /etc/php5/conf.d/ with the dpkg-dist or dpkg-old extension.

    Reply
  3. Guillaume Plessis

    Hi,

    I know that the redis packages are a bit outdated. Nginx, php5-apc and php5-memcache as well. MySQL 5.5 (or Percona Server, or MariaDB, I have not made a decision), on its side, needs a complete rework of the packaging method and I have to handle safe data migrations and no interference with previous installation.

    Sorry guys, but Dotdeb is not “Packages on demand” and I need some free time to release new versions. I’m doing my best without a sponsor and without weighty donations.

    Thanks for your understanding.

    Reply
  4. Koen

    @Guillaume: tnx haha i’m still figuring out linux cause i’m trying to build a webserver on my xbox.. so forgive me hehe i’ll search some tuts on the manual install.

    Reply
  5. Pascal

    Hi!
    I use to use dotdeb, and want to install pinba, but I’ve nginx and ph5-fpm from dotdeb, and percona server 5.5 from percona repository
    Do you plan to support percona, or must I search how to install pinba on a percona server (I’m not a linux admin, I just search and install most interesting tool in its category)?
    Thanks for your site, really helpful.

    Reply
  6. Guillaume Plessis

    @Pascal : Percona is one of the fork I’d wish to maintain instead of MySQL for its 5.5 branch. But it requires a lot of work to repackage it in a pure Debian way.

    Waiting this, you can rebuild the pinba-storage-engine against percona-server. If you need some help, drop me a mail : gui at dotdeb dot org

    Reply
  7. Jaroslav

    Hello Guillaume Plessis,
    I wanted to thank you for such a wonderful services, so many new packagse are often updated – really very useful for LAMP server (maybe now LNMP since nginx support).

    But I wanted to ask one more question, do you plan on including the mysql 5.5 here? if so, maybe you have some estimates on this?

    I know you do all this for free… but I just wanted to ask

    thank you very much for an answer!

    Reply
  8. Guillaume Plessis

    @Jaroslav :MySQL 5.5 will be included in Dotdeb, but I don’t know which fork I’ll include :
    - I’m not at ease with Oracle’s MySQL 5.5, but the packaging method is about to be ready in a pure Debian or Ubuntu way. It should be easy to backport it for Dotdeb
    - Percona is a great fork (the one I’d prefer), has good performances and great tools/addons, but their packaging method is far from the best for Debian. I’ll need time and a lot of work to include it
    - MariaDB may have to much addons for its packaging process to be maintained by only one person (me).

    I think you’ll find MySQL 5.5 on Dotdeb this summer. Waiting this, you can switch to percona using their own binary Debian packages.

    Reply
  9. Kamalakar

    Hi,

    Can somebody help me in upgrading mysql version, from 5.1.43 to 5.1.57?
    What is the actual process of upgradation and what measures need to be taken before upgrading.

    Reply
  10. CP

    Hi,
    i want to install this new MySQL package.

    But i become a error with “apt-get dist-upgrade”:
    The following packages have been kept back:
    mysql-client (5.0.51a-24+lenny5 => 5.1.57-1~dotdeb.0)
    mysql-server (5.0.51a-24+lenny5 => 5.1.57-1~dotdeb.0)

    Can anyone help me?

    Reply

Leave a Reply

  • (will not be published)


3 − one =