Posted by & filed under Nginx, Passenger.

Nginx 1.0.11 packages are now available :

  • for both Debian 6.0 “Squeeze” and 5.0 “Lenny”
  • for both amd64 and i386 architectures

Here are the changes on the Dotdeb side :

  • nginx-extras now includes the Push stream module, instead of the bogus HTTP Push. Please review your configuration.
  • nginx-extras now uses Passenger 3.0.11
Please take a look at Nginx’ and Passenger’s Changelogs before upgrading.

 

18 Responses to “Nginx 1.0.11 : Passenger 3.0.11 and Push stream support”

  1. Didier Kryn

    I use nginx to serve static, php, and fastCGI to a small community. Use nginx because lightweight yet full-featured. I need Auth_Pam module to provide Kerberos auth. I had to recompile the debian package and must now lock versions, including passenger etc or recompile for every release.
    Why not include auth_pam in dotdeb’s nginx-extra? This modules brings into nginx all the flexibility of PAM.

    Reply
  2. Adam

    A little advise and word to the wise.

    Remember to comment out nginx repositories before attempting to use Dotbeb.org upgrade. lol

    Reply
  3. huglester

    Hello,

    is there any way that nginx/nginx-full to have HttpSecureLink module in it?

    I’ve seen it is in the nginx-extras from 1.0.6 version, but this one offers to uninstall nginx, nginx-full and install passenger, ruby etc…

    any way around it?

    Or I should somehow compile myself?

    Thanks

    Reply
  4. radar

    It seems, that nginx resets back permissions of /var/log/nginx.

    Before upgrade (I set these permissions manually):
    drwxr-xr-x 2 www-data adm 20480 20120123 00:16:52 /var/log/nginx/
    -rw-r–r– 1 www-data adm 2163320807 20120123 13:34:17 access.log

    After upgrade:
    drwxr-x— 2 www-data adm 20480 20120123 00:16:52 /var/log/nginx/
    -rw-r—– 1 www-data adm 2158881077 20120123 13:29:15 access.log

    Reply
  5. Jason

    Hi Guillaume

    Thanks for your hard work, I tried to install nginx-extras in ubuntu 11.10, but got an error saying “Could not apply changes! Fix broken packages first”

    Tried, the “Full” and “light” packages, both are fine.

    Can you help me fix the error, I need the HTTP push mod in the extra package.

    Thanks

    Reply
    • Guillaume Plessis

      @Jason : be sure to have all your package cleanly installed before installing new ones.
      About SSL, both nginx-full and nginx-extras have it included.
      Don’t forget that Dotdeb is made for Debian. Installing Dotdeb packages on Ubuntu may lead to some problems such as unresolved dependencies and so on.

      Reply
  6. Jason

    Also only the nginx-extras package has SSL support, so installing the full-package isn’t enough if we need SSL.

    Reply
  7. Jason

    @Guillaume

    According to the packages doc, only the extras package have the SSL mod listed under Optional HTTP Module, so a doc error “nginx-full” has SSL?

    Regarding to the broken package, I tried to install it in synaptics, right after I mark the “nginx-extras” for installation and I get the “broken package msg” without any further details.

    Can you help me track down what the problem is?

    Thanks

    Reply
  8. Guillaume Plessis

    @Jason : I’ve just updated the future packages’ documentation to include SSL in the corresponding nginx-* packages. In fact, full, extras and even light include the http_ssl module :

    https://github.com/gplessis/dotdeb-nginx/commit/696e341687b650bd9411550714448545249e8256

    About your broken package issue, please use a more verbose package manager, such as aptitude, dselect or directly apt-get to know what happens. I suspect a dependency problem. Don’t forget such issues might happen when you try to install Dotdeb package on anything else but stock Debian.

    Reply
  9. Jason

    @Guillaume, thanks for your help, looks like installing nginex-extras package results in the following errors:

    nginx-extras : Depends: libperl5.10 (>= 5.10.1) but it is not installable
    Depends: perlapi-5.10.1 but it is not installable
    Depends: passenger-common (>= 3.0.11) but it is not going to be installed
    Depends: passenger-common (< 3.0.12) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    Reply
  10. Drew Clardy

    Do any of these packages contain the stub status module? At one point, I saw that the light packages contained it, but I am not finding it there anymore.

    Reply
  11. VolCh

    In Ubuntu Server 11.10:
    nginx-extras :
    libperl5.10 (>= 5.10.1) = libperl5.12 (5.12.4-4)
    perlapi-5.10.1 = perlapi-5.12.4
    passenger-common :
    libev3 (>= 3.0) = libev4 (1:4.04-1)

    May be it will be helpfull…

    Reply

Leave a Reply

  • (will not be published)


seven − 6 =