Posted by & filed under Nginx.

Nginx 1.0.13 packages are now available for Debian 6.0 “Squeeze” on both amd64 and i386 architectures.

Here are the changes on the Dotdeb side :

  • nginx-upload-module has been added to nginx-extras
  • nginx-auth-pam has been added to nginx-extras and nginx-full. Closes #5.
  • http_secure_link_module has been added to nginx-full. Closes #3.
  • file-aio is now supported by all nginx flavors
  • ngxensite/ngxdissite scripts are available to enable/disable sites. Closes #4.

Please take a look at Nginx’ Changelog before upgrading.

9 Responses to “Nginx 1.0.13”

  1. Jools

    Thanks for the github setup. Was that officially announced btw ? I noticed it in a comment link I think.

    Reply
  2. Don

    Hi,

    Thanks for the update!

    Just wondering how I get around this error:

    Preparing to replace nginx 1.0.12-1~dotdeb.0 (using …/nginx_1.0.13-1_amd64.deb) …
    Unpacking replacement nginx …
    dpkg: error processing /var/cache/apt/archives/nginx_1.0.13-1_amd64.deb (–unpack):
    trying to overwrite ‘/etc/logrotate.d/nginx’, which is also in package nginx-common 1.0.13-1~dotdeb.0
    configured to not write apport reports
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/nginx_1.0.13-1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:

    I tried moving the logrotate.d file out temporarily but same error.

    Any help greatly appreciated!
    Thanks.

    Reply
  3. Don

    Hey Guillaume – Thanks for the quick reply!
    I did what you suggested and then did:

    aptitude install nginx-full

    That worked great..

    Cheers!

    Reply

Leave a Reply

  • (will not be published)


3 + six =