Posted by & filed under PHP.

Now that PHP 5.4.0 packages have been published as preview, issues have to be fixed. That’s why these packages have been updated with the following changes :

  • gzopen64() has been wrongly introduced on the i386 architecture, instead of the regular gzopen(). It is now fixed.
  • PCRE functions did not support Unicode. That’s ok now.
  • APC has been packaged as php5-apc against its svn/trunk version. It should now work well. Still waiting for an official release.
  • Xdebug should appear very soon is now available in 2.2.0RC1 version.
Thanks for your useful reports.

52 Responses to “Packages of PHP 5.4.0 have been updated”

  1. pross

    apc fails to install

    root@Debian-60-squeeze-64-minimal ~ # apt-get install php5-apc
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-apc : Depends: php5-common (= 5.4.0-1~dotdeb.0) but 5.4.0-1~dotdeb.1 is to be installed
    E: Broken packages

    Reply
  2. EPIC

    Oh! thanks for answer. And one more thing… SUHOSIN security patch has been applied?

    Reply
  3. phil

    tu recommande de ne pas l’installer actuellement sans suhosin sur un serveur en production ?

    Reply
  4. Guillaume Plessis

    @phil : Bonjour. C’est un long débat :) Perso, j’attendrai d’être sûr que toutes mes applications critiques sont bien compatibles avec PHP 5.4 avant de le déployer en production. Pour le reste, Suhosin n’est pas vital, il faudra juste faire attention lorsqu’il sera activé dans les futurs paquets.

    Reply
  5. phil

    je suis actuellement avec ton paquet 5.3.10 donc j’attendrais ton paquet 5.4 quand tu le sentira près espérons que cela ne tarde pas trop

    en tout cas bravo pour ton boulot

    Reply
  6. Adam H

    The following partially installed packages will be configured:
    php5-apc
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.
    Setting up php5-apc (5.4.0-1~dotdeb.1) …
    /var/lib/dpkg/info/php5-apc.postinst: line 22: local: can only be used in a function
    dpkg: error processing php5-apc (–configure):
    subprocess installed post-installation script returned error exit status 1
    Processing triggers for php5-fpm …
    configured to not write apport reports
    insserv: script vzquota: service vzreboot already provided!
    Restarting PHP5 FastCGI Process Manager: php5-fpm.
    Processing triggers for libapache2-mod-php5 …
    Reloading web server config: apache2.
    Errors were encountered while processing:
    php5-apc
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    Setting up php5-apc (5.4.0-1~dotdeb.1) …
    /var/lib/dpkg/info/php5-apc.postinst: line 22: local: can only be used in a function
    dpkg: error processing php5-apc (–configure):
    subprocess installed post-installation script returned error exit status 1
    Processing triggers for php5-fpm …
    insserv: script vzquota: service vzreboot already provided!
    Restarting PHP5 FastCGI Process Manager: php5-fpm.
    Processing triggers for libapache2-mod-php5 …
    Reloading web server config: apache2.
    Errors were encountered while processing:
    php5-apc

    Reply
  7. Nathan Green

    Thanks for updating the Packages of PHP 5.4.0. I was searching Google for this update version. Now it closes to my hand and I’m impressed to find this update version. Thanks :)

    Reply
  8. Guillaume Plessis

    @bRunO : does

    touch /etc/php5/mods-available/mysqlnd.ini
    touch /etc/php5/mods-available/xdebug.ini
    apt-get install –reinstall php5-xdebug php5-mysqlnd

    solve the problem?

    Reply
  9. Chris

    Just ugpraded one of my servers since I had to install an extension anyway, and it looks like php5-apc is still broke and requires 5.3.10

    Reply
  10. Chris

    @Guillaume I was already on 5.3.10 using just the regular repo since I’m on Debian 6. I needed to install php5-gd and it complained about not having the correct packages. I ran `aptitude update && aptitude upgrade` to upgrade everything, and that brought me to PHP 5.4.0-2. During the install it told me that php5-apc would be removed.

    I then installed php5-gd without any problems. I then tried to install php5-apc and it complained about unmet dependencies as it requires php5-common (=5.3.10-1~dotdeb.1).

    It looks like some packages need 5.4.10 (like php5-odbc) and some need 5.3.10 (like ssh2), but since 5.4. is just released I’m not 100% which modules are updated and which aren’t.

    I tried adding the php54 specific repos and I get the same thing.

    Reply
  11. Guillaume Plessis

    @Chris : is your sources.list using only squeeze entries?

    PHP 5.4.0-2 does not exist on Dotdeb. It exists in Debian testing or unstable. Could you please provide the output of “apt-cache policy php5 php5-apc”?

    Reply
  12. Ondřej Surý

    Many thanks for pulling stuff from Debian, but actually never reporting found bugs and patches back. It has been so helpful…

    Reply
  13. Rudi

    Is it possible to install php 5.4 and keep 5.3 on the same machine? I only can find Tutorials for 5.2 and 5.3, but if i do it this way my 5.3 will be overwritten

    Reply
  14. Guillaume Plessis

    @Rudi : it’s not possible with Debian or Dotdeb packages. Target binaries have the same name and dependencies prevents their installation on the same machine. Please consider using different servers/virtual machines.

    Reply
  15. Jools

    @rudi you could install one as a debian package and the other from source in another location however. I have done that before having php 5.3 on the system with debian packages and php 5.2 available in /opt for compatibility with some older code.

    Reply
  16. Paul Schwarz

    I’ve just installed php 5.4.7. PCRE appears not to be installed. pcretest gives “command not found”. I’m not sure where PCRE comes from so I don’t know how to install it. When I do, will PHP have PCRE UTF8 support according to you build configuration? Thanks.

    Reply
    • Guillaume Plessis

      @Paul Schwarz : PHP is installed by default with its bundled PCRE support. It is also not linked against your system’s libpcre.
      – if your want to test PHP’s pcre support, display a phpinfo()
      – if you want to test your system’s libpcre, install the libpcre3 package and launch pcretest
      Both are independent.

      Reply

Leave a Reply

  • (will not be published)


nine × 1 =