Posted by & filed under Nginx.

Dotdeb’s packages of Nginx 1.2.2 are now available for Debian 6.0 “Squeeze” (amd64/i386). They fix 11 bugs, enhance IPv6, and introduce weighted ip_hash and least_conn load-balancing to upstream servers. Please take a look at Nginx’ official Changelog before upgrading.

Please also note that :

  • Naxsi has been upgraded to the 0.47 version, and the new nginx-naxsi-ui package provides the autolearning daemon and the web user interface.
  • Nginx Cache Purge has been upgraded to the 1.6 version.
  • Passenger has been upgraded to the 3.0.13 version.

As usual, if you want to know which module has been included in each Nginx flavor, you just have to look at this document.

5 Responses to “Nginx 1.2.2”

  1. Terry R

    Hi,

    Thank you for yet another timely release.

    Saw in the comments to a previous nginx release announcement (1.2.0) that you were considering adding naxsi to another package(s). Is that still a consideration? If so, I’d vote for adding naxsi to nginx-extras.

    Thanks.

    Reply
  2. Jools

    Just wanted to say that I currently need nginx-extras + passenger – currently building my own based on nginx-extras. Some of the modules like flv etc are not that costly, so it might be worth having a build that has passenger + stuff like that. anyway, ill continue to build myself for now. thanks. I understand it is tricky to please everyone with the way nginx modules are built in.

    Reply
  3. BruceWayne

    I genuinely appreciate your work.

    However, could you possibly create a separate source for nginx?

    I would like php 5.4.4 for 64bit with your nginx-naxsi package.

    But i would like your naxsi package to have a few more modules.

    Thank you,

    Reply

Leave a Reply

  • (will not be published)


seven × = 49