Posted by & filed under MySQL.

The packages of MySQL 5.5.27 are now available for Debian 6.0 “Squeeze” on both amd64 and i386 architectures. They fixes some InnoDB- and replication-related issues.

As usual, please read carefully the full Changelog before upgrading.

10 Responses to “MySQL 5.5.27”

  1. Hugo

    When upgrading from mysql-server-5.5.23-1 I got the following error:

    Stopping MySQL database server: mysqld.
    this is very strange! see /tmp/mysql-symlink-restore-vWo0y0/README…
    mv: no se puede mover «/var/lib/mysql» a «/tmp/mysql-symlink-restore-vWo0y0/mysql»: Dispositivo o recurso ocupado
    dpkg: error al procesar mysql-server-5.5 (–configure):
    el subproceso instalado el script post-installation devolvió el código de salida de error 1

    Initially I was having another error because my datadir is on /home/mysql and I had a symlink to /var/lib/mysql. After searching for the error I found this comment http://www.dotdeb.org/2009/11/27/mysql-5-1-41-is-available-for-debian-lenny-and-etch/#comment-1788 sugesting to use a mount point, now I got the error shown above.

  2. Michael Krieg

    After upgrading from 5.5.25a the mysqld did not came up again. The problem is caused by wrong file permissions of the binlogs – suddenly the binlogs belonging root:root (0660).

    Quick fix was a chown – but I guess this is not the way it should be.

    Any bug in the package files/scripts?

    Regards,
    Michael

  3. Michael Krieg

    UPDATE:
    if you have your own my.cnf (as in our case here) – make sure you provide a “user = mysql” setting in the [mysqld] section. Without it, files will be created as root. (doh)

  4. Hugo

    Please, I need help with the error posted above.

    I managed to get mysql running and noticed that it’s running on version 5.5.27-1 but as the post-int script finished with errors apt thinks things are broken and I can’t use it to install new software.

    • Guillaume Plessis

      @Roland Franssen : Dotdeb is built for Debian stable. Debian stable contains libmysqlclient16. If you use another distribution (at your own risk), you may encounter dependency issues.

      In your case, prefer installing php5-mysqlnd instead of php5-mysql, it’s bound to the bundled MySQL native driver instead of libmysqlclient16.

  5. Roland Franssen

    So i need php5-mysqlnd for PHP 5.4 (squeeze-php54)? it’s weird because php5-mysql (5.3.10ubunutu3.4) does depends on libmysqlclient18… :S

    • Guillaume Plessis

      @Roland Franssen : Yes, as said before, installing php5-mysqlnd instead of php5-mysql will solve your dependency issue.

      FYI, php5-mysql from one distribution depends from the current libmysqlclient from the distribution. In Debian stable, it’s libmysqlclient16, on Ubuntu, it’s libmysqlclient18. No big deal.