Posted by & filed under PHP.

On august 16th 2012, the PHP group has released PHP 5.4.6, that brings 20 minor bug fixes.

The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures. As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

36 Responses to “PHP 5.4.6”

  1. ju1ius

    Hi, in latest update, the php5-xdebug (v5.4.6) fails to configure due to an error in the postinst script.
    Here’s the fix:
    in /var/lib/dpkg/info/php5-xdebug.postinst on lines 22 && 23:
    replace these lines:

    local md5sum=”$(md5sum ${inidir}/${inifile}.dpkg-new | sed -e ‘s/ .*//’)”
    local old_md5sum=”$(md5sum ${inidir}/${inifile} | sed -e ‘s/ .*//’)”
    by:

    md5sum=”$(md5sum ${inidir}/${inifile}.dpkg-new | sed -e ‘s/ .*//’)”
    old_md5sum=”$(md5sum ${inidir}/${inifile} | sed -e ‘s/ .*//’)”

    Reply
  2. tgabi333

    I have a problem with memcached extension:

    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20100525+lfs/memcached.so’ – /usr/lib/php5/20100525+lfs/memcached.so: undefined symbol: memcached_server_minor_version in Unknown on line 0

    Reply
  3. tgabi333

    After “apt-get update && apt-get install –reinstall php5-memcached”

    another problem appeared:
    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20100525+lfs/memcached.so’ – libmemcached.so.11: cannot open shared object file: No such file or directory in Unknown on line 0

    Reply
  4. solitary1510

    Package: libmemcached10
    Status: install ok installed
    Priority: optional
    Section: libs
    Installed-Size: 264
    Maintainer: Guillaume Plessis
    Architecture: amd64
    Source: libmemcached
    Version: 1.0.10-1~dotdeb.0
    Depends: libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.1.1)

    But still have problem with memcached dynamic library

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/memcached.so' - libmemcached.so.10: cannot open shared object file: No such file or directory in Unknown on line 0

    Reply
  5. solitary1510

    Hi. Disturb again. I use NGINX as reserve proxy for Apache2. I use WordPress + W3 Total Cache and use APC + Memcached for Cache. 2 days age, before I’m release new version, everything OK. When I’m upgrade, first issue that can’t load dynamic library. And I fixed with upgrade new version of libmemcached and reinstall php5-memcached (thanks for Guillaume Plessis). Everything may be OK but today I check my site and get error 502 Bad Gateway nginx. Try restart apache2, nginx and memcached service. Well, It’s OK but after little minutes. Error 502 Bad Gateway nginx appear. I don’t know what exactly happened. I’m just beginner use VPS. Thanks for help.

    Sorry for my bad English ^^!

    Reply
  6. Alexander

    @solitary1510 It’s because of apc, uninstall php5-apc and install pecl apc, it will give you some error in the console every time you restart server but server will work. That bug is already submitted to the php bugtracker.

    Reply
  7. Anonymous

    Hi Guillaume,

    thanks for your work. I am using the dotdeb mirrors since years on my debian stable servers.

    One question: Currently Debian wheezy (testing) is not supported by dotdeb, although it is already frozen and the next stable release. When wheezy is stable, how long will it take for dotdeb to support it? :-)

    Thanks for your answer

    Reply
  8. Chris Olbekson

    Getting segfaults from php5-apc after upgrading to 5.4.6
    Aug 22 10:43:59 deathstar kernel: php5-fpm[10385]: segfault at 100000018 ip 00000000006d0128 sp 00007fffb745da10 error 4 in php5-fpm[400000+762000]

    Same issues as solitary1510 except running Nginx

    Reply
  9. Chris Olbekson

    Guillaume that would be a good idea. Comment probably aren’t the most efficient way for you to keep track of bugs. Thanks for all the work you do on the packages. I certainly appreciate your efforts.

    Reply
  10. Guillaume Plessis

    php5-apc for both PHP 5.3 and PHP 5.4 brings APC 3.1.12, the most recent version. I’ll take a further look at the PHP bugtracker about it. Don’t hesitate to provide a backtrace of your crashes (after having installed php5-dbg)

    Reply
    • Chris Olbekson

      I uninstalled the pecl apc version that I replaced php5-apc with via:

      pecl uninstall apc

      I then ran apt-get install php5-apc

      For me your bug fix works and I am no longer having any segfaults or Nginx bad gateway errors. Thanks for you timely attention to this

      Reply
  11. Andrey Polyakov

    When i’m install php5-redis im got this error

    The following packages have unmet dependencies:
    php5-redis : Depends: php5-common (= 5.3.16-1~dotdeb.0) but 5.4.4-6 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Please fix it.

    Reply
  12. Veer

    After following the instructions I am getting this error:
    php5-imagick : Depends: libmagickcore3 (>= 8:6.6.0.4) but it is not installable
    Depends: libmagickwand3 (>= 8:6.6.0.4) but it is not installable
    php5-mysql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable
    php5-suhosin : Depends: php5-common (= 5.3.16-1~dotdeb.0) but 5.4.6-1~dotdeb.0 is to be installed

    Reply
    • Guillaume Plessis

      @Veer : first, uninstall php5-suhosin, it’s not available with PHP 5.4. And be sure to use a Debian Squeeze (you can add the appropriate lines in your sources.list) to satisfy the dependencies

      Reply
  13. Pether

    @Guillaume Plessis
    I did what was in that link you posted, added all the lines, ran the commands(though it said sudo was an unknown command).
    But it still says it has unmet dependencies.

    Reply

Leave a Reply

  • (will not be published)


× two = 2