Posted by & filed under PHP.

On february 21st 2013, the PHP group has released PHP 5.4.12.

This releases fix about 10 bugs. All users of PHP are encouraged to upgrade to PHP 5.4.12

The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures. As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

Note : PHP 5.3.22 packages will be available at the end of this week.

19 Responses to “PHP 5.4.12”

  1. Michael Meinecke

    Thank you very much for the update! I wanted to update by aptitude but after upgrade command i get the following and I am not sure what to do – the last php updates went smooth without any problems.

    The following packages will be upgraded:

    php5-imagick{b}

    1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 118 kB of archives. After unpacking 0 B will be used.
    The following packages have unmet dependencies:

    php5-imagick: Depends: php5-common (= 5.4.12-1~dotdeb.1) but 5.4.11-1~dotdeb.0 is installed.

    The following actions will resolve these dependencies:

    Remove the following packages:
    1) php5-imagick

    Accept this solution? [Y/n/q/?]

    So removing imagick will fix it (?) Thanks!

    Reply
  2. Niels

    Hi,

    Just updated – still having some issues with APC, see error:

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-apc : Depends: php5-common (= 5.4.11-1~dotdeb.0) but 5.4.12-1~dotdeb.1 is to be installed
    E: Broken packages

    Could you help me with this? APC is not working/installing at all now

    Reply
  3. withgod

    thanks great work!

    Here is an installing issue report. Please check the following and open php5-pecl source to public.

    While installing the “php5-memcached”, there is an issue of a php5-memcached dependency.
    ( https://gist.github.com/withgod/5087534 )

    The problem might be the “php-memcached” dependency with “libmemcached10″, however this libmemcached10 has a dependency with the “wheezy/sid” ONLY!

    ( http://packages.debian.org/search?suite=all&searchon=names&keywords=libmemcached10 )

    Although I will report to this issue and will try to build via “apt-get source libmemcached10″ to fix this bug, “php5-pecl” source could not be installed. Therefore could you open this php5-pecl source to public for not having this kind of issue again.
    ( http://packages.dotdeb.org/dists/squeeze-php54/php5-pecl/ )

    Reply
  4. Zippo

    Hello, could someone help me? Thanks in advance :)

    Removing php-apc …
    dpkg: error processing php-apc (–remove):
    unable to create updated files list file for package php-apc: No such file or directory
    Errors were encountered while processing:
    php-apc
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Reply
  5. nfo

    for me it looks like the new “Session Upload Progress” feature does not work ?! can anyone confirm ?!

    Reply

Leave a Reply

  • (will not be published)


2 + = three