Posted by & filed under PHP.

On July 4th 2013, the PHP group has released PHP 5.4.17.

About 20 bugs were fixed. All users of PHP are encouraged to upgrade to this release.

The corresponding packages are now available on Dotdeb :

  • for Debian 7.0 “Wheezy” and Debian 6.0 “Squeeze”,
  • on both amd64 and i386 architectures.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

And if you like Dotdeb, feel free to show your support.

17 Responses to “PHP 5.4.17, for Wheezy and Squeeze”

  1. lbw99

    “Added Zend Opcache extension and enable building it by default.” …

    when does it come to dotdeb version !? :)

    Reply
  2. Michel

    I am gettting these errors:

    Reading package lists…
    Building dependency tree…
    Reading state information…
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5 : Depends: libapache2-mod-php5 (>= 5.4.17-1~dotdeb.1) but it is not going to be installed or
    libapache2-mod-php5filter (>= 5.4.17-1~dotdeb.1) but it is not going to be installed or
    php5-cgi (>= 5.4.17-1~dotdeb.1) but it is not going to be installed or
    php5-fpm (>= 5.4.17-1~dotdeb.1) but it is not going to be installed
    Depends: php5-common (>= 5.4.17-1~dotdeb.1) but it is not going to be installed
    E: Broken packages

    Any ideas ?

    Reply
  3. Toni

    Hello Guillaume,
    are you going to continue to provide builds of PHP 5.3, at least for Squeeze, as long as PHP itself supports it?

    Reply
  4. mojiz

    Hi
    Could you please add php5-apcu to dotdeb? I think many like just using the caching and use zend optimizer for opcode caching.

    Regards

    Reply
  5. Brian

    Hi, i Have similar errors on Debian 7 (Wheezy) i Have installed php 55, and i want install with command

    ~# apt-get build-dep php5
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following packages have unmet dependencies:
    libpq-dev : Depends: libpq5 (= 9.1.9-1) but 9.3.0-2.pgdg60+1 is to be installed
    E: Build-dependencies for php5 could not be satisfied.

    ~# apt-get build-dep php5 && apt-get source -b php5
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following packages have unmet dependencies:
    libpq-dev : Depends: libpq5 (= 9.1.9-1) but 9.3.0-2.pgdg60+1 is to be installed
    E: Build-dependencies for php5 could not be satisfied.

    ANY IDEAS TO SOLVE THIS?

    Reply
    • Guillaume Plessis

      @Brian : you’re using PostgreSQL packages from postgresql.org, that are more recent that Debian’s. If you want to rebuild PHP 5.5 (why?), you’ll have to follow these steps :

      apt-get source php5
      cd php5-5.5.4
      vi debian/control

      Then replace libpq5 (= 9.1.9-1) with only libpq5 in the Build-depend section.

      dpkg-checkbuilddeps

      Install all the listed build-dependencies

      dpkg-build-package

      Good luck.

      Reply

Leave a Reply

  • (will not be published)


9 × one =