Posted by & filed under PHP.

On July 24th 2014, the PHP group has released PHP 5.4.31. Over 10 bugs were fixed in this release. All PHP 5.4 users are encouraged to upgrade to this version.

The corresponding packages are now available on Dotdeb :

  • for Debian 7 “Wheezy” and Debian 6 “Squeeze”,
  • on both amd64 and i386 architectures.

The following modules have been packaged too :

  • APC 3.1.13
  • apcu 4.0.6
  • ffmpeg 0.6.0 (Squeeze only)
  • gearman 0.8.3
  • geoip 1.0.8
  • imagick 3.1.2
  • memcache 3.0.8
  • memcached 2.2.0
  • mongo 1.5.4
  • pecl_http 1.7.6
  • pinba (master)
  • redis 2.2.5
  • spplus 1.1
  • ssh2 0.12
  • xcache 3.1.0
  • xdebug 2.2.5
  • xhprof 0.9.4
  • zendopcache 7.0.3

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

7 Responses to “PHP 5.4.31, for Wheezy and Squeeze”

  1. Enrico

    After the upgrade, my log is full of the error “Warning: simplexml_load_file(): I/O warning : failed to load external entity” and all xml files was suddenly invalid.

    Modifing the PHP in this way
    from
    // $xml = simplexml_load_file($path);
    to
    $xml = simplexml_load_string(file_get_contents($path));
    all is ok.

    I have upgraded another similar system (Debian 6.0 + dotdeb squeeze-php54 ) without problems so probably is a configuration problem, but i tested all the obvious thing ( filename, owner, right ) and not so obvious ( apache ssl config, removed php5-xmlrpc, pecl ) but i have no result.

    Could someone give me a clue ?

    Thank you !

    • Enrico

      Sorry, a typo. The code was
      from
      $xml = simplexml_load_file($path);
      to
      $xml = simplexml_load_string(file_get_contents($path));

      without //

  2. Enrico

    Thank you for the hint, Guillaume !
    Googling on libxml_disable_entity_loader take me to a fast solution.

    Cheerfuly,
    Enrico

  3. Pawel

    I’m still getting library mismatch error:

    Code:

    ~$ php m.php
    PHP Warning: mysqli::mysqli(): Headers and client library minor version mismatch. Headers:50538 Library:50619 in /home/user/m.php on line 1

    $ dpkg -l | grep -i mysql
    ii libmysqlclient18:amd64 5.6.19-1~dotdeb.1 amd64 MySQL database client library
    ii mysql-common 5.6.19-1~dotdeb.1 all MySQL database common files, e.g. /etc/mysql/my.cnf
    ii php5-mysql 5.4.31-1~dotdeb.1 amd64 MySQL module for php5

    What went wrong ?