PHP 5.4.3 and PHP 5.3.13 have been released by the PHP development team to fix some critical security issues :
- Source code disclosure with a trivial request (CVE-2012-1823 and CVE-2012-2311) - PHP 5.4 and 5.3 are vulnerable
- buffer overflow in apache_request_headers() (CVE-2012-2329) - only PHP 5.4 is vulnerable.
If you’re using the CGI flavor of PHP, upgrading is highly recommended. You can see more info on PHP’s website and on this useful blog post.
Packages of PHP 5.4.3 and PHP 5.3.13 are available for Debian 6.0 “Squeeze” on both amd64 and i386 architectures. Please also note that they fix the error logging features of PHP-FPM.
As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.
Merci Guillaume !
A propos d’apache2, pourquoi ne pas essayer de proposer la version 2.4 sur dotdeb ? PHP 5.4 + Apache 2.4 seraient fantastiques pour les performances et la sécurité.
Hey Guys, thanks for the great work.
Suhosin still isn’t installable btw.
Depends: php5-common (= 5.3.13-1
dotdeb.0) but 5.4.3-1dotdeb.0 is to be installed@x-f : interesting too : https://github.com/stefanesser/suhosin/issues/5
Suhosin (the extension, not the patch) builds, but it is not fully functional and stable
There will be a workarround to install php5-suhosin under PHP 5.4 on wheezy.
http://www.php-security.net/archives/8-Suhosin-0.9.34-dev-installation-howto.html
From Christopher Kunz at php-security.net.
It seems the source packages of php-pecl aren’t available. Is there a legal (or other) reason for this?
Thanks for the great work you guys do!
Thank you for the update.
A heads up for anyone using APC - you’ll need to upgrade to 3.1.10 - otherwise apache2 will crash php when re-starting.
After upgrading to the latest dotdeb php 5.4, I encountered some debian squeeze server errors, which I have addressed in a post at: http://drupal.org/node/1578840
I wish I would have read this BEFORE upgrading, but it is still very helpful info after the upgrade to PHP 5.4, and should save many people lots of time.
Thanks for the upgrade, it’s great to be on the right path to PHP 6.
@webmaster eddie : thanks for this useful report.
Once again, upgrading to a new major version of PHP should b done with great care, after reading the change logs and after ensuring that all the applications are fully compatible.
That’s also why I’ve published PHP 5.4 in squeeze-php54 instead of squeeze.
What’s up for mod_APC ? he work now whith PHP 5.4.x ?
Pour ce qui est d’Apache, la version mpm event avec PHP-FPM chargé par mod_proxy_fcgi semble quand même super intéressante.
@Nico : APC 3.1.10 is compatible with PHP 5.4 (see its changelog). The package is available on Dotdeb squeeze-php54. Just note that its version number has not been incremented in the source, it’s still displayed as 3.1.9 in phpinfo().
I have no plan for Apache 2.4 without a major sponsor. If you’re looking for an event-driven web server, Nginx should do the trick.
I am running dotdebs php 5.3.13 packages with APC, but it comes with APC 3.1.3p.
What would be the best method to upgrade APC to 3.1.9 or 3.1.10?
@midal : apt-get install php5-apc
PHP 3.1.9 will be displayed in phpinfo() but in fact it’s 3.1.10 (version number hasn’t been raised in the source code)
Thx for the fast reply, Guillaume! I already tried this before, but get this:
error processing /var/cache/apt/archives/php5-apc_5.3.13-1
dotdeb.0_amd64.deb (–unpack): trying to overwrite ‘/etc/php5/conf.d/apc.ini’, which is also in package php-apc 3.1.3p1-2 configured to not write apport reports Errors were encountered while processing: /var/cache/apt/archives/php5-apc_5.3.13-1dotdeb.0_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)we use these sources:
deb http://packages.dotdeb.org stable all deb-src http://packages.dotdeb.org stable all
(its a debian squeeze)
Could you give me some hints about that? Thanks a lot in advance!
@LYP-Blog : you can do apt-pinning :
http://wiki.debian.org/AptPreferences http://jaqque.sbih.org/kplug/apt-pinning.html
FYI MySQL 5.1 will be removed from Dotdeb in the next few days (recent releases are maintained by debian-security). About MySQL 5.5, you can install mysql-server-5.1 from Debian, and skip mysql-server and mysql-server-5.5 from Dotdeb
Update your sources.list it’s squeeze-php54, not squeeze-54
/instructions/