Posted by & filed under Nginx.

Dotdeb’s packages of Nginx 1.2.6 are now available for Debian 6.0 “Squeeze” (amd64/i386) with the following changes (see the Changelog) :

  • Feature: the $request_time and $msec variables can now be used not only in the “log_format” directive.
  • Bugfix: cache manager and cache loader processes might not be able to start if more than 512 listen sockets were used.
  • Bugfix: in the ngx_http_dav_module.

As usual, if you want to know which module has been included in each Nginx flavor, you just have to look at this document.

20 Responses to “Nginx 1.2.6”

  1. Steven

    Thanks again Guillaume!

    Unfortunately, somehow my nginx is not updating… although with apt-get install nginx I ges this:
    Preparing to replace nginx 1.2.5-1~dotdeb.0 (using …/nginx_1.2.6-1~dotdeb.0_all.deb) …
    Unpacking replacement nginx …
    Setting up nginx (1.2.6-1~dotdeb.0) …

    After doing this, nginx -v still returns 1.2.0 🙁 Any ideas?

  2. Steven

    Indeed and thanks Guillaume, my thoughts as well, but I installed nginx initially from dotdeb, and which nginx indeed returns /usr/sbin/nginx. I have no clue what is going on.

  3. Steven

    Ok I found the issue.
    “dpkg -l” showed that nginx was indeed 1.2.6, but the nginx-common and nginx-full packages were still at 1.2.0 (are they not linked?)
    So, I did “apt-get install nginx-common” and all is updated now!

  4. Tero

    nginx-extras package does not install on Ubuntu 12.04.1 LTS. There are two unmet dependencies:

    Depends: perlapi-5.10.1, but it is not installable
    Depends: libperl5.10 (>= 5.10.1) but it is not installable

    Ubuntu’s own nginx-extras package depends on perlapi-5.14.2 and libperl5.14 (>= 5.14.2)

    Can this issue be resolved by relaxing the version requirements of the nginx-extras package in dotdeb?

  5. Guillaume Plessis

    @Tero : Dotdeb is built for Debian stable. If you want to use it on Ubuntu (at your own risk), you’d certainly want to add Debian Squeeze’s related entries in your sources.list to staisfy the dependencies.

  6. Damien

    For me Nginx is also not upgrading. I try update and upgrade but still stuck on version 1.2.4. This can be seen by typing nginx -v and dpkg -l. The initial install was done with dotdeb as adding the dotdeb PPA was the first thing I did after the new server was created.

    I also tried upgrading just nginx-common and nginx-full as Steven has mentioned.

    Any ideas?

  7. Yakov

    I was wondering, are you planning on adding to your nginx builds support for SPDY? There’s an official patch for this: nginx.org/patches/spdy/

    It’ll will be great if you implement this in future versions. Thanks for your work!

  8. Guillaume Plessis

    @Yakov : I already know that this patch exists. I’ll include it in the Dotdeb package at latest when it’s included in the stable release.