On June 20th 2013, the PHP group has released the first stable version of PHP 5.5.
The key features of PHP 5.5.0 include:
- Added generators and coroutines.
- Added “finally” keyword.
- Added simplified password hashing API.
- Added support for constant array/string dereferencing.
- Added Class Name Resolution As Scalar Via “class” Keyword
- Added support for using empty() on the result of function calls and other expressions
- Added support for non-scalar Iterator keys in foreach
- Added support for list in foreach
- Added Zend Opcache extension and enable building it by default.
- The GD library has been upgraded to version 2.1 adding new functions and improve existing functionality.
- A lot more improvements and fixes
Changes that affect compatibility:
- PHP logo GUIDs have been removed
- Windows XP and 2003 support dropped
- Case insensitivity is no longer locale specific. All case insensitive matching for function, class and constant names is now performed in a locale independent manner according to ASCII rules
I’m proud to announce that the corresponding packages are now available on Dotdeb for Debian 7.0 “Wheezy”, on both amd64 and i386 architectures.
To upgrade your Wheezy boxes to PHP 5.5.0, just add these two lines to your sources.list :
deb http://packages.dotdeb.org wheezy-php55 all
deb-src http://packages.dotdeb.org wheezy-php55 all
Please note that :
php5-apcis not available for PHP 5.5 yet. Instead, PHP OPcache (the open-sourced Zend Optimizer+) has been included and activated by default inphp5-common. And if you need a user cache, please installphp5-apcu.php5-xcacheis missing too. Don’t upgrade if you need it.- PHP 5.4 will still be considered as default branch on Debian 7.0
- PHP 5.5 won’t be packaged for Debian 6.0 “Squeeze”. Upgrade to Wheezy instead.
Please read the Changelog and the migration guide (be aware of the backward incompatible changes) before upgrading.
Last but not least, if you like Dotdeb, feel free to show your support.
Works fine! Great Job! Thank you!
By the way: can dotdeb host the packages for MariaDB? :-)
Hello I add repo to my sourcelist and run aptitude update – but I am still on 5.4. My linux is: Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.41-2+deb7u2
Where can be problem?
re php5-geoip, this is what aptitude gives me when I try to do a dist-upgrade:
The following packages have unmet dependencies: php5-apc : Depends: phpapi-20100525+lfs which is a virtual package. Depends: php5-common (= 5.4.16-1
dotdeb.1) but 5.5.0-1dotdeb.1 is to be installed. php5-geoip : Depends: phpapi-20100525+lfs which is a virtual package. The following actions will resolve these dependencies:Accept this solution? [Y/n/q/?]
Look like php5-fpm is broken.
Настраивается пакет php5-fpm (5.5.0-1~dotdeb.1) … invoke-rc.d: initscript php5-fpm, action “start” failed. dpkg: error processing php5-fpm (–configure):
@John : why is what? not in the php5-gd package?
http://packages.dotdeb.org/dists/wheezy-php55/php5/binary-amd64/
updated to php5.5 and the init.d startscript for php5-fpm is broken:
/etc/init.d/php5-fpm: 37: /etc/init.d/php5-fpm: init_is_upstart: not found
Any idea what went wrong?
If you have problems with upstart check out dmesg: sudo dmesg | grep php
If it says something regarding php5-fpm pre-start process terminated with status 1 Check out the fie /etc/init/php5-fpm.conf to see what is the prestart process. Perhaps run it manually from the console and check for errors.
I had an error saying failed to open error_log (/var/log/php5-fpm.log): Permission denied (13)
You might have another case. Check it out.
Hi (i’m french),
I’ve this error next update :
root# php -v bash: /usr/bin/php: Aucun fichier ou dossier de ce type
How can I fix this ?
All my dependances of php has been removed. I did this : root# apt-get dist-upgrade Lecture des listes de paquets… Fait Construction de l’arbre des dépendances Lecture des informations d’état… Fait Calcul de la mise à jour… Fait Les paquets suivants seront ENLEVÃS : libapache2-mod-php5 php5 php5-cli php5-fpm php5-mcrypt php5-mysql Les NOUVEAUX paquets suivants seront installés : libltdl7 libonig2 libqdbm14 Les paquets suivants seront mis à jour : php5-common 1 mis à jour, 3 nouvellement installés, 6 à enlever et 0 non mis à jour. Il est nécessaire de prendre 1 011 ko dans les archives. Après cette opération, 24,2 Mo d’espace disque seront libérés. Souhaitez-vous continuer [O/n] ? Réception de : 1 http://packages.dotdeb.org/ wheezy-php55/all php5-common amd64 5.5.1-1
dotdeb.1 [682 kB] Réception de : 2 http://ftp.free.fr/mirrors/ftp.ubuntu.com/ubuntu/ precise/main libltdl7 amd64 2.4.2-1ubuntu1 [37,6 kB] Réception de : 3 http://ftp.free.fr/mirrors/ftp.ubuntu.com/ubuntu/ precise/universe libonig2 amd64 5.9.1-1 [147 kB] Réception de : 4 http://ftp.free.fr/mirrors/ftp.ubuntu.com/ubuntu/ precise/universe libqdbm14 amd64 1.8.78-1build2 [144 kB] 1 011 ko réceptionnés en 0s (6 397 ko/s) (Lecture de la base de données… 55450 fichiers et répertoires déjà installés.) Suppression de php5 … Suppression de libapache2-mod-php5 … Module php5 disabled. To activate the new configuration, you need to run: service apache2 restart Suppression de php5-cli … Suppression de php5-mysql … Suppression de php5-mcrypt … Suppression de php5-fpm … Traitement des actions différées (« triggers ») pour « man-db »… Traitement des actions différées (« triggers ») pour « ureadahead »… Sélection du paquet libltdl7 précédemment désélectionné. (Lecture de la base de données… 55427 fichiers et répertoires déjà installés.) Dépaquetage de libltdl7 (à partir de …/libltdl7_2.4.2-1ubuntu1_amd64.deb) … Préparation du remplacement de php5-common 5.3.10-1ubuntu3.7 (en utilisant …/php5-common_5.5.1-1dotdeb.1_amd64.deb) … Dépaquetage de la mise à jour de php5-common … Sélection du paquet libonig2 précédemment désélectionné. Dépaquetage de libonig2 (à partir de …/libonig2_5.9.1-1_amd64.deb) … Sélection du paquet libqdbm14 précédemment désélectionné. Dépaquetage de libqdbm14 (à partir de …/libqdbm14_1.8.78-1build2_amd64.deb) … Paramétrage de libltdl7 (2.4.2-1ubuntu1) … Paramétrage de php5-common (5.5.1-1~dotdeb.1) … Installation de la nouvelle version du fichier de configuration /etc/cron.d/php5 …Creating config file /etc/php5/mods-available/pdo.ini with new version
Creating config file /etc/php5/mods-available/opcache.ini with new version Paramétrage de libonig2 (5.9.1-1) … Paramétrage de libqdbm14 (1.8.78-1build2) … Traitement des actions différées (« triggers ») pour « libc-bin »… ldconfig deferred processing now taking place
I have similar problem with php5-fpm.
It is on debian7. status/start/stop does not give anything… I think it is something to do with upstart, but can’t figure out.
any ideas anyone?:)
@Etienne @Helias @Guillaume Plessis
Looks like some installations of Debian 7 Wheezy installs Apache 2 with apache2-mpm-worker package by default. With this package, the build of php provided by dotdeb doesn’t work out of the box, and gives that must recompile error. If instead, you install apache2-mpm-prefork, it will work.
Hope this helps, Andy
To remove the error :
[crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe
on debian 7 :
apt-get remove apache2-mpm-worker apt-get apache2 apache2-mpm-prefork (normally already install)
E: Unable to locate package php5
Can anyone help???