Posted by & filed under PHP.

On November 26th 2015, the PHP group published the eighth release candidate of the upcoming new major branch, PHP 7 :

PHP 7.0.0 RC 8 contains fixes for 11 reported bugs.
(…)
This release candidate prepares the short jump to the RTM. If no major issues appear, the 7.0.0 general availability (GA) release will be brought out on December 3rd. You can also read the full list of planned releases on our wiki.

Packages of PHP 7.0-RC8 are now available for Debian 8 “Jessie” on amd64 and i386 architectures.

Please note that starting this release candidate – and compared to previous ones, core PHP extensions are now named php7.0-something instead of php-something, to reflect what’s happening in Debian experimental. Please make sure that you uninstall obsolete packages before upgrading.

Disclaimer : THIS IS STILL A DEVELOPMENT PREVIEW (from a PHP upstream and from a Dotdeb/Debian packaging perspectives) – DO NOT USE IT IN PRODUCTION!

  • Don’t upgrade any staging/production/critical environments yet, and use these RC packages at your own risk!
  • Make sure that you understand the PHP/Debian/Dotdeb changes and that you don’t need any of the missing features/packages
  • Your feedbacks are always welcome. Just make sure they are useful.

These packages have been published on the main repository for Jessie. So to test PHP 7.0-RC8 , just follow the instructions.

And as usual, feel free to show your support

22 Responses to “PHP 7.0-RC8 for Jessie”

  1. CloneVince

    Bonjour Guillaume,

    Merci pour tout le boulot accompli 馃檪
    Je suis pass茅 脿 PHP7 RC8 mais je vois que le paquet OPCACHE est toujours en RC7 et n’est pas propos茅 sous la forme de php7.0-opcache
    Est-ce juste le temps que le repo se mette 脿 jour ?

    Merci encore.

    Vincent

  2. grzegorz

    I cant use this version with php5 is conflict:

    Nast臋puj膮ce pakiety maj膮 niespe艂nione zale偶no艣ci:
    php7.0-fpm : Wymaga: php7.0-cli ale nie zostanie zainstalowany
    Wymaga: php7.0-common (= 7.0.0~rc8-1~dotdeb+8.1) ale nie zostanie zainstalowany
    E: Nie uda艂o si臋 naprawi膰 problem贸w, zatrzymano uszkodzone pakiety.
    root@web:~# apt-get install php7.0-cli
    Czytanie list pakiet贸w… Gotowe
    Budowanie drzewa zale偶no艣ci
    Odczyt informacji o stanie… Gotowe
    Nie uda艂o si臋 zainstalowa膰 niekt贸rych pakiet贸w. Mo偶e to oznacza膰,
    偶e za偶膮dano niemo偶liwej sytuacji lub u偶yto dystrybucji niestabilnej,
    w kt贸rej niekt贸re pakiety nie zosta艂y jeszcze utworzone lub przeniesione
    z katalogu Incoming (“Przychodz膮ce”).
    Nast臋puj膮ce informacje mog膮 pom贸c rozwi膮za膰 sytuacj臋:

    Nast臋puj膮ce pakiety maj膮 niespe艂nione zale偶no艣ci:
    php7.0-cli : Wymaga: php7.0-common (= 7.0.0~rc8-1~dotdeb+8.1) ale nie zostanie zainstalowany
    Poleca: php-readline ale nie da si臋 go zainstalowa膰
    W konflikcie z: php5-cli ale 5.6.14+dfsg-0+deb8u1 ma zosta膰 zainstalowany
    E: Nie uda艂o si臋 naprawi膰 problem贸w, zatrzymano uszkodzone pakiety.

  3. Guillaume Plessis

    @grzegorz :

    > can you create package to use 7 and 5.6 at this same time?

    Sorry, no.

    > your build dont have memcache

    I’ll provide pecl/memcache soon. In the meantime, you can try to install it via “pecl install memcache”

  4. grzenio

    hm.. i have problem i dont have pecl on system, i test in clean system on virtaualbox

    root@debian:~# dpkg -l |grep php
    ii php-all-dev 9-1~dotdeb+8.1 all package depending on all supported PHP development packages
    ii php-common 9-1~dotdeb+8.1 all Common files for PHP packages
    ii php7.0 7.0.0~rc8-1~dotdeb+8.1 all server-side, HTML-embedded scripting language (metapackage)
    ii php7.0-cli 7.0.0~rc8-1~dotdeb+8.1 amd64 command-line interpreter for the PHP scripting language
    ii php7.0-common 7.0.0~rc8-1~dotdeb+8.1 all Common files for packages built from the PHP source
    ii php7.0-curl 7.0.0~rc8-1~dotdeb+8.1 amd64 CURL module for PHP
    ii php7.0-dev 7.0.0~rc8-1~dotdeb+8.1 amd64 Files for PHP7.0 module development
    ii php7.0-fpm 7.0.0~rc8-1~dotdeb+8.1 amd64 server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii php7.0-gd 7.0.0~rc8-1~dotdeb+8.1 amd64 GD module for PHP
    ii php7.0-intl 7.0.0~rc8-1~dotdeb+8.1 amd64 Internationalisation module for PHP
    ii php7.0-mysql 7.0.0~rc8-1~dotdeb+8.1 amd64 MySQL module for PHP
    ii php7.0-pspell 7.0.0~rc8-1~dotdeb+8.1 amd64 pspell module for PHP
    ii php7.0-recode 7.0.0~rc8-1~dotdeb+8.1 amd64 recode module for PHP
    ii php7.0-tidy 7.0.0~rc8-1~dotdeb+8.1 amd64 tidy module for PHP
    root@debian:~# pecl
    -bash: pecl: nie znaleziono polecenia

  5. grzenio

    pear package has conflict

    root@debian:~# apt-get install php-pear
    Czytanie list pakiet贸w… Gotowe
    Budowanie drzewa zale偶no艣ci
    Odczyt informacji o stanie… Gotowe
    Nie uda艂o si臋 zainstalowa膰 niekt贸rych pakiet贸w. Mo偶e to oznacza膰,
    偶e za偶膮dano niemo偶liwej sytuacji lub u偶yto dystrybucji niestabilnej,
    w kt贸rej niekt贸re pakiety nie zosta艂y jeszcze utworzone lub przeniesione
    z katalogu Incoming (“Przychodz膮ce”).
    Nast臋puj膮ce informacje mog膮 pom贸c rozwi膮za膰 sytuacj臋:

    Nast臋puj膮ce pakiety maj膮 niespe艂nione zale偶no艣ci:
    php-pear : Wymaga: php5-common (>= 5.6.14+dfsg-0+deb8u1~) ale nie zostanie zainstalowany
    Wymaga: php5-cli ale nie zostanie zainstalowany
    E: Nie uda艂o si臋 naprawi膰 problem贸w, zatrzymano uszkodzone pakiety.

  6. carl mcdade

    Upgrading from rc7 is not possible. The instructions do not take in account the state of a server after initial installation of a PHP7 RC. Will this also be the case after the RTM? Uninstalling and re-installation seems to be the only workaround.

  7. Guillaume Plessis

    @carl mcdade : I’ll keep this packaging scheme for the RTM, so yes, there’s a chance your problems occurs during RC7 (once again, preview packages) => RTM.

    What was exactly the problem?

  8. carl mcdade

    carl@carl-MacBook:~$ sudo apt-get upgrade php7.0
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Calculating upgrade… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php7.0 : Depends: libapache2-mod-php7.0 (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed or
    php7.0-cgi (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed or
    php7.0-fpm (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed
    Depends: php7.0-common (= 7.0.0~rc8-1~dotdeb+8.1) but 7.0.0~rc7-1~dotdeb+8.1 is to be installed
    E: Unable to correct problems, you have held broken packages.

  9. carl mcdade

    carl@carl-MacBook:~$ sudo dpkg -l |grep php
    ii libapache2-mod-php7.0 7.0.0~rc7-1~dotdeb+8.1 i386 server-side, HTML-embedded scripting language (Apache 2 module)
    ii php 9-1~dotdeb+8.1 all server-side, HTML-embedded scripting language (default)
    ii php-common 9-1~dotdeb+8.1 all Common files for PHP packages
    ii php-pear 5.5.9+dfsg-1ubuntu4.14 all PEAR – PHP Extension and Application Repository
    ii php-sqlite3 7.0.0~rc7-1~dotdeb+8.1 i386 SQLite3 module for PHP
    ii php5-cli 5.5.9+dfsg-1ubuntu4.14 i386 command-line interpreter for the php5 scripting language
    ii php5-common 5.5.9+dfsg-1ubuntu4.14 i386 Common files for packages built from the php5 source
    ii php5-json 1.3.2-2build1 i386 JSON module for php5
    ii php5-readline 5.5.9+dfsg-1ubuntu4.14 i386 Readline module for php5
    ii php7.0 7.0.0~rc7-1~dotdeb+8.1 all server-side, HTML-embedded scripting language (metapackage)
    ii php7.0-cli 7.0.0~rc7-1~dotdeb+8.1 i386 command-line interpreter for the PHP scripting language
    ii php7.0-common 7.0.0~rc7-1~dotdeb+8.1 all Common files for packages built from the PHP source
    ii php7.0-dev 7.0.0~rc7-1~dotdeb+8.1 i386 Files for PHP7.0 module development
    ii pkg-php-tools 1.11 all various packaging tools and scripts for PHP packages
    carl@carl-MacBook:~$

  10. MirkoBrunner

    Hello,

    i have the same problem as carl. I have remove all php module but i am unable to perform the installation of php 7.

    I got following msg:

    The following packages have unmet dependencies:
    php7.0 : Depends: libapache2-mod-php7.0 (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed or
    php7.0-cgi (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed or
    php7.0-fpm (>= 7.0.0~rc8-1~dotdeb+8.1~) but it is not going to be installed

    I麓m a little confused, because “dpkg -l |grep php” shows nothing and via “apt-get –installed list” shows no php modules are listed.

  11. Guillaume Plessis

    @MirkoBrunner : could you please use aptitude or dselect to spot exactly what prevents the installation? What is your target distribution? A clean Jessie?

  12. MirkoBrunner

    Here i麓m back:

    so via aptitude i got:

    The following NEW packages will be installed:
    libapache2-mod-php7.0{ab} php-common{a} php7.0 php7.0-cli{ab} php7.0-common{a}
    0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
    Need to get 5.276 kB of archives. After unpacking 23,7 MB will be used.
    The following packages have unmet dependencies:
    php7.0-cli : Depends: libenchant1c2a (>= 1.6.0) which is a virtual package.
    Depends: libltdl7 (>= 2.4.2) but it is not installable.
    Depends: libmcrypt4 but it is not installable.
    Depends: libqdbm14 (>= 1.8.74) but it is not installable.
    Depends: libxslt1.1 (>= 1.1.25) which is a virtual package.
    libapache2-mod-php7.0 : Depends: libenchant1c2a (>= 1.6.0) which is a virtual package.
    Depends: libltdl7 (>= 2.4.2) but it is not installable.
    Depends: libmcrypt4 but it is not installable.
    Depends: libqdbm14 (>= 1.8.74) but it is not installable.
    Depends: libxslt1.1 (>= 1.1.25) which is a virtual package.

    The Server Debian was only 6 days old. The target is “http://packages.dotdeb.org jessie all” (i think you mean that).

  13. Guillaume Plessis

    @MirkoBrunner : please make sure that you also have a full Jessie sources.list along Dotdeb entries. Don’t forget to run apt-get update :

    deb http://http.debian.net/debian/ jessie main contrib non-free
    deb http://http.debian.net/debian/ jessie-updates main contrib non-free
    deb http://http.debian.net/debian/ jessie-backports main contrib non-free
    deb http://security.debian.org/ jessie/updates main contrib non-free
    
  14. MirkoBrunner

    Hurray! 馃榾 It works. Thank you and You’re doing a very good job and save my day.

    And I like to donate a little ..