Posted by & filed under MySQL.

The packages of MySQL 5.5.28 are now available for Debian 6.0 “Squeeze” on both amd64 and i386 architectures. They fixes some InnoDB-, partition- and replication-related issues.

The Pinba engine has also been rebuilt to be used with the new version.

As usual, please read carefully the fullĀ Changelog before upgrading.

20 Responses to “MySQL 5.5.28”

  1. Leroyk2

    The ssl replication problems in MySQL 5.5.18 are fixed in this release. Instead of only use the key param you should now also use MASTER_SSL_CA and MASTER_SSL_CERT

    Reply
  2. Doug

    Hi. Firstly, Thanks for releasing MySQL 5.5.28 but, I am getting this when I try to start my MySQL server:

    * Starting MySQL database server mysqld [ OK ]
    * Checking for tables which need an upgrade, are corrupt or were
    not closed cleanly.

    and after searching a lot on google, I found that my error is:
    Unknown table engine ‘PERFORMANCE_SCHEMA’

    Can you help me?

    Reply
  3. Renaud

    Hi, thanks for this release, but I have a little problem with php5-mysql.
    This package depends only on libmysqlclient16 (5.1.21). Impossible to use libmysqlclient18 (5.5.28).

    How to use the right mysql lib ?

    Reply
    • Guillaume Plessis

      @Renaud : Dotdeb is built for Debian stable. Debian stable contains libmysqlclient16.
      If you use Dotdeb with another distribution (at your own risk), install php5-mysqlnd instead of php5-mysql : The MySQL native driver doesn’t depend on any libmysqlclient package.

      Reply
      • Renaud

        I use a stable Debian 6 Squeeze and dotdeb repository

        Dotdeb provide Mysqm Server 5.5.28 and its lib libmysqlclient18 (5.5.28).

        Unfortunatly, php5-mysql (provided by dotdeb-squeeze and dotdeb-squeeze-php54) depends only on libmysqlclient16 (5.1.21)

        libmysqlclient16 is provided by official squeeze repo but libmysqlclient18 is provided by dotdeb repository.

        So i would like to use dotdeb mysql and php5 packages including libmysqlclient18.

        Why this is not possible ?

        Reply
        • Guillaume Plessis

          @Renaud : only php5-mysql from PHP 5.4 depend on libmysqlclient16 (>= 5.1.21-1). This last package is present in Debian stable in version 5.1.63 that will satisfy the dependency :

          http://packages.debian.org/libmysqlclient16

          On the other side, php5-mysql depends on libmysqlclient16 only because it has been built against this version of libmysqlclient16 (MySQL 5.1 in fact). Of course, I could build php5-mysql from PHP 5.4 against my libmysqlclient18 (MySQL 5.5), but it would lead to very bad issues, such as duplicate symbols or segfaults when PHP is loaded with other MySQL-linked modules from the stock Debian distribution (those are linked to libmysqlclient16). For example : mod_php5 + Apache + mod_auth_mysql would crash.

          If this libmysqlclient16 dependency really annoys you, feel free to use install php5-mysqlnd, that is not linked against any libmysqlclient library and that has a lot of benefits :

          http://www.php.net/mysqlnd

          Reply
          • Renaud

            Thanks for the quick responses.

            Unfortunatly, phpmyadmin depends on php5-mysql and there is a conflict between php5-mysql and php5-mysqlnd

  4. Vide

    Sorry for the offtopic but, dou you have a NDB build? Or do you know of any Debian repo with up-to-date Mysql Cluster NDB engine? Thanks!

    Reply
    • Guillaume Plessis

      @Finn Dorby : I won’t package RC of MySQL, you’ll have to wait until 5.6 is GA.
      BTW, InnoDB FTS might not be such a great feature. You can take a look at Sphinxsearch, it rocks.

      Reply
  5. Finn Dorby

    @Guillaume: thank you for pointing me to sphinx, which i stumbled upon before, but never had a project where i could actually use it. Now i decided to use sphinx and mongoDB for my search index. And thanks for dotdeb. You do great work.

    Reply
    • Guillaume Plessis

      Hello Michael,

      because I want to follow Debian’s packaging scheme for full compatibility, that’s probably a feature you’ll want to submit to http://bugs.debian.org/ . If there’s no move from them, I’ll try to package an extra libmysqlclient18-dbg. Please keep me informed, ok?

      Reply

Trackbacks/Pingbacks

  1.  How use a fitting PHP client library version when combining PHP 5.4 and MySQL 5.5 from Dotdeb? « Mind of Matt

Leave a Reply

  • (will not be published)


4 + one =