Posted by & filed under MySQL.

MySQL 5.1.37 is now available on Dotdeb for Debian 4.0 “Etch” / Debian 5.0 “Lenny” in amd64/i386 flavours.

It fixes two security issues and brings a lot of bugfixes (read the list of changes), especially about replication and partitioning.

Please upgrade your servers.

18 Responses to “MySQL 5.1.37 is available for Debian “Etch” and “Lenny””

  1. Tom Bailey

    I am unable to get mysql-server 5.1.37 to install. It hangs while unpacking mysql-server-5.1_5.1.37-0.dotdeb.1_i386.deb or mysql-server_5.1.37-0.dotdeb.1_all.deb I can’t tell.

    Anyone else have this problem?

    Attempting to build from source.

  2. Tom Bailey

    Source compile was successful but the package fails important tests. I’ll stick with 5.0 for now. Thanks for the PHP packages though.

  3. hgf

    A general question: I can’t find gpg-signatures of your releases… are there none, or is it my failure? I do trust you, but not the internet… 😉

  4. Tom Bailey

    FYI, dotdeb packages are unsigned. That’s why you get no apt-get update warning, only a warning that you are installing an unsigned package when you do so.

  5. Gonzague

    Bon.. Aptitude m’a un peu cassé les pieds pour passer de 5.0.84 à 5.1 ( problèmes de dépendances bloquant la mise à jour etc etc ) mais voilà c’est passé

  6. endre

    Hi,

    Just a wishlisht item, would it be possible to build mysql client with the system readline? It’s much more powerful than the bundled one. Some previous versions were built with it, some not (Debian versions are, dotdeb ones mostly aren’t), and this always messes up my .mysql_history files.

  7. hgf

    @Guillaume: Thanks for your response! I’m looking forward to secure dotdeb-releases. Greetings from Germany 🙂

  8. Jean-Michel

    Hello Guillaume,
    Since a recent upgrade on one server from MySQL 5.0 to 5.1.37, I have incorrect figures for several InnoDB tables in different databases. The concerned data are DATA_FREE and DATA_LENGTH (shown with ‘SHOW TABLE STATUS’ and also reported by PhpMyAdmin in the “Perte” an “Effectif” fields – in the french version). For example, many tables have ‘850395136’ as DATA_FREE value (“Perte 830 464 Ko” in PhpMyAdmin). If I try to optimize these tables, it returns OK but the numbers stay the same.
    I don’t know if it is related to this but I have had some trouble to upgrade this server to 5.1 with my current my.cnf, so I replaced it by another my.cnf which worked for 5.1 and then I change some numbers such as key_buffer size.
    The behaviour of the server seems OK now but I would like to have the correct numbers in order to make optimization when necessary. Do you have an idea of how to reset these numbers ? (I have stop and restart the server several times but nothing changed)
    (I have posted this issue to the mysql forum too but I have’nt got any answer for now)

  9. jdelmour

    Why are your packages not trusted?

    WARNING: untrusted versions of the following packages will be installed!

    Untrusted packages could compromise your system’s security.
    You should only proceed with the installation if you are certain that
    this is what you want to do.

    libmysqlclient15off mysql-server libapache2-mod-php5 php5-snmp php5-gd libmysqlclient16 php5-imagick php-pear php5-curl php5-mhash mysql-client php5-mcrypt php5-mysql php5-cli php5-dev mysql-common php5-common
    mysql-server-5.1 mysql-client-5.1 php5-odbc

  10. Guillaume Plessis

    @Edgard Pineda : What makes you say that?

    # dpkg -I mysql-server-5.1_5.1.39-0.dotdeb.1_amd64.deb
    (...)
    Depends: mysql-client-5.1 (>= 5.1.39-0.dotdeb.1), libdbi-perl, perl (>= 5.6), libc6 (>= 2.7-1), libgcc1 (>= 1:4.1.1), libmysqlclient16 (>= 5.1.36), libstdc++6 (>= 4.1.1), libwrap0 (>= 7.6-4~), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, psmisc, passwd, lsb-base (>= 3.0-10)

  11. Edgard Pineda

    Well… generally we don’t use mysql-server alone, then when you try to use php5-mysql, this package is not compiled against libmysqlclient16, then the connection between apache2 and php and mysql is not good, you’ll see warning of possible conflicts.