MySQL 5.1.39 released for Debian “Etch” and “Lenny”

MySQL 5.1.39 is now available on Dotdeb for Debian 4.0 “Etch” / Debian 5.0 “Lenny” in amd64/i386 flavours.

This maintenance release fixes a lot of bugs. Please note that the Lenny version introduces some hardening features.

As usual, please read the list of changes in 5.1.39 before upgrading.

15 replies on “MySQL 5.1.39 released for Debian “Etch” and “Lenny””


it seems that the postinst script doesn’t work very well. I always get this error when configuring the package

ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ALTER TABLE user ADD column Show_view_priv enum(‘N’,’Y’) CHARACTER SET utf8 NOT ‘ at line 1

This is weird cause the postinstall script seems just fine. Anyway I had to put an exit 0 on top of it and run mysql_upgrade manually and I get it working ok. Anyone experiencing the same problem?

@Edgard Pineda : What makes you say that?

# dpkg -I mysql-server-5.1_5.1.39-0.dotdeb.1_amd64.deb
Depends: mysql-client-5.1 (>= 5.1.39-0.dotdeb.1), libdbi-perl, perl (>= 5.6), libc6 (>= 2.7-1), libgcc1 (>= 1:4.1.1), libmysqlclient16 (>= 5.1.36), libstdc++6 (>= 4.1.1), libwrap0 (>= 7.6-4~), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, psmisc, passwd, lsb-base (>= 3.0-10)

Well… generally we don’t use mysql-server alone, then when you try to use php5-mysql, this package is not compiled against libmysqlclient16, then the connection between apache2 and php and mysql is not good, you’ll see warning of possible conflicts.

For example, a new compiled php5-mysql against libmysqlclient16 is missing.

@Edgard Pineda : Compiling PHP modules against MySQL 5.1/libmysqlclient16 would cause more pain than it brings features : In fact, there will be issues when MySQL5.0-linked Apache modules (such as auth_mysql) and MySQL5.1-linked PHP extensions are loaded together.
Segfaults will occur as soon as a MySQL function is called.

This behavior has changed with mysql PHP 5.3 (preview) packages as mysql native driver has replaced libmysqlclient in all the MySQL-related extensions :

Otherwise, if you want to build PHP against MySQL 5.1 (at your own risks), follow these steps :
apt-get install libmysqlclient-dev (ensure that it’s the 5.1 version)
apt-get source -b php5

Good luck.

@Guillame: can you post an update when the new compilation is online in your repo? InnoDB plugin is still broken, at least for me:

091027 16:59:49 [ERROR] Can’t open shared library ‘’ (errno: 0 API version for STORAGE ENGINE plugin is too different)

@Vide : I planned to upload new 5.1.39 packages, but MySQL 5.1.40 is on its way, so you’ll need a little bit more patience 🙂

If you can’t wait, you’ll have to install libmysqlclient-dev that contains the appropriate .so (but it depends on libc6-dev…)

@Guillaume: mmmh just installed libmysqlclient-dev and all its dependencies and still no luck. The error is the same I’ve reported in my previous comment. Any idea?

Ok, I’m stupid, the dev package PROVIDES /usr/lib/mysql/plugin/ so no need for separate plugin from

Sorry 🙂

Comments are closed.