Posted by & filed under PHP.

New packages of PHP 5.3.1 and PHP 5.2.13 has been uploaded to fix some annoying bugs :

In addition, PHP 5.3.2 now restarts softly, without any problem (thanks to Daniel Hahler).

67 Responses to “PHP 5.3.2 and PHP 5.2.13 get an update”

  1. Sorin

    Thanks ๐Ÿ™‚
    I’m using dotdeb repositories for a Froxlor Control Panel install ๐Ÿ˜‰
    Seems that PHP 5.3.2 is running smoothly so far.

  2. Dave Carlson

    Updated, thanks!

    Have you ever considered doing packages for apache as well ?
    Still stuck on 2.2.9 on my lenny install (yes I know I could compile but bleh, dotdeb packages FTW!)

  3. Hans van Eijsden

    Apache packages? I would like to have them as well! I’m also a Lenny-user and would like to have a new version without the need for compiling. Because Dotdeb rocks… ๐Ÿ˜‰

  4. Steve Davies


    I’m new to Linux and have a Ubuntu server. I’ve added the links to my repositories but can anyone tell me how to install PHP 5.3.2?

    I’ve used tasksel but it doesn’t appear in any of the lists?

  5. Steve Davies

    Thanks, but how for example would I install PHP 5.3.2?

  6. Steve Davies

    Sorry, could you do the same for MySQL?

    Basically, I want a LAMP server with the latest versions on.

  7. Boris

    Just a request for :
    php5-memcache (and php5-memcached maybe)

    Other (I don’t use really but could be good):
    The following packages have unmet dependencies.
    php5-apc: Depends: php5-common (= 5.2.13-0.dotdeb.1) but 5.3.2-1 is to be installed
    E: Broken packages

    using :

  8. Steve Davies

    What do you mean by make a request?

    (I know this isn’t a forum so apologies)

    Basically, I was looking for a guide or a 1,2,3 of how to install a LAMP setup using specific versions of MySQL and PHP when I found this site.

  9. Boris

    This is just that PHP Debian Package are not build on DotDeb repository, so I can’t install this “properly”.

    But I’m a weird case, having Debian “official” sources.list in SID and dotdeb for PHP 5.3.

    I know this is huge work to maintain dotdeb, it’s just to ask them.

    Sorry, my English isn’t really good, maybe it’s just a missunderstanding.

  10. Guillaume Plessis

    First, add the appropriate lines in your /etc/apt/sources.list

    deb stable all
    deb stable all

    Then, use a decent package manager (such as aptitude, dselect or synaptic) to install all the packages you want (mysql-server-5.1, php5, php5-apc, php5-memcache…). Dependencies will automatically be satisfied by using the most recent packages (Dotdeb’s ones if you’re on Debian stable, aka “Lenny”).

  11. Guillaume Plessis

    @Lyon : 64bits issue has been fixed by Stefan Esser and Dotdeb still includes the Suhosin patch. No plan for removing it.

  12. Jockl


    I don’t know if this is the right place for the following question. I am about to upgrade from etch to Lenny (I now, I’m late :-/) but want to use PHP 5.2 again with Lenny. Am I right, that using

    deb stable all
    deb-src stable all

    in the source.list will prevent that PHP will be upgraded to 5.3 as well?
    I guess, using

    deb stable all
    deb-src stable all

    (as seen at: )would upgrade to PHP5.3 as well?

    Thank you in advance!

  13. Guillaume Plessis

    You’re right. PHP 5.3 is on a separate repository to avoid the direct upgrade. Using only the main repository will keep PHP 5.2.

  14. Mostafa


    Please also provide these packages :

    Thank you for your great work

  15. Guillaume Plessis

    @Mostafa : Sorry but I don’t have enough time to maintain well all these packages. About Nginx, provides up-to-date packages for Lenny.

  16. Guillaume Plessis

    @SplitIce : thanks for this link/patch. I’ll take a look at it to evaluate its maintainability. I also have to preserve existing installation’s integrity and performance.

    If I include it, I’ll announce it.

  17. SplitIce

    Ok thanks mate, hopefully you save me having to compile my own when you do such a great job already.

    On my centos ‘crappy lappy’ (400mhz processor makes it ideal for performance testing)

    I tested the patch without APC (lol 32mb ram makes it impossible) and didn’t notice any real performance difference between that and a non-patched compiled version.

    If you need any assistance let me know.

  18. Jonathan

    Hi Guys,

    When I try to update the packages I get the following error:

    Err stable/all php5-common 5.3.2-0.dotdeb.1
    404 Not Found

    Is it a file server currently down or something else ?

    Thanks for the great work !

  19. Niels

    I have an big Problem my Debian says when i try to update from 5.2 to 5.3

    root@vs184036:~# apt-get upgrade
    Reading package lists… Done
    Building dependency tree… Done
    The following packages have been kept back:
    libapache2-mod-php5 php5-cli php5-common php5-curl php5-gd php5-imap
    php5-mysql php5-xsl
    0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

    Can Anyone help me MY Email is

  20. Guillaume Plessis

    @Niels : please use a decent package manager, such as dselect, aptitude or synaptic. They will be more verbose on the dependency that prevents the installation of PHP 5.3.

  21. Niels

    So i have now used dselect the first time and was suprised how nice it was but still I have a big Problem with the keystrokes

    here an screenshot

    what i must push to select them to update ?
    I have already tryed + , Inster
    but nothing happens.

    Hopping for help ๐Ÿ™‚ And sry i am new to this ^^

  22. Guillaume Plessis

    @Niels : great, the screenshot shows that the packages will be updated. Press “enter” to validate your changes. If a dependency problem occur, dselect will let you know in a conflict resolution screen.

  23. Niels

    I got the Same answer as with apt-get

    0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

    Here how i go:

    –Shift Q
    — Install

    0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

    PHP is srtill 5.2 what is the Problem of my funny System ? Want it to kidding me ore make a Joke? ๐Ÿ™‚


  24. Niels

    Is ther a way we can chat in ICQ ore something similair ? My Spoken English is quit bedder ๐Ÿ™‚

  25. Limo

    Thank you for the time and effort required for maintaining the repository.

  26. Niels

    Thanks for helping me man ๐Ÿ™‚
    I got your Tip and Kicket PLESK out now I am an Only Putty ssh Consol user ๐Ÿ™‚
    Dose that make me to a nerd ? xD
    I Hope so ^^

    Thanks mutch for your ervord.

    And Forgive me my English ๐Ÿ™‚

    and keep up
    Niels Rode
    from Germany

  27. Gingko

    There seems to be a problem with PHP 5.3.2 : cookies are not working properly in some cases, for example when running PhpBB 3.0.5 (and probably other versions also).
    The reason seems to be that the $_COOKIE super global variable is not always populated with received cookies, and the most visible effect is that the users of my phpBB forum are not able to use the “automatic logon” feature of phpBB.
    However, a simple test case with the setcookie function works properly, so I don’t know exactly what kind of cookie can trigger the bug.
    Downgrading to phpBB 5.2.13 or lower effectively fix the problem.

    Gingko (France)

  28. geronimoh

    first of all:
    Merci beaucoup pour ce terrible travail de garder ร  jour php et mysql, vraiment, vous รชtes gรฉnial!! ๐Ÿ˜€
    ( just saying thank you very much ).

    However i’ve got a failing apache with the dotdeb php packages, apache crashes with these notice in my logs :
    [notice] child pid exit signal Segmentation fault (11)
    i saw there were similar problems with the 5.2.10 packages, but i havent seen any solutions yet…
    please help!!, any hints would be very helpfull

    apache2-mpm-prefork 2.9-10+lenny7
    apache2-utils 2.2.9-10+lenny7
    apache2.2-common 2.2.9-10+lenny7
    libapache2-mod-php5 5.2.13-0.dotdeb.1

  29. Guillaume Plessis

    @geronimoh : the best way to fix this is to find a way to reproduce the bug. By enabling more logging options in Apache or in PHP, you may isolate the involved piece of code.
    Then, you could send me (gui_at_php_dot_net) a trace from “strace -f apache2 -X”

  30. geronimoh

    @Guillaume : Thank you! i’ve narrowed down the problem to one module, and guess what… it’s zend optimizer… grrr.. when i’ve found a compatible binary i’ll post the version here, so others won’t have the same problem.
    just for info it’s a 32bits lenny

  31. Guillaume Plessis

    @geronimoh : be sure to enable just one opcode-related extension (zend_optimizer, apc, xdebug, xhprof…) at a time.
    Why not using APC instead of zend_optimizer?

  32. geronimoh

    @Guillaume : Thanks,
    Someone else is also developing on our server and obfuscated with zend.. (i know there are plenty dezenders out there, but they want it that way.. so i get to debug the server… ๐Ÿ™ )

  33. Joshua Parker

    I upgraded my server to php 5.2.4 but then it started having problems, so I upgraded to 5.2.13, restarted the server and things were faster again. But then things slowed down again. I was wondering if you could help me figure out the issue. My site is at

    I am using ubuntu 8.0.4 with 64bit.

  34. Guillaume Plessis

    @Joshua Parker : consider those tips :
    – watch your logfiles. If there’s none, set up PHP, Apache, MySQL to be as verbose as needed. Watch MySQL slow queries, queries without indexes, Apache response time, PHP warning and errors
    – monitor your platform with things (load average, memory, disks, latencies, mysql queries…)
    – profile your code with tools such as Xdebug
    – install an opcode cache such as php5-apc.

  35. Nixx


    I added dotdeb on my sources list and tried to update php from 5.2.0+dfsg-8+etch16 to 5.2.13-0.dotdeb.1 (for symfony requires Ver>5.2.1), but I keep getting dependency issues like this:

    libapache2-mod-php5: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch10+b1 is to be installed
    Depends: libdb4.6 but it is not installable
    Depends: libkrb53 (>= 1.6.dfsg.2) but 1.4.4-7etch6 is to be installed
    Depends: libssl0.9.8 (>= 0.9.8f-5) but 0.9.8c-4etch4 is to be installed
    Depends: libxml2 (>= 2.6.28) but 2.6.27.dfsg-6 is to be installed
    Depends: php5-common (= 5.2.13-0.dotdeb.1) but 5.2.0+dfsg-8+etch16 is to be installed.

    Am I missing something ? should I further update my sources.list ? Currently it looks like this:

    deb etch main contrib non-free
    deb etch/volatile main contrib non-free
    deb etch/updates main contrib non-free
    deb etch all
    deb stable all

    ## This is temporary appended by Autoinstaller for
    ## specify source of product’s packages for APT.
    deb etch all

    (running etch 4 with plesk 9 installed)

    Thank you for helping the newbie that I am !
    Should it not be the right place to post, feel free to redirect me ๐Ÿ™‚


  36. Guillaume Plessis

    @Nixx : the problem is that you’re using Etch on your server. Dotdeb only supports the stable version of Debian (aka Lenny).
    Since the security support has been ended for Etch, I advise you to upgrade your serveur to Lenny. Then you should be able to use Dotdeb without any dependency issue.

    If you can not upgrade to Lenny, take a look at and grab and install the needed Etch packages manually.

  37. Nedko Iliev

    Hello, from couple days I’m trying to compile php 5.3.2-1 for debian unstable with fpm, but I experience some problems. I would like to see(and use :)) your “debian/rules” file if it is possible.
    P.S. your job is great ๐Ÿ˜‰

  38. Nixx

    Hello Guillaume.

    Sorry for the late reply…

    I had to download and install packages manually (this is for a rented virtual server => upgrade to lenny is not an option), but it did the job.

    Thanks a lot for the awesome work on the packages, and for following up on issues !

    All the best…


  39. Kissifrot

    It seems I’m having the same problem as geronimoh (segfaults), but with the PHP 5.3.2 version.

    However Zend optimizer doesn’t seem to be activated.

    Any hint on how to track the source of the problem?

  40. Guillaume Plessis

    @Kissifrot : as said for geronimoh, the best way to fix this is to find a way to reproduce the bug. By enabling more logging options in Apache or in PHP, you may isolate the involved piece of code.
    Then, you could send me (gui_at_php_dot_net) a trace from โ€œstrace -f apache2 -Xโ€

  41. Gary

    Hi this is probably a stupid question I’m new to linux. Last night installed php using this site. I’ve deleted the serve and cant figure out how i got the php5 on.
    I’ve updated the sources list, I remember using a command like: apt get install something something. But cant find the post which i got it from :S


  1.  MAJ : Bug LibGD de PHP 5.3.2 sur Debian 5 (32bits) – DotetDeb.2 | EXinsidePHP