Posted by & filed under MySQL.

MySQL 5.1.48 packages for Debian 5.0 « Lenny » are now available on Dotdeb in amd64/i386 flavours.

This is a bug fix release, focused on replication and partitioning, and the InnoDB plugin has been updated to the 1.0.9 stable version.

As usual, please read the Changelog carefully before upgrading.

9 Responses to “MySQL 5.1.48 packages for Debian are here”

  1. Vide

    Guillaume, thanks for the new release. Just a thing I noticed in your packages (as well in official Debian ones). Every time I upgrade it changes /var/lib/mysql permissions to 700, while IMO it should be set to 770, as the group is “mysql”. I have some scripts running as another user, part of the mysql group, which fails every time I update the mysql package and forget about the permission “problem”. Can you change this? Is there a rational behind the 700 permissions? Thanks in advance

  2. danei

    Hi, Guillaume, Thx for the release.
    I remember you have mentioned the gpg-key for the pakages was on going long time ago, but I can’t find it. Could you figure it out?

  3. christian

    Hello !
    since i added the dotdeb depot in my soucelist and upgraded to mysql 5.1.48, phpmyadmin is displaying :

    Version du serveur: 5.1.48-0.dotdeb.0
    Version du client MySQL: 5.0.51a

    so i tried to uninstall:
    apt-get remove mysql-client-5.0 or apt-get remove mysql-client

    and reinstalled mysql-client-5.1

    But phpmyadmin is always displaying a 5.0 version.

    Any help would be appreciated.
    i’m french.

    Thank you

  4. Guillaume Plessis

    @Icebreaker : you just have to follow the instructions… Add the appropriate lines in your /etc/apt/sources.list, then apt-get update and then apt-get install mysql-server-5.1

  5. Guillaume Plessis

    @christian : ce problème a été abordé plusieurs fois dans les commentaires. La version de MySQL rapportée par phpinfo() ou PHPMyAdmin est celle des librairies MySQL par rapport auxquelles PHP a été compilé, pas celle du serveur lui-même.
    La version 5.0 rapportée ne peut pas être différente. En effet, si on compile les extensions MySQL de PHP par rapport à une autre version, des conflits de symboles auront lieu avec d’autres éléments de Apache ou PHP, provoquant des segfaults… Cela n’entrave en rien la bonne marche de PHP avec des serveurs MySQL >=5.1

  6. Daniel Hahler

    offtopic: the flattr button appears to be non-functional on this entry, while it works on your other posts (where there are more than 0 flattrs already though).