Categories
PHP

PHP 5.3.5, now for Squeeze

I just released PHP 5.3.5 packages for Debian 6.0 (a.k.a “Squeeze”), with some changes against the Lenny’s ones :

  • the packaging process has been improved : dependencies were cleaned up, PHP tests are now displayed, libtool 2.2 is now supported (thanks to the Debian team for their precious work)
  • 3 new useful extensions have been packaged : gearman, phpredis and xhprof (without its interface files)

With these new packages, Dotdeb’s support for Squeeze is still experimental, but almost complete. Some more packages could be added in a near future :

  • MySQL (or Percona) Server 5.5 will replace MySQL Server 5.1. More info here and here.
  • a Nginx backport

The installation instructions did not change : just add Dotdeb’s GnuPG key to your keyring, pick a mirror near you and add squeeze-related lines to your sources.list. For example :

deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

And, of course, feel free to donate if you find Dotdeb useful.

43 replies on “PHP 5.3.5, now for Squeeze”

thanks for the continued hard work Guillaume

i’m glad that we will have some php and mysql updates out the box when squeeze is released stable

i assume this is syncing to mirrors so people can also use local mirrors just changing stable to squeeze in the mirror lines?

This is great news. I tried it when I read it, but when running apt-get update, I got this warning:

W: Conflicting distribution: http://packages.dotdeb.org squeeze Release (expected squeeze but got lenny)

Installation of PHP 5.3.5, etc. went fine though. I am running a fresh Squeeze beta install.

@Guillaume: Thanks a lot for your work!
I got an (quite offtopic) question: Since you somewhere wrote, you’ve 600+ Servers – do you prefer xcache or APC (or don’t you use an opcode cache at all)? I’m used to xcache, but further development seems to be slow (at best). In APC it’s possible to enable CLI Mode – which is great for Unit-Testing. Is it as stable as xcache? I never had any issues with xcache, even when running in parallel with xdebug.

@Laph : I use APC by default on my servers (they’re a little less than 600 now, I’ve got a new job). It is stable enough, it is well maintained by the PHP Group and it will (some day) be part of the PHP core. It also have its own userland functions and many configuration options that allow a fine-grained cache control.

I only use xcache on some problematic projects (blank pages with APC, source code sharing…).

I think you can switch safely, but not without a test phase.

@Nicolas Favre-Felix : You’re welcome. I think I’ll package it for Lenny too.

Good luck with PECL. Don’t forget to update PHP_REDIS_VERSION in the next releases, according to the Git tags (the 2.0.12 tag still claims it’s 2.0.11).

Hi Guillaume,

Great to see that 535 is available. I added the dotdeb repo, and ran an update and upgrade, but it did not upgrade the current 5.3.3-7 version installed. However, it did upgrade mysql!

Results were:
# apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages have been kept back:
libapache2-mod-php5 php-pear php5 php5-cli php5-common php5-gd php5-imap php5-mcrypt php5-mysql php5-pspell php5-sqlite php5-suhosin
0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.

And the repos are:
deb http://ftp.debian.org/debian squeeze main non-free
deb http://backports.debian.org/debian-backports squeeze-backports main
deb http://packages.dotdeb.org squeeze all

Linux srv31 2.6.32-cgmemcap-smack #1 SMP Tue Dec 28 14:28:18 CET 2010 x86_64 GNU/Linux

Any ideas where I went wrong?

All the best, P.

@Guillaume,

Marvellous. I forgot about aptitude.Thank-you.

~# aptitude safe-upgrade
Resolving dependencies…
The following NEW packages will be installed:
libicu44{a}
The following packages will be upgraded:
libapache2-mod-php5 php-pear php5 php5-cli php5-common php5-gd php5-imap php5-mcrypt php5-mysql php5-pspell php5-sqlite
php5-suhosin

# php -v
PHP 5.3.5-0.dotdeb.1 with Suhosin-Patch (cli) (built: Jan 11 2011 09:08:22)

nginx backport would be awesome. for now, i compile it myself after new release.

also, is it possible to rsync php53.dotdeb.org for mirroring?

# apt-get install -y php5-cli php5-mhash php5-mcrypt php5-mysql php5-gd php5-curl

The following packages have unmet dependencies:
php5-cli: Depends: php5-common (= 5.3.5-0.dotdeb.0) but it is not going to be installed
php5-curl: Depends: php5-common (= 5.3.5-0.dotdeb.0) but it is not going to be installed
php5-gd: Depends: php5-common (= 5.3.5-0.dotdeb.0) but it is not going to be installed
php5-mcrypt: Depends: php5-common (= 5.3.5-0.dotdeb.0) but it is not going to be installed
php5-mhash: Depends: phpapi-20060613
Depends: php5-common (= 5.2.17-0.dotdeb.0) but it is not going to be installed
php5-mysql: Depends: php5-common (= 5.3.5-0.dotdeb.0) but it is not going to be installed
E: Broken packages

what should I do?

@ap : send me an email (gui at dotdeb dot org) with the source IP of your server, I’ll grant you an access to the rsync server.

@boss : uninstall php5-mhash before upgrading. This package disapeared with PHP 5.3. The hash functions are now bundled in the PHP core.

Please, please, please revive mailparse PECL module package. I was heavily using it and now reinstalled couple of my production boxes with Squeeze, to realise it’s no longer on dotdeb 🙁
Can you please make them available again, please?

Is php5-fpm enabled on this build? I’m having trouble with the dependencies for php5-pgsql is too old – libpq 8.3, but I would like 8.4, so I may have to compile from source.

@Guillaume: I read this guide, but I thought it would be less hassle for you to re-enable it, especially in the note mentioning removeal of mailparse and id3 you asked if anyone wants it back. So I do want 🙂 Any chance you re-include mailparse anyway? Would donate if so as it’d save my time. Thanks

@Paul : php5-fpm is available with the php5-fpm package, as usual. about libpq, 8.3 is the default version Squeeze packages are built against. Building against 8.4 could lead to duplicate symbols and segfaults on some configs.

Hi. Is it possible to “Compile PHP with the –with-mm option and set session.save_handler=mm in php.ini.”, but set default php.ini session.save_handler=files?

Thank you Guillaume. I found out mm isn’t what I thought it was and made the changes that you have suggested.

sorry. must have missed that! aah i see it happened today. I’ve locked my sources to lenny now. thanks – however your instructions are not updated to reflect this and refer to lenny still. Also it would be useful to have 5.2 available for squeeze – any plans for this?

why is in the php.ini delivered with these packages cgi.fix_pathinfo=1 ???

wouldn´t it be better to change this?

apt-get install -y php5-curl

The following packages have unmet dependencies.
php5-curl: Depends: phpapi-20060613+lfs
Depends: php5-common (= 5.2.17-0.dotdeb.0) but 5.3.5-0.dotdeb.0 is to be installed
E: Broken packages

Comments are closed.