Categories
Miscellaneous

Debian 6.0 “Squeeze” has been released

Today is a great day for the Debian community : Debian Squeeze has been released.

After 24 months of constant development, the Debian Project is proud to present its new stable version 6.0 (code name Squeeze). Debian 6.0 is a free operating system, coming for the first time in two flavours. Alongside Debian GNU/Linux, Debian GNU/kFreeBSD is introduced with this version as a technology preview.

The website of the Debian project also got a facelift. Please visit it for more information.

As a consequence, you have to take care of the content of your /etc/apt/sources.list file :

  • Squeeze is now refered as “stable”
  • Lenny is now known as “oldstable”

Therefore, if you want to stick to Lenny, change all the occurrences of “stable” to “oldstable” or “lenny”.

21 replies on “Debian 6.0 “Squeeze” has been released”

Successfully upgraded to squeeze on my xen vps with dotdeb repositories. Do I need to keep the php 5.3 repository at this point? (I assume not, as squeeze defaults at 5.3.3)

Hi,
Do you plan to releases php 5.2 package for squeeze ?

I need to install a drupal6 webserver cluster for a customer, but lenny will become archive in 1 year, so no future security update…

+ I need some others recent squeeze packages (ocfs2, corosync,…).
And migration to drupal7 is not in the plans of my customer for the moment….

(And i don’t wan’t to use ubuntu server 8.04 :/ )

@Alexandre Derumier : Good point for not using Ubuntu 8.04 🙂

Sorry, but I won’t publish the end-of-life PHP 5.2 for Squeeze. Instead, the packages from Lenny will work on Debian 6.0.

After adding the Dotdeb repo, how could I use apt-pinning to install mysql packages from the main Debian repos instead of Dotdeb?
I’m interested only in your php5 packages, and am afraid my attempts to configure the apt preferences file haven’t been met with success.

Hello,

I was able to use dotdeb to install php 5.3.5 successfully a few weeks ago on lenny, without any errors (thank you!). Just now I did an update and safe-upgrade using aptitude and got some new errors. Should packages made for lenny be requiring a newer version of libncurses5 not included in the lenny repository?

Here’s the output of “aptitude -y safe-upgrade”

Reading package lists… Done
Building dependency tree
Reading state information… Done
Reading extended state information
Initializing package states… Done
Reading task descriptions… Done
The following packages are BROKEN:
libapache2-mod-php5 mysql-client-5.1 php5-gd
The following packages will be upgraded:
mysql-server-5.1 mysql-server-core-5.1 php5 php5-apc php5-common php5-mysql
The following packages are RECOMMENDED but will NOT be installed:
libhtml-template-perl php5-cli php5-suhosin
9 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 23.9MB of archives. After unpacking 701kB will be freed.
The following packages have unmet dependencies:
mysql-client-5.1: Depends: libncurses5 (>= 5.7+20100313) but 5.7+20081213-1 is installed.
Depends: libreadline6 (>= 6.0) which is a virtual package.
php5-gd: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is installed.
Depends: libjpeg62 (>= 6b1) but 6b-14 is installed.
libapache2-mod-php5: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is installed.
Depends: libdb4.8 which is a virtual package.
Depends: libgssapi-krb5-2 (>= 1.6.dfsg.2) which is a virtual package.
Depends: libicu44 (>= 4.4.1-1) which is a virtual package.
Depends: libk5crypto3 (>= 1.6.dfsg.2) which is a virtual package.
Depends: libkrb5-3 (>= 1.6.dfsg.2) which is a virtual package.
Depends: libonig2 (>= 5.2.0) but it is not installable
Depends: libqdbm14 (>= 1.8.74) but it is not installable
Depends: libssl0.9.8 (>= 0.9.8m-1) but 0.9.8g-15+lenny11 is installed.
Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5+lenny3 is installed.
Unable to resolve dependencies for the upgrade (no solution found).The following packages have been kept back:
libapache2-mod-php5{a} mysql-client-5.1{a} mysql-server-5.1{a} mysql-server-core-5.1{a} php5
php5-apc php5-common{a} php5-gd php5-mysql
0 packages upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reading extended state information
Initializing package states… Done
Reading task descriptions… Done

Current status: 0 broken [+0], 9 updates [+0], 28 new [+0].

where are the source packages for php5-apc_5.2.17-0.dotdeb.0_i386.deb ? apt-get source doesn’t find them – is it part of the main php package source ?

Comments are closed.