Posted by & filed under MySQL.

I already talked about Pinba, this great Application Performance Monitoring (APM) tool that is made of :

  • a MySQL storage engine (pinba-mysql-5.5),
  • a PHP extension (php5-pinba),
  • and even a python module, pynba, (thanks to my IsCool Entertainment friends) and an experimental Nginx module.

But sinceΒ MySQL 5.1 support has been discontinued on Dotdeb, it was impossible to install the Pinba MySQL storage engine, just because it depended on a non-existant MySQL 5.1 version.

This problem is now fixed and I’m proud to announce that the Pinba storage engine version 1.0.0 is now compatible with Dotdeb’s MySQL 5.5 packages. Just install the pinba-mysql-5.5 package and add the following line to your MySQL configuration file :

plugin-load=libpinba_engine.so

About the PHP extensions, they will be updated from version 0.0.6 to version 1.0.0 with the upcoming PHP 5.4.6 and 5.3.16 packages.

Please visit the Pinba website fore more info (changes, installation, support…).

18 Responses to “Pinba engine 1.0.0”

  1. mikhal

    Is this safe with yours mysql percona package (5.5.25a-27.1-log)? When i try to install, it ask to install mysql-server-core-5.5

    apt-get install pinba-mysql-5.5
    ….
    The following NEW packages will be installed:
    libjudydebian1 libprotobuf-lite6 mysql-server-core-5.5 pinba-mysql-5.5

  2. Guillaume Plessis

    @mikhal : Sadly, because of the internal MySQL storage engine mechanics, Pinba from Dotdeb is strongly tied with the MySQL version it has been built against. You’ll have to :

    • install MySQL 5.5 from Dotdeb if you want to install pinba-mysql-5.5
    • or rebuild pinba-mysql-5.5 against your MySQL/Percona version (might be tricky)
  3. mikhal

    @Guillaume Plessis, seems i have to install mysql 5.5 to another server to collect pinba data and do not corrupt production server

    thanks for the answer and for this cool site with latest builds πŸ˜‰

  4. silver price

    To upgrade to 5.1 from any previous version, MySQL recommends that you dump your tables with mysqldump before upgrading and reload the dump file after upgrading.

  5. Mayur Ahir

    I am getting this error,

    # sudo apt-get install php5-pinba
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-pinba : Depends: libprotobuf6 but it is not installable
    E: Unable to correct problems, you have held broken packages.

    Please help.

  6. Ovidiu

    trying to install:

    ‘apt-get install pinba-engine-mysql-5.5 -u
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    pinba-engine-mysql-5.5 : Depends: mysql-server-core-5.5 (< 5.5.36) but 5.5.37-0+wheezy1 is to be installed
    E: Unable to correct problems, you have held broken packages.'

    'apt-get install mysql-server-core-5.5 -u -s
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following NEW packages will be installed:
    mysql-server-core-5.5
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Inst mysql-server-core-5.5 (5.5.37-0+wheezy1 Debian-Security:7.0/stable [amd64])
    Conf mysql-server-core-5.5 (5.5.37-0+wheezy1 Debian-Security:7.0/stable [amd64])'

    So I guess I need to install mysql-server-core-5.5 from Dotdeb not from Debian-Security

    Can I get a hint on how to do that?

  7. Guillaume Plessis

    @Ovidiu : sorry, I have to rebuild pinba-engine-mysql-5.5 against the latest packages from Debian security to satisfy the dependency. It should be fixed in the next few hours.

  8. Ovidiu

    Hi Guillaume,

    did you get a chance to look at this?

  9. Ovidiu

    Does this error ring any bells with you? Will also google it, thought to ask here first…

    An error occurred while installing the database:
    β”‚
    β”‚ mysql said: ERROR 1126 (HY000) at line 1: Can’t open shared library
    β”‚ ‘/usr/lib/mysql/plugin/libpinba_engine.so’ (errno: 2
    β”‚ /usr/lib/mysql/plugin/libpinba_engine.so: undefined symbol:
    β”‚ _ZN7handler22read_multi_range_firstEPP18st_key_multi_rangeS1_jbP17st)
    β”‚
    β”‚ If at this point you choose “retry”, you will be prompted with all the
    β”‚ configuration questions once more and another attempt will be made at performing

  10. Guillaume Plessis

    @Ovidiu : I’ll take a further look and keep you posted. Could you please give me the result of this command?

    dpkg -l '*mysql*' | grep '^.i'

    Thanks

  11. Ovidiu

    sorry,was out of town and offline :-/

    dpkg -l ‘*mysql*’ | grep ‘^.i’
    ii dovecot-mysql 1:2.1.7-7 amd64 MySQL support for Dovecot
    ii libdbd-mysql-perl 4.021-1+b1 amd64 Perl5 database interface to the MySQL database
    ii libmysqlclient18:amd64 5.6.17-1~dotdeb.1 amd64 MySQL database client library
    ii mysql-client 5.6.17-1~dotdeb.1 all MySQL database client (metapackage depending on the latest version)
    ii mysql-client-5.5 5.5.37-0+wheezy1 amd64 MySQL database client binaries
    ii mysql-client-5.6 5.6.17-1~dotdeb.1 amd64 MySQL database client binaries
    ii mysql-client-core-5.6 5.6.17-1~dotdeb.1 amd64 MySQL database core client binaries
    ii mysql-common 5.6.17-1~dotdeb.1 all MySQL database common files, e.g. /etc/mysql/my.cnf
    ii mysql-server 5.6.17-1~dotdeb.1 all MySQL database server (metapackage depending on the latest version)
    ii mysql-server-5.6 5.6.17-1~dotdeb.1 amd64 MySQL database server binaries and system database setup
    ii mysql-server-core-5.5 5.5.37-0+wheezy1 amd64 MySQL database server binaries
    ii mysql-server-core-5.6 5.6.17-1~dotdeb.1 amd64 MySQL database server binaries
    ii mysql-utilities 1.0.5-1 all collection of scripts for managing MySQL servers
    ii php5-mysqlnd 5.4.28-1~dotdeb.1 amd64 MySQL module for php5 (Native Driver)
    ii pinba-engine-mysql-5.5 1.0.0-4~dotdeb.2 amd64 realtime statistics server for PHP using MySQL as a read-only interface
    ii postfix-mysql 2.9.6-2 amd64 MySQL map support for Postfix
    ii pure-ftpd-mysql 1.0.36-1.1 amd64 Secure and efficient FTP server with MySQL user authentication
    ii python-mysql.connector 0.3.2-1 all pure Python implementation of MySQL Client/Server protocol
    ii python-mysqldb 1.2.3-2 amd64 Python interface to MySQL

  12. Guillaume Plessis

    @Ovidiu : the Pinba storage engine has been build against MySQL 5.5. Could you please install ‘*-5.5’ packages only and try to load the module?

  13. Ovidiu

    Hi Guillaume,

    I tried fixing it on my own for a few days then gave up and removed it alltogether. Didn’T have the time to keep trying and fixing it. Maybe with the next release I’ll try again.

  14. Phil

    Hi,
    there is still a error in pinba:

    pinba-engine-mysql-5.5 : Depends: mysql-server-core-5.5 (< 5.5.38) but 5.5.38-0+wheezy1 is to be installed