PHP 5.4.8 and PHP 5.3.18

On october 18th 2012, the PHP group has released PHP 5.4.8 and PHP 5.3.18, that bring ~20 bug fixes. The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

31 replies on “PHP 5.4.8 and PHP 5.3.18”

A very solid update. Personally, I did not experience these issues with starting and stopping the PHP-FPM daemon, but nevertheless, the bugfixes were necessary. Keep the good work up, Dotdeb!

Running into an issue with php5-cli, it’s apparently not working. I wrote a little php script and when I try and execute, it fails. Can’t figure this out. From the web site it seems to be working but CLI is not.


I just upgraded from PHP 5.3.14 to 5.3.18. I have no more segmentation faults when using xcache PHP module in combination with ionCubeLoader PHP module like in PHP versions 5.3.14 till 5.3.17. The PHP team finally did it ;).

Best wishes

Ok here are my results: Since PHP 5.3.18 I can use XCache with a workaround again in combination with ionCubeLoader PHP module. I have to load the module as “”. If I load it as zend extension (as recommended), I get again segmentation faults like in PHP 5.3.15+.

I’ve update PHP to 5.4.8 on Ubuntu 12.04 but it has broken Xdebug. I’m now getting:

dpkg: dependency problems prevent configuration of php5-xdebug:
php5-xdebug depends on php5-common (= 5.4.7-1~dotdeb.0); however:
Version of php5-common on system is 5.4.8-1~dotdeb.0.
dpkg: error processing php5-xdebug (–configure):
Any ideas to fix this?
Many thanks

Thanks for the swift reply. I get
# apt-get install php5-xdebug = 5.4.8-1~dotdeb.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package
E: Unable to locate package 5.4.8-1~dotdeb.0
E: Couldn’t find any package by regex ‘5.4.8-1~dotdeb.0’

oops, sorry. However, I now get:
php5-xdebug depends on php5-common (= 5.4.7-1~dotdeb.0); however:
Version of php5-common on system is 5.4.8-1~dotdeb.0.
dpkg: error processing php5-xdebug (–configure):

Sorry, I have to go. I’ll catch up tomorrow, but thanks for your time.

I need some help… I’m trying to upgrade PHP to latest, and it states that it depends on libmysqlclient16 (16? I thought we were on 18 now…?). For some reason, I can’t install 16 – it says there are no installation candidates.

@Jason : Dotdeb is built for Debian stable. Debian stable contains libmysqlclient16.
If you use Dotdeb with another distribution (at your own risk), install php5-mysqlnd instead of php5-mysql : The MySQL native driver doesn’t depend on any libmysqlclient package.

I am new with nginx and php-fpm. I install dotdeb repo but I got 502 Bad Gateway with my simple phpinfo. Static html is fine. I Google the problem but still not able to find the solution. Please help. Thanks!

If I want to upgrade my php 5.3 (installed via dotdeb) to php 5.4 (dotdeb) is there a simple way? or do I need to remove all my php and then do a fresh install of php 5.4?

I seem to be getting an error when i try to install php-apc.

aptitude install php-apc
The following NEW packages will be installed:
The following packages will be REMOVED:
libonig2{u} libqdbm14{u} php5-common{u}
0 packages upgraded, 1 newly installed, 3 to remove and 0 not upgraded.
Need to get 82.9 kB of archives. After unpacking 3,066 kB will be freed.
The following packages have unmet dependencies:
php-apc: Depends: phpapi-20090626 which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) php-apc [Not Installed]

Accept this solution? [Y/n/q/?]

Hello there ,
I have question please ,
how can i remove the php 5.3.18 completely , cause i do upgrade my php to 5.3.18 then i got a lot of problems on my localhost ,
i tried removing all my php mysql apache server using the command line
sudo apt-get remove apache2* mysql-server* php5* phpmyadmin
and after that when i check for any php version using the command line is says no php5 is installed no mysql no apache , but from the browser using the phpinfo function i got PHP Version 5.3.18-1~dotdeb.0 and Client API version mysqlnd 5.0.8-dev …

can you help me .

Have a question. I see xcache package in dotdeb only have cacher module built. The package in debian site have more, like “cacher optimizer coverager assembler disassembler encoder decoder”. Is it make difference?

Sorry my english is poor.

Thank you a lot Guillaume, you do a wonderful job by maintain all these LAMP packages always up-to-date!

Well, now I’m facing some problems unfortunately. The installation went fine, but when trying to call a php script the browser just downloads it in plain text. So it seems PHP5 is not enabled on the server.

So I tried a2enmod php5 which went fine. But when trying to restart Apache I get the following message:

apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ cannot open shared object file: No such file or directory
Action ‘configtest’ failed.

It seems there was some interference with a previous php installation. I did “aptitude remove php5-cgi” and after that a “apt-get install –reinstall php5-xdebug=5.4.8-1~dotdeb.0” worked!

Thanks for this release.
It would be nice if php-cli was complied with –enable-maintainer-zts option for using pthreads pecl module for example 🙂

I have been having problems trying to have a LAMP configuration. In a quick snapshot, my issues are:
i. Have RHEL 6.1 and had (:() PHP 5.3.3 and have MySQL 5.1.52.
ii. PHP was working fine, but MySQL Connectivity was not.
iii. Installed PHP 5.4.8. I am a novice and do not know how to make the system recognize PHP 5.4.8, instead of 5.3.3. Now, since I removed 5.3.3, no more PHP scripting:(; But, php -v shows 5.4.8.
iv. I have yet to connect MySQL.

Also, I am on a Virtual Machine; therefore, please do not suggest apt_gets:).

Please help.
– Guru Prasad

Comments are closed.