Posted by & filed under PHP.

On April 11th 2013, the PHP group has released PHP 5.4.14.

These releases fix about 10 bugs aswell as upgrading the bundled PCRE library. All users of PHP are encouraged to upgrade to PHP 5.4.14.

The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures with the following changes. As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

22 Responses to “PHP 5.4.14”

  1. hanti

    thx for update
    but it seems geoip and imagick are not updated

    The following packages have unmet dependencies:
    php5-geoip : Depends: php5-common (= 5.4.13-1~dotdeb.1) but 5.4.14-1~dotdeb.1 is to be installed

    The following packages have unmet dependencies:
    php5-imagick : Depends: php5-common (= 5.4.13-1~dotdeb.1) but 5.4.14-1~dotdeb.1 is to be installed

  2. Rohit Yadav

    I’m getting conflicts with php5-common and php5-suhosin on my Debian6 system.

    • Guillaume Plessis

      @Rohit : could you be more specific and paste the exact message of conflict, please? FYI, there’s no php5-suhosin package for PHP 5.4

  3. Jerome Warnier

    There are definitely migration problems because of the new “mods-available” feature. The old .ini files in conf.d do not get removed, but new symlinks are added to basically provide the same purpose.

  4. David Manners

    Big thank you for this update. It has been working well for me for a while.

    Though I went to install php5-intl today and got the following:

    php5-intl : Depends: phpapi-20090626
    Depends: php5-common (= 5.3.3-7+squeeze14) but 5.4.14-1~dotdeb.1 is to be installed

    Any help would be great.


  5. David Manners

    @Guillaume Plessis: So it turns out that I needed to upgrade first to PHP 5.4.14-1~dotdeb.1 before I could install php5-intl.

    Now I have done the upgrade everything has installed nicely.

    Thank you for your help.

  6. @Mikl

    J’ai une tuile lorsque j’essai l’installer php5-fpm:

    php5-fpm : Dépend: php5-common (= 5.4.4-14) mais 5.4.14-1~dotdeb.1 devra être installé

    ## Debian Squeeze sources.list

    ## FR mirror
    deb wheezy main contrib non-free
    deb-src wheezy main contrib non-free

    ## Debian security updates
    deb wheezy/updates main contrib non-free
    deb-src wheezy/updates main contrib non-free

    deb wheezy-backports main

    deb wheezy all
    deb-src wheezy all

    Quelqu’un pour m’aider ?
    merci par avance

    • Guillaume Plessis

      @Miki : les paquets de PHP 5.4 pour Wheezy ne sont pas encore prêts. En attendant, tu peux ajouter les lignes suivantes dans ton sources.list pour corriger le souci :

      deb squeeze-php54 all