PHP 5.5.0 is out and available for Debian 7.0 “Wheezy”

On June 20th 2013, the PHP group has released the first stable version of PHP 5.5.

The key features of PHP 5.5.0 include:

  • Added generators and coroutines.
  • Added “finally” keyword.
  • Added simplified password hashing API.
  • Added support for constant array/string dereferencing.
  • Added Class Name Resolution As Scalar Via “class” Keyword
  • Added support for using empty() on the result of function calls and other expressions
  • Added support for non-scalar Iterator keys in foreach
  • Added support for list in foreach
  • Added Zend Opcache extension and enable building it by default.
  • The GD library has been upgraded to version 2.1 adding new functions and improve existing functionality.
  • A lot more improvements and fixes

Changes that affect compatibility:

  • PHP logo GUIDs have been removed
  • Windows XP and 2003 support dropped
  • Case insensitivity is no longer locale specific. All case insensitive matching for function, class and constant names is now performed in a locale independent manner according to ASCII rules

I’m proud to announce that the corresponding packages are now available on Dotdeb for Debian 7.0 “Wheezy”, on both amd64 and i386 architectures.

To upgrade your Wheezy boxes to PHP 5.5.0, just add these two lines to your sources.list :

deb wheezy-php55 all
deb-src wheezy-php55 all

Please note that :

  • php5-apc is not available for PHP 5.5 yet. Instead, PHP OPcache (the open-sourced Zend Optimizer+) has been included and activated by default in php5-common. And if you need a user cache, please install php5-apcu.
  • php5-xcache is missing too. Don’t upgrade if you need it.
  • PHP 5.4 will still be considered as default branch on Debian 7.0
  • PHP 5.5 won’t be packaged for Debian 6.0 “Squeeze”. Upgrade to Wheezy instead.

Please read the Changelog and the migration guide (be aware of the backward incompatible changes) before upgrading.

Last but not least, if you like Dotdeb, feel free to show your support.

58 replies on “PHP 5.5.0 is out and available for Debian 7.0 “Wheezy””

Works fine! Great Job! Thank you!

By the way: can dotdeb host the packages for MariaDB? 🙂

Hello I add repo to my sourcelist and run aptitude update — but I am still on 5.4. My linux is: Linux version 3.2.0-4-amd64 ([email protected]) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.41-2+deb7u2

Where can be problem?

Thanks, but I had error on a clean install of Apache2, & php : Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP [..]
What could I do ?

@John : I have to think about it, but running mod_php with the worker is really not recommended, because of non-thread-safe third-party library. I advise you to use PHP-FPM instead.

re php5-geoip, this is what aptitude gives me when I try to do a dist-upgrade:
The following packages have unmet dependencies:
php5-apc : Depends: phpapi-20100525+lfs which is a virtual package.
Depends: php5-common (= 5.4.16-1~dotdeb.1) but 5.5.0-1~dotdeb.1 is to be installed.
php5-geoip : Depends: phpapi-20100525+lfs which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
1) php5-apc
2) php5-geoip

Accept this solution? [Y/n/q/?]

@Daniel : APC isn’t neither compatible nor available for PHP 5.5 yet. You’ll have to uninstall it before upgrading. But don’t worry, opcache is included in php5-common (and enabled by default) while php5-apcu can handle the user cache part.

Thanks, I’m aware that APC isn’t available, but that error is also saying that GeoIP is not available. I need the GeoIP package and don’t want to have to compile it manually, so I’m scared to upgrade…

Never mind, I fixed the GeoIP issue. Turns out I had the Debian GeoIP package installed (version 1.0.8) and the upgrade didn’t want to upgrade it for some reason. I used Aptitude to force an upgrade to that package.

Look like php5-fpm is broken.

Настраивается пакет php5-fpm (5.5.0-1~dotdeb.1) …
invoke-rc.d: initscript php5-fpm, action “start” failed.
dpkg: error processing php5-fpm (–configure):

I’m also really struggling with this. I tried php5-fpm instead but there’s no libapache2-mod-fastcgi

updated to php5.5 and the init.d startscript for php5-fpm is broken:

/etc/init.d/php5-fpm: 37: /etc/init.d/php5-fpm: init_is_upstart: not found

Any idea what went wrong?

If you have problems with upstart check out dmesg:
sudo dmesg | grep php

If it says something regarding php5-fpm pre-start process terminated with status 1
Check out the fie /etc/init/php5-fpm.conf
to see what is the prestart process. Perhaps run it manually from the console and check for errors.

I had an error saying
failed to open error_log (/var/log/php5-fpm.log): Permission denied (13)

You might have another case. Check it out.

Hi (i’m french),

I’ve this error next update :

root# php -v
bash: /usr/bin/php: Aucun fichier ou dossier de ce type

How can I fix this ?

All my dependances of php has been removed.
I did this :
root# apt-get dist-upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Calcul de la mise à jour… Fait
Les paquets suivants seront ENLEVÃSÂ :
libapache2-mod-php5 php5 php5-cli php5-fpm php5-mcrypt php5-mysql
Les NOUVEAUX paquets suivants seront installés :
libltdl7 libonig2 libqdbm14
Les paquets suivants seront mis à jour :
1 mis à jour, 3 nouvellement installés, 6 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 011 ko dans les archives.
Après cette opération, 24,2 Mo d’espace disque seront libérés.
Souhaitez-vous continuer [O/n]Â ?
Réception de : 1 wheezy-php55/all php5-common amd64 5.5.1-1~dotdeb.1 [682 kB]
Réception de : 2 precise/main libltdl7 amd64 2.4.2-1ubuntu1 [37,6 kB]
Réception de : 3 precise/universe libonig2 amd64 5.9.1-1 [147 kB]
Réception de : 4 precise/universe libqdbm14 amd64 1.8.78-1build2 [144 kB]
1 011 ko réceptionnés en 0s (6 397 ko/s)
(Lecture de la base de données… 55450 fichiers et répertoires déjà installés.)
Suppression de php5 …
Suppression de libapache2-mod-php5 …
Module php5 disabled.
To activate the new configuration, you need to run:
service apache2 restart
Suppression de php5-cli …
Suppression de php5-mysql …
Suppression de php5-mcrypt …
Suppression de php5-fpm …
Traitement des actions différées (« triggers ») pour « man-db »…
Traitement des actions différées (« triggers ») pour « ureadahead »…
Sélection du paquet libltdl7 précédemment désélectionné.
(Lecture de la base de données… 55427 fichiers et répertoires déjà installés.)
Dépaquetage de libltdl7 (à partir de …/libltdl7_2.4.2-1ubuntu1_amd64.deb) …
Préparation du remplacement de php5-common 5.3.10-1ubuntu3.7 (en utilisant …/php5-common_5.5.1-1~dotdeb.1_amd64.deb) …
Dépaquetage de la mise à jour de php5-common …
Sélection du paquet libonig2 précédemment désélectionné.
Dépaquetage de libonig2 (à partir de …/libonig2_5.9.1-1_amd64.deb) …
Sélection du paquet libqdbm14 précédemment désélectionné.
Dépaquetage de libqdbm14 (à partir de …/libqdbm14_1.8.78-1build2_amd64.deb) …
Paramétrage de libltdl7 (2.4.2-1ubuntu1) …
Paramétrage de php5-common (5.5.1-1~dotdeb.1) …
Installation de la nouvelle version du fichier de configuration /etc/cron.d/php5 …

Creating config file /etc/php5/mods-available/pdo.ini with new version

Creating config file /etc/php5/mods-available/opcache.ini with new version
Paramétrage de libonig2 (5.9.1-1) …
Paramétrage de libqdbm14 (1.8.78-1build2) …
Traitement des actions différées (« triggers ») pour « libc-bin »…
ldconfig deferred processing now taking place

@mstrasser : bonjour Mathias. Les paquets Dotdeb sont construits pour Debian. Ils doivent marcher sur Ubuntu, mais aucun support n’est garanti.
Ton problème, c’est que le paquet php5-cli a été supprimé, certainement à cause d’une dépendance non satisfaite. Essaie d’utiliser un logiciel tel que aptitude, dselect, voire synaptic, afin de savoir quelle est la dépendance qui empêche l’installation de php5-cli.

I have similar problem with php5-fpm.

It is on debian7. status/start/stop does not give anything… I think it is something to do with upstart, but can’t figure out.

any ideas anyone?:)

I have a clean debian wheezy installation, with PHP 5.5.4-1~dotdeb.1 installed by apt-get just like apache2. I had to manually enable the php5 module, and since then, when I try to reload apache2 I get this error: [Sat Sep 28 21:44:25 2013] [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP.
Pre-configuration failed
Action ‘configtest’ failed.
The Apache error log may have more information.
Any idea?

Same problem than @Etienne.
Same error message.
Just a simple Lamp installation but impossible to run php5 code. =/
What’s wrong with us ?

herbalife online store in tthe January 2009 issue of the
“Journal of Hepatology”. If you ave an tchy rash
or a round, the lotion will help calm thhe irritation.
Foor indigestion, anxiety and insomnia, take some Chamomile in teea

Is anyone using Ansible with Dotdeb? I can’t seem to have both the standard and php55 repos working with apt_repository action.

@Etienne @Helias @Guillaume Plessis

Looks like some installations of Debian 7 Wheezy installs Apache 2 with apache2-mpm-worker package by default. With this package, the build of php provided by dotdeb doesn’t work out of the box, and gives that must recompile error. If instead, you install apache2-mpm-prefork, it will work.

Hope this helps,

To remove the error :

[crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe

on debian 7 :

apt-get remove apache2-mpm-worker
apt-get apache2 apache2-mpm-prefork (normally already install)

Okay, that was quite easy to fix: I upgraded Ansible from Version 1.2 to Version 1.7 and now it works 😉 – Just have to fix all my playbooks now to be compatible 🙁

I cannot access the software.
“Unable to locate package php55” or php5 or php4. Can you help? I’ve performed the update.

Comments are closed.