Categories
PHP

PHP 5.4.20, for Wheezy and Squeeze

On September 19th 2013, the PHP group has released PHP 5.4.20. About 30 bugs were fixed. All PHP 5.4 users are encouraged to upgrade to this version.

The corresponding packages are now available on Dotdeb :

  • for Debian 7.0 “Wheezy” and Debian 6.0 “Squeeze”,
  • on both amd64 and i386 architectures.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

And if you find Dotdeb useful, feel free to show your support.

8 replies on “PHP 5.4.20, for Wheezy and Squeeze”

This auto installed last night but broke my production installation. The /etc/php5/fpm/pool.d/www.conf file was automatically overwritten. Is this a bug with your package that can be fixed?

We’re having unmet dependencies on php 5.4 for Squeeze:

Depends on libmemcached10, but there is no candidate? I updated the repositories (apt-get update), but to no avail.

Thank you Guillaume, that fixed it 🙂
I was under the impression all dependencies would’ve been under the same repo.

Can you help me?
I’m just open Debian for myself. I used to use XAMPP only previously.
So, for my server I’ve installed
1) debian6.0-x86_64
2) http://cdn.mysql.com/Downloads/MySQL-5.5/mysql-5.5.33-debian6.0-x86_64.deb
3) PHP 5.4.20 from that article.
4) php5-mysqlnd
5) Fill mysql.default_socket, mysqli.default_socket, pdo_mysql.default_socket = /tpm/mysql.sock in php.ini

As result. Php works good. Mysql server works from console.
But I can’t get mysql working from php.
As example:
mysql_connect(“localhost”, “root”, “”) or die(mysql_errno() . ‘ – ‘ . mysql_error());
returns me 2002 – No such file or directory.

What I’m doing wrong? Thank you!!

Hmm, looks like php5-mysql has some issues:

# php -v
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20100525/pdo_mysql.so’ – /usr/lib/php5/20100525/pdo_mysql.so: undefined symbol: pdo_parse_params in Unknown on line 0
PHP 5.4.20-1~dotdeb.1 (cli) (built: Sep 21 2013 22:24:38)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
with the ionCube PHP Loader v4.4.1, Copyright (c) 2002-2013, by ionCube Ltd.

MySQL connectivity no longer works after this upgrade, please advice.

@Guillaum, on Debian squeeze PHP 5.4.20 is installed from dotdeb. Now I’m trying to install php-fpm, which reports:
php5-fpm : Depends: php5-common (= 5.3.27-1~dotdeb.0) but 5.4.20-1~dotdeb.0 is to be installed
How to do with that? Thanks!

Comments are closed.