Categories
PHP

PHP 5.4.30, for Wheezy and Squeeze

On June 26th 2014, the PHP group has released PHP 5.4.30. Over 20 bugs were fixed in this release, including the following security issues: CVE-2014-3981, CVE-2014-0207, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-4049, CVE-2014-3515. All PHP 5.4 users are encouraged to upgrade to this version.

The corresponding packages are now available on Dotdeb :

  • for Debian 7 “Wheezy” and Debian 6 “Squeeze”,
  • on both amd64 and i386 architectures.

The following modules have been packaged too :

  • APC 3.1.13
  • apcu 4.0.6
  • ffmpeg 0.6.0 (Squeeze only)
  • gearman 0.8.3
  • geoip 1.0.8
  • imagick 3.1.2
  • memcache 3.0.8
  • memcached 2.2.0
  • mongo 1.5.4
  • pecl_http 1.7.6
  • pinba (master)
  • redis 2.2.5
  • spplus 1.1
  • ssh2 0.12
  • xcache 3.1.0
  • xdebug 2.2.5
  • xhprof 0.9.4
  • zendopcache 7.0.3

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

And if you find Dotdeb useful, feel free to show your support.

16 replies on “PHP 5.4.30, for Wheezy and Squeeze”

Hi,

Yes I’ve done that now https://github.com/gplessis/dotdeb-php5/issues/58

One thing I noticed is that dpkg -l ‘php*’ | grep ‘^.i’ tells me I have php 5.5.14 but I ran apt-get update again and I’m currently on the latest available..

Hopefully we can get this fixed, I don’t have the issue on my other servers, I really don’t know what’s different.

Thanks

Issue above has been fixed. I’m still wondering about the php version though, post says 5.5.30, but 5.5.14 installed ?

Thanks

Hi,

I’ve added the dotdeb repos to a server running squeeze and added the squeeze-php54 lines also.

I then apt-get update && upgrade

It says its upgrading various components of php but now I have an older version than is currently shipped with squeeze?

php -v
PHP 5.3.28-1~dotdeb.0 with Suhosin-Patch (cli) (built: Dec 13 2013 01:38:56)

What am I missing?

Thanks!
Brian

I’m trying to disable warning messages (php 5.4.30) ..
I tried to set the error_reporting variable and restart apache .. but the warnings remain. is a bug? how can I fix it?

– Warning: Illegal string offset ‘type’ in etc etc…
– Strict Standards: Non-static method … on line XX

thanks for your reply

@Nello : could you please :

  1. check that you’re editing the right php.ini among /etc/php5/*/php.ini
  2. check that your Apache vhosts / FPM pools’ configuration / .htaccess do not override the error reporting level
  3. restart Apache2 or your PHP-FPM pools if needed
  4. check that your application does not override the errort reporting level via ini_set() or error_reporting()
  5. display or log the error reporting level at strategic places in your code to know what happens

resolved, thanks..

but I notice this:

if i print connection to db with print_r
[client_info] => 5.1.73 50173
…..
[server_info] => 5.5.31-1~dotdeb.0-log
[server_version] => 50531

Comments are closed.