Posted by & filed under PHP.

On July 10th 2015, the PHP group released PHP 5.6.11.

Five security-related issues in PHP were fixed in this release, including CVE-2015-3152. All PHP 5.6 users are encouraged to upgrade to this version.

PHP 5.6.11 packages are now available for Debian 7 “Wheezy”, on both amd64 and i386 architectures, in ZTS and non-ZTS (default) flavors, along with the usual PECL extensions.

Note : php5-memcached still lacks JSON support.

13 Responses to “PHP 5.6.11 for Wheezy”

  1. Michael

    Hello,

    the php xcache module is still missing. Will it be included in future releases or is there no intention to support it in the PHP 5.6.x packages for Debian Wheezy?

    Best regards
    Michael

  2. Paul

    After upgrade from PHP 5.6.10 to 5.6.11 I can’t restart PHP, I’m using non TS version of PHP, Debian is working on VM (VirtualBox 5.0) and I get following error message:

    [….] Restarting PHP5 FastCGI Process Manager: php5-fpm*** glibc detected *** /usr/sbin/php5-fpm: free(): invalid pointer: 0x00007fa0a2beeaf8 ***
    ======= Backtrace: =========
    /lib/x86_64-linux-gnu/libc.so.6(+0x75be6)[0x7fa0d3ecfbe6]
    /lib/x86_64-linux-gnu/libc.so.6(cfree+0x6c)[0x7fa0d3ed498c]
    /usr/sbin/php5-fpm(php_module_shutdown+0x2b)[0x695a0b]



    7ffc9756b000-7ffc9756c000 r-xp 00000000 00:00 0 [vdso]
    ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
    failed!

  3. Chrome

    Dear Guillaume,

    Do yo have any plans for creating php5-pinba extension package for php 5.6?

    Thank you.

  4. Guillaume Plessis

    @bill : Jessie a déjà des paquets de PHP 5.6.9, avec les corrections de sécurité incluses. Je ne souhaite pas dupliquer l’effort, je préfère me concentrer sur PHP 7 pour Jessie lorsqu’il sera déclaré comme stable.

  5. bill

    arf ok, je souhaité avoir la dernière version de php, il existe pas d’autre repository avec 5.6.11 pour jessie a ta connaissance ?

  6. Vincent

    Bonjour,

    Est-ce que des paquets php 5.6 sont (ou seront) disponibles pour squeeze ?

    Merci
    Vincent

  7. Guillaume Plessis

    @Vincent : non, désolé. Le support étendu de sécurité (LTS) de Squeeze se termine en février 2016, il est temps de penser à mettre à jour 🙂