On October 1st 2015, the PHP group released PHP 5.5.30.
This is a security release. Two security bugs were fixed in this release. All PHP 5.5 users are encouraged to upgrade to this version.
PHP 5.5.30 packages are now available on Dotdeb for Debian 7 “Wheezy”, on both amd64 and i386 architectures.
The following modules have been packaged too :
- apcu 4.0.7
- gearman 0.8.3
- geoip 1.0.8
- imagick 3.1.2
- memcache 3.0.8
- memcached 2.2.0
- mongo 1.6.11
- pecl_http 1.7.6
- pinba (master)
- redis 2.2.7
- spplus 1.1
- ssh2 0.12
- xcache 3.2.0
- xdebug 2.3.2
- xhprof 0.9.4
Please read the Changelog before upgrading.
5 replies on “PHP 5.5.30 for Wheezy”
Works fine, thank you very much!
My memcached not working anymore … using wheezy all
Error at apt-get install php5-memcached:
# Depends: phpapi-20100525
# Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.5.30-1~dotdeb+
@Sanjo : it looks like you’re trying to mix 5.4 and 5.5 version. Which is your target?
Same here, cannot install php5-memcached on wheezy:
# php -v
PHP 5.5.30-1~dotdeb+7.1 (cli) (built: Oct 1 2015 17:38:39)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
# apt-get install php5-memcached
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
php5-memcached : Depends: libmemcached11 but it is not installable
E: Unable to correct problems, you have held broken packages.
@Benoit : according to the instructions, could you please make sure that you have both wheezy AND wheezy-php55 lines in your sources.list (the first one provides libmemcached11)?