Posted by & filed under PHP.

On March 3rd 2016, the PHP group released PHP 5.6.19.

This is a security release in which several security bugs were fixed. All PHP 5.6 users are encouraged to upgrade to this version.

PHP 5.6.19 packages are now available for Debian 7 “Wheezy”, on both amd64 and i386 architectures, in ZTS and non-ZTS (default) flavors, along with the usual PECL extensions.

22 Responses to “PHP 5.6.19 for Wheezy”

  1. Noel


    Je souhaites savoir si cette version de PHP sur wheezy est compatible avec apache 2.2?

    Merci d’avance pour la réponse!



  2. Jaroslav


    I can’t install php5-sybase package.
    I get this:
    The following packages have unmet dependencies:
    php5-sybase : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.19-1~dotdeb+7.1 is to be installed

    Is there anything I can do about it in the ‘proper’ way?
    Thank you

  3. Guillaume Plessis

    @Jaroslav : it is strange, because the php5-sybase package is present in the wheezy-php56 repo. Could you please use dselect or aptitude to find which dependency or package prevents the upgrade?

  4. Jaroslav

    Hello Guilllaume Plessis,

    using aptitude I see this:

    # aptitude install php5-sybase
    The following NEW packages will be installed:
    apache2-mpm-prefork{a} apache2-utils{a} apache2.2-bin{a} apache2.2-common{a} libapache2-mod-php5filter{ab} libapr1{a} libaprutil1{a} libaprutil1-dbd-sqlite3{a}
    libaprutil1-ldap{a} php5-sybase{b}
    The following packages will be REMOVED:
    libboost-filesystem1.49.0{u} libboost-program-options1.49.0{u} libboost-system1.49.0{u} libboost-thread1.49.0{u} libgearman6{u} libnet-daemon-perl{u} libpcrecpp0{u}
    0 packages upgraded, 10 newly installed, 8 to remove and 44 not upgraded.
    Need to get 4,302 kB of archives. After unpacking 13.7 MB will be used.
    The following packages have unmet dependencies:
    libapache2-mod-php5filter : Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.19-1~dotdeb+7.1 is installed.
    php5-sybase : Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.19-1~dotdeb+7.1 is installed.
    The following actions will resolve these dependencies:

    Keep the following packages at their current version:
    1) libapache2-mod-php5filter [Not Installed]
    2) php5-sybase [Not Installed]

    Actually I am using nginx, not sure why it needs apache2 php5filter

    Thank you

  5. Guillaume Plessis

    @Jaroslav : why is your system trying to upgrade from 5.4.45 to 5.6.19. Please check your sources.list and launch “apt-get update” before any further move, depending on which PHP version you want.

  6. Jaroslav

    Hello @Guillaume

    well souces.list is quote general:
    # Dotdeb stuff
    deb wheezy all
    deb-src wheezy all

    #deb wheezy-php55 all
    #deb-src wheezy-php55 all
    deb wheezy-php56 all
    deb-src wheezy-php56 all

    # Java
    #deb precise main
    #deb-src precise main

    # Debian Backports
    #deb wheezy-backports main contrib non-free

    # Main packages
    deb wheezy main contrib non-free
    # Testing
    #deb sid main contrib non-free

    # Debian Updates / ex-volatile
    deb wheezy-updates main contrib non-free

    # Debian Security updates
    deb wheezy/updates main contrib non-free

    I have `apt-get update` once more, and tried installing – results the same

  7. Jaroslav


    I have done apt-get update. apt-get upgrade.

    And installing this, agains getting this error. Really not sure why… Something must have messed up the repos for me probably :/

  8. Laurel Amberdine


    Thank you very much for all your work with these repositories. I thought I had successfully upgraded a Debian 7.0 installation to use PHP 5.6, but I have been dealing with the following error:

    The following packages have unmet dependencies:
    php5-adodb : Depends: phpapi-20100525

    When I try to install the dependency:
    E: Package ‘phpapi-20100525’ has no installation candidate

    Do you have any advice? I wound normally just mess around with this until I understood better, but unfortunately I am forced to work on a production server which makes me very nervous!

  9. Guillaume Plessis

    @Laurel : unfortunately, the php5-adodb package is not compatible with PHP 5.6 from Dotdeb. But, because it’s a PHP-only library (not compilation), you can also avoid the installation of the php5-adodb package and vendor adodb in your PHP application.

  10. Laurel Amberdine

    Thank you so much! Just edited that out and it worked.

  11. Jaroslav

    Hello Guillaume!

    here is the more information

    But I know that earlier I have added something about java to sources.list for sure.. then removed.

    Not sure how to recover from this hell now…

    Thank you,

  12. Guillaume Plessis

    What I don’t understand is why, given this sources.list, the first error message you gave was mentioning “PHP 5.4.45-1~dotdeb+7.1”. Please make sure that you ran apt-get update first.

    In doubt, you could remove all PHP-related packages and re-install them from scratch.

  13. Remco


    after running apt-get update, I want to install php-apc, but it depends on phpapi-20100525.

    The following packages have unmet dependencies:
    php-apc : Depends: phpapi-20100525
    E: Unable to correct problems, you have held broken packages.

    When I then want to install phpapi-20100525, it gives me:

    Package phpapi-20100525 is a virtual package provided by:
    php5-fpm 5.4.44-1~dotdeb+7.1 [Not candidate version]
    php5-fpm 5.4.45-1~dotdeb+7.1 [Not candidate version]
    php5-cli 5.4.44-1~dotdeb+7.1 [Not candidate version]
    php5-cli 5.4.45-1~dotdeb+7.1 [Not candidate version]
    php5-cgi 5.4.44-1~dotdeb+7.1 [Not candidate version]
    php5-cgi 5.4.45-1~dotdeb+7.1 [Not candidate version]
    libphp5-embed 5.4.44-1~dotdeb+7.1 [Not candidate version]
    libphp5-embed 5.4.45-1~dotdeb+7.1 [Not candidate version]
    libapache2-mod-php5filter 5.4.44-1~dotdeb+7.1 [Not candidate version]
    libapache2-mod-php5filter 5.4.45-1~dotdeb+7.1 [Not candidate version]
    libapache2-mod-php5 5.4.44-1~dotdeb+7.1 [Not candidate version]
    libapache2-mod-php5 5.4.45-1~dotdeb+7.1 [Not candidate version]

    My installed php5 version is 5.6.19 and doesn’t seem to provide phpapi.
    # dpkg -l | grep php
    ii libapache2-mod-php5 5.6.19-1~dotdeb+7.1 amd64 server-side, HTML-embedded scripting language (Apache 2 module)
    ii php5 5.6.19-1~dotdeb+7.1 all server-side, HTML-embedded scripting language (metapackage)
    [.. etc ..]

    Is this somehow fixable or to be worked around with, without downgrading php?

    thanks in advance,


  14. Remco


    I was hopeful, but it didn’t work.

    The following packages have unmet dependencies:
    php5-apc : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.19-1~dotdeb+7.1 is to be installed
    E: Unable to correct problems, you have held broken packages.

  15. Guillaume Plessis

    @Remco : Hmm, sorry, I forgot that APC was shutdown with PHP 5.6. The packages already include an opcode cache (opcache, included in php5-common). If you need a user land cache, install php5-apcu.