Posted by & filed under PHP.

The PHP 5.3.1 packages for Debian “Lenny” have been updated to fix :

  • the php5-fpm binary
  • the /etc/init.d/php5-fpm script

All should work fine now.

27 Responses to “The PHP 5.3.1 packages have been updated”

  1. WebGoddess

    Be careful with this upgrade. You’ll likely run into deprecation issues.

    In your PHP.ini be sure to set the timezone explicitly, and then you’ll want to add this line:

    error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

    Some major stuff was deprecated like split() and magic_quotes, which are used heavily in many third-party apps.

    I had to turn off display_errors and just log everything to a file because there were so many errors with the large commercial application, Kayako SupportSuite.

    Finally, Zend Optimizer does not support 5.3.x. If you have applications that are Zend-encoded you’ll have to see if you can obtain Ioncube versions instead or you’ll be stuck waiting until Zend releases a new optimizer.

    I opted to stay at 5.3.1 rather than revert back; it is worth upgrading for performance increase just be aware of the changes before you jump into it and you’ll be fine.

  2. Admin Serv

    I have a little bug, maybe not PHP 5.3 issue, the function get_browser can’t parse browsercap.ini file.
    Directive :
    [browscap]
    ;browscap = extra/browscap.ini

    Maybe a PHP bug, I wrote it, maybe it’s not dotdeb related, just for feedback.

  3. Wouter van Vliet

    I’ve found it a better approach to use a custom error handler, and use that to filter exactly which message should be logged/shown/thrown.

    This way, I am making sure that all errors generated from my own scripts are at least logged (including E_DEPRECATED), but some directly emailed to me. While the lower priority messages generated by PEAR/ZEND/ThirdPartyFramework are directly simpley ignored.

  4. thorpe

    There also seems to be a bug within the /etc/php5/conf.d/xdebug.ini file.

    PHP Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0

    This is easily fix by changing xdebug.ini from…

    extension=xdebug.so

    to

    zend_extension=/full/path/to/xdebug.so

  5. Guillaume Plessis

    @Myst : as soon as I find time to migrate to a decent repository manager (reprepro or something…). Not before year 2010, but it’s my #1 priority.

  6. Alex

    Great work, thanks.

    Is there any way you can provide the packages for “armel” processors too? I’m using a Sheevaplug (1.2 GHz ARM Marvell Kirkwood 88F6281) and love to make use of the benefits of php-fpm. Sadly the patched sources won’t compile correctly though this might be just me.

  7. Guillaume Plessis

    @Alex : Sorry, but I can’t build such packages, because :
    – I have no arm machine
    – there is not enough users interested of this port for me supporting it in the long term.

  8. Guillaume Plessis

    @Psycho : Yes, but it’s only a release candidate. PHP 5.3.2 will be packaged for Debian Lenny as soon as it is published as stable by the PHP Group.
    Dotdeb’s goal is not to provide nightly builds, but stable production builds.

    If you want to package PHP 5.3.2 RC1, you can try to extract the “debian” subfolder from the extracted source packages and apply it to the PHP 5.3.2 RC1 sources.

  9. Marco

    Hi

    I am using this excellent module on ubuntu, I have a problem though where I need to install php5-mcrypt but I get the following message

    The following packages have unmet dependencies.
    php5-mcrypt: Depends: libltdl3 (>= 1.5.2-2) but it is not installable

    Any idea what I can do here?

  10. Marco

    Great thanks, that seems to of solved my problem, i can now install php5-mcrypt no problem.

  11. George Shammas

    The php-pear package differs from i386 to amd64 but does not have a different suffix. This is a problem because the same file name is listed in both Packages.gz with different md5sums causing reprepro to fail if syncing both.

    Other then that, these repos are a life saver. Been trying to build a php 5.3.1 with fpm for a while and just couldn’t get it to click.

  12. xblax

    I think you should add php5-fpm as dependency to the php5 metapackage, as some debian packages have the php5 package as dependency.
    If you only want to have php5-fpm installed you have allways to install libapache2-mod-php5, libapache2-mod-php5filter or php5-cgi to get these packages work.

    phpmyadmin for example:
    http://packages.debian.org/lenny/phpmyadmin

  13. Pat

    Hi Guillaume,

    2 questions:
    – trying to use php53.dotdeb.org to get php5-fpm but since php53 is listed as part of stable/lenny I get:
    The following packages have unmet dependencies:
    php5-fpm: Depends: php5-common (= 5.3.1-0.dotdeb.1) but 5.2.6.dfsg.1-1+lenny6 is to be installed
    … end of course I can not remove the standard debian lenny or I miss more stuff (and pinning is not applicable).
    Should I just download all packages and install manually or am I missing something?
    – any news on a 5.2.12 packaging including php5-fpm: would be really cool (I saw the Ubuntu packaged one but ended up it some dependency troubles trying to use it)

    Nice of you to make those available, thank you.