Posted by & filed under MySQL.

MySQL 5.1.44 is now available on Dotdeb for Debian 5.0 “Lenny” in amd64/i386 flavours.

This is primarily a bug fix release, but please read the Changelog carefully before upgrading.

35 Responses to “MySQL 5.1.44 is available for Debian 5.0 “Lenny””

  1. m_ueberall

    Hm… looks like there’s an upgrade problem (cleaning the cache and retrying didn’t work either):

    Preparing to replace mysql-common 5.1.41-3.dotdeb.1 (using …/mysql-common_5.1.44-0.dotdeb.0_all.deb) …
    Unpacking replacement mysql-common …
    dpkg: error processing /var/cache/apt/archives/mysql-common_5.1.44-0.dotdeb.0_all.deb (–unpack):
    unable to create `./etc/mysql/my.cnf’: Invalid argument
    Errors were encountered while processing:

  2. Guillaume Plessis

    @m_ueberall : please give me the output of the following command :

    “ls -al /etc/mysql/my.cnf ; file /etc/mysql/my.cnf”

    Which release of Debian are you using?

  3. m_ueberall

    # ls -al /etc/mysql/my.cnf ; file /etc/mysql/my.cnf ; cat /etc/debian_version
    -rw-r–r– 1 root root 4197 23. Jan 18:09 /etc/mysql/my.cnf
    /etc/mysql/my.cnf: ASCII English text

  4. Terry Hobart

    I had problems upgrading from my lenny install too. I ran an update after the php5 security post ~ 02/22/2010. Then I changed my sources.lst to dotdeb and ran another update upgrade. I used the default answers to keep my my.cnf etc. After that mysql start failed.

    The syslog says ‘FEDERATED’ plugin disabled and mysql.plugin table missing.

    Finally the install says mysql-server5.1 & mysql-server were left unconfigured.

    Thanks in advance for any advice

  5. Guillaume Plessis

    @Terry Hobart : it’s better to install the package maintainer’s version of my.cnf and then backport your changes.
    For example, if you upgraded from MySQL 5.0, the former skip-bdb option will prevent the mysql-server-5.1 to start.

  6. Terry Hobart

    Thank you SO much. Commenting out that in my my.cnf file worked! I am such a moron! It says right in the comments that the property is dead as of 5.1.some low number.

    Thanks again for saving a fools face. I know I should use the new config files, I just had a brain seizure.

  7. beginner

    Is there any instruction available how I can upgrade my Debian (including PHP and MySQL). For me it alwyas shows the old version installed after the installation.

    A step by step instruction would be great as I am a beginner!

  8. m_ueberall

    Disregard my previous postings… the cause of the error must have been that the host file system had been damaged and required a manual fsck run.

  9. jon Bennett

    I’m trying to upgrade but keep getting the following error:

    Unpacking replacement mysql-server-5.1 …
    dpkg: error processing /var/cache/apt/archives/mysql-server-5.1_5.1.44-0.dotdeb.0_i386.deb (–unpack):
    trying to overwrite ‘/usr/sbin/mysqld’, which is also in package mysql-server-core-5.1 0:5.1.37-1ubuntu5.1
    dpkg-deb: subprocess paste killed by signal (Broken pipe)

    any ideas?

  10. Guillaume Plessis

    @jon Bennett : Just remove the mysql-server-core package from Ubuntu.
    FYI, Dotdeb should work with Ubuntu, but it does not provide any additional support.

  11. jon Bennett

    @Guillaume – ok, so I just do apt-get remove mysql-server-core ? Will that wipe out my databases?


  12. Guillaume Plessis

    @jon Bennett : It should not wipe out your databases without any confirmation from you, but be sure to backup your data before any further manipulation (who said “as usual”? 🙂 )

  13. beginner

    I did all steps as in the instructions but it still shows me the old mysql and php versions…not really sure what I am doing wrong…

  14. Cyril

    I used Debian etch and i need to upgrade mysql (5.0.32) to 5.1.X

    but is not working…

    please help me

  15. Guillaume Plessis

    @Cyril : pas avec les paquets cités précédemment, mais Etch n’étant plus entretenue ni par Debian ni par Dotdeb en terme de sécurité, migrer vers Lenny est une bonne idée.

  16. Cyril

    D’accord je vais y penser.

    Lorsque je fais la manip “Instruction” je n’ai pas de message d’erreur par contre l’upgrade de mysql ne se fait pas :

    “0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded.”

  17. Cyril

    D’accords et comment les installer a la main ?
    apt-get install “nom du paquet.deb” ???

  18. Cyril

    j’y arrive pas, as tu un bon source.list pour etch (je vais essayer l’upgrade de la distrib)

  19. Cyril

    pour lenny je voulais dire

    le probleme c’est qu’il veut ca : zlib1g-dev
    et je ne l’ai pas

  20. Cyril

    Merci, je suis en train de mettre a jour vers Lenny.

    J’espere que ca va bien se passer.

  21. Cyril

    CA Y EST !!!

    >> Debian GNU/Linux 5.0 \n \l

    Merci pour tout, et a bientôt j’espère ^^

  22. Jan

    After the update it says the PHP MySQL version is 5.0.51a but MySQL server version is 5.1.44. Does it matter and how do I get them to match?

    I used aptitude update & upgrade.

  23. Guillaume Plessis

    @Jan : 5.0.51a is just the version of the libmysqlclient library PHP was built with. Don’t worry about that delta between the client side and the server side, it does not affect the PHP behaviour.

  24. Jan

    Great! Thanks, got a little worried… I guess alot of error message sounds omnious, bording doomsday warnings 🙂

  25. oliver

    When I try to upgrade from 5.0 to 5.1, I got following error in mysql.err:

    100317 18:45:31 [Note] Plugin ‘FEDERATED’ is disabled.
    100317 18:45:32 InnoDB: Started; log sequence number 123 1166503368
    ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ALTER TABLE user ADD column Show_view_priv enum(‘N’,’Y’) CHAR
    ACTER SET utf8 NOT ‘ at line 1
    100317 18:45:32 [ERROR] Aborting

    I found the query in postinst script and run it manually and there is no syntax error.

    Have you found the reason of this?


  26. Jaime Silva

    Hello there, thanks a lot for this helpful repository… Kudos!

    I’m running your MySQL 5.1.45 in a Debian 5.0 (lenny) server.

    However I’m getting warnings from PHP because the php5-mysql (5.2.13-0.dotdeb.0) driver is depending on (and using) the old library libmysqlclient15off instead of the newer libmysqlclient16 you provide.

    Can this be fixed, please?

    Thanks a lot.


  1.  Dotdeb » Blog Archive » MySQL 5.1.44 is available for Debian 5.0 … | Just linux!