Posted by & filed under PHP.

On november 22nd 2012, the PHP group has released PHP 5.4.9 and PHP 5.3.19, that bring ~15 bug fixes. The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures.

Please also note that Xcache (packaged as php5-xcache) has been upgraded to its 3.0.0 version.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

39 Responses to “PHP 5.4.9 and PHP 5.3.19”

  1. Geo

    Something happed after the update, all sites started to low super slowly, even simple
    script load in 10 seconds… Does anyone have similar issues??

  2. Geo

    It was version issue for sure. Rolled back to older version and problems were gone.
    I guess I’ll skip this upgrade untill the next. Perhaps something in my setup didn’t get along with
    the newest version

  3. Pascale Beier

    Because I prefere APC above xCache, the update is not that interesting to me.

    One interesting aspect is that PCRE is updated to 8.3.1, but it’s not the world 😉

    Nevertheless, good work, guys! /updated.

  4. David Goodwin

    I’m seeing :

    “/usr/lib/php5/20090626/ doesn’t appear to be a valid Zend extension”

    on Debian Squeeze when using php5-xcache ( 5.3.19-1~dotdeb.0 ).

    Is this perhaps why the above commenter reported his sites being slow?

  5. David

    I’m having the same issue as you, catastrophic performance on my sites hosted on the server with PHP 5.4.9. The WordPress one takes several seconds to being rendering pages, the self-made one takes 16 seconds to finish rendering pages… I’ll have to downgrade too… So much for getting to bed “early” :/

  6. David

    I don’t think so. Well, I don’t have package php5-xcache installed, at least:

    dpkg -s php5-xcache
    Package `php5-xcache’ is not installed and no info is available.

  7. David

    NB: like Geo, all solved by downgrading. More specifically, when I downgraded package libapache2-mod-php5filter (not sure if that means the problem is there, it’s also the last package of the upgrade batch that I downgraded)

  8. David

    Btw, any news on this? Not that I really need to upgrade to 5.4.9, but if noone knows where this comes from, I’m afraid it might do it again in 5.4.10 and so on…

  9. mig5


    I was just wondering why your php5-memcached / php5-memcache packages (and php5-suhosin, for that matter, even though I know it’s deprecated) aren’t showing in your for previous releases?

    I have version 5.3.19 of these from your repository, but I need to downgrade.

    Can the old versions of those other packages be added to the archive?


  10. Michael Lednev

    Hello. Any plans to upgrade php5-gearman (and gearman itself) to more recent version? Version 0.13 present in squeeze is way too old.

  11. Yury

    Hi. I can’t install php5-apc.

    ~# apt-get install php5-apc
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-apc : Depends: php5-common (= 5.3.19-1~dotdeb.0) but 5.3.8-2 is to be installed
    E: Broken packages

  12. Kissifrot

    On my side I’m having problems with utf8 encoding the php 5.4 (and PDO): defining the charset=utf8 in the DSN doesn’t work, as well as the PDO::MYSQL_ATTR_INIT_COMMAND.only an exec(‘SET NAMES utf8’); will work. Any idea? (I’m using mysqlnd)

  13. Kissifrot

    haha, found the problem: when specifying the charset in the DSN, I typed charset=utf-8 instead of charset=utf8 (as writen in my previous comment), so it works 🙂

  14. Anthony Somerset

    i had the same issue here, latest update, didnt update my xcache.ini file, had to manually change extension = to zend_extension = for this to work

  15. Sameer


    Where can i get the php5-ldap for php 5.3.19 the latest in the repo is for php 5.3.22 but i need for php 5.3.19