Categories
PHP

PHP 5.4.9 and PHP 5.3.19

On november 22nd 2012, the PHP group has released PHP 5.4.9 and PHP 5.3.19, that bring ~15 bug fixes. The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures.

Please also note that Xcache (packaged as php5-xcache) has been upgraded to its 3.0.0 version.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

39 replies on “PHP 5.4.9 and PHP 5.3.19”

It was version issue for sure. Rolled back to older version and problems were gone.
I guess I’ll skip this upgrade untill the next. Perhaps something in my setup didn’t get along with
the newest version

Because I prefere APC above xCache, the update is not that interesting to me.

One interesting aspect is that PCRE is updated to 8.3.1, but it’s not the world 😉

Nevertheless, good work, guys! /updated.

I’m seeing :

“/usr/lib/php5/20090626/xcache.so doesn’t appear to be a valid Zend extension”

on Debian Squeeze when using php5-xcache ( 5.3.19-1~dotdeb.0 ).

Is this perhaps why the above commenter reported his sites being slow?

I’m having the same issue as you, catastrophic performance on my sites hosted on the server with PHP 5.4.9. The WordPress one takes several seconds to being rendering pages, the self-made one takes 16 seconds to finish rendering pages… I’ll have to downgrade too… So much for getting to bed “early” :/

I don’t think so. Well, I don’t have package php5-xcache installed, at least:

dpkg -s php5-xcache
Package `php5-xcache’ is not installed and no info is available.

NB: like Geo, all solved by downgrading. More specifically, when I downgraded package libapache2-mod-php5filter (not sure if that means the problem is there, it’s also the last package of the upgrade batch that I downgraded)

Btw, any news on this? Not that I really need to upgrade to 5.4.9, but if noone knows where this comes from, I’m afraid it might do it again in 5.4.10 and so on…

Hi. I can’t install php5-apc.

~# apt-get install php5-apc
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-apc : Depends: php5-common (= 5.3.19-1~dotdeb.0) but 5.3.8-2 is to be installed
E: Broken packages

On my side I’m having problems with utf8 encoding the php 5.4 (and PDO): defining the charset=utf8 in the DSN doesn’t work, as well as the PDO::MYSQL_ATTR_INIT_COMMAND.only an exec(‘SET NAMES utf8’); will work. Any idea? (I’m using mysqlnd)

Comments are closed.