Posted by & filed under PHP.

On March 14th 2013, the PHP group has released PHP 5.4.13.

These releases fix about 15 bugs, including fixes for CVE-2013-1643 and CVE-2013-1635. All users of PHP are encouraged to upgrade to PHP 5.4.13.

The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures with the following changes :

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

Note : PHP 5.3.23 packages will be available at the end of this week.

16 Responses to “PHP 5.4.13”

  1. Tim

    That was fast, Guillaume.
    Thank you for the update and the ffmpeg package. 🙂

  2. Guillaume Plessis

    @skp : they’re the same as long as Squeeze is the stable distribution. If you don’t want an unexpected upgrade when Wheezy is the new stable, stick to the “squeeze” line.

  3. Alexander M. Turek

    The upgrade from 5.4.12 to 5.4.13 fails on my Ubuntu quantal box because of an unsatisfied dependency on libdb4.8. As far as I can tell, Ubuntu dropped that package with quantal.

  4. Guillaume Plessis

    @Alexander M. Turek : Dotdeb is made for Debian stable. If you want to use it on Ubuntu (at your own risk), you should keep Debian Squeeze-related sources.list entries, so that dependencies are satisfied.

  5. Alexander M. Turek

    Thank you for your quick reply. I’m grateful for your package repository and I know that I’m doing this at my own risk. I just wanted to let you know about this issue, as you’re saying “The packages from Dotdeb should work on Ubuntu”, which was true for me until that upgrade.

    Installing the libdb4.8 package from Ubuntu precise manually solved the problem for me, btw. I ran into a different one with the php5-mysql package, but I switched to your github issue tracker for that report.

  6. Thomas

    I am using PHP 5.4.13 with php5-ssh2 from dotdeb (on a debian squeeze server) and wordpress uses ssh2 for updates. But every time I try to make a wordpress update this warning is logged and the update do not start:
    PHP Warning: stream_set_timeout(): No support for ssh2 stream timeout. Please recompile with libssh2 >= 1.2.9 in …/wp-admin/includes/class-wp-filesystem-ssh2.php on line 141

    This is line 141: stream_set_timeout( $stream, FS_TIMEOUT );
    The version of libssh2-1 in squeeze is: 1.2.6-1

    Is it possible to use ssh2 for wordpress-updates with this dotdeb php packages on squeeze?

    Thanks for your great work!

  7. Guillaume Plessis

    @Thomas : sorry to hear that. I don’t think I’ll fix it (by backporting libssh2) in Squeeze, but it will be ok in the upcoming Wheezy.

  8. Tom


    When restarting Apache, I get this:
    Starting web server: apache2apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ cannot open shared object file: No such file or directory
    Action ‘start’ failed.

    So I looked for and I can’t find it on the machine so I tried to install it and got this:
    apt-get install -f -y –force-yes libapache2-mod-php5
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libapache2-mod-php5 : Depends: php5-common (= 5.3.3-7+squeeze15) but 5.4.13-1~dotdeb.1 is to be installed
    E: Broken packages

    What should I do to fix this?

  9. Tom

    Solved my own problem by doing this:
    apt-get install -t squeeze-php54 libapache2-mod-php5