Posted by & filed under Miscellaneous.

Now that Debian 7.0 “Wheezy” has been released, I’m glad to announce that it’s supported by Dotdeb. Feel free to change your sources.list and to upgrade your boxes.

About Wheezy & Dotdeb

Wheezy is supported as of today and these packages will be maintained :

  • PHP : 5.4 and 5.5 (as soon as it’s GA)
  • MySQL : 5.6 or equivalent (Percona Server, MariaDB…)
  • Nginx
  • Redis
  • Zabbix
  • Percona toolkit

(PHP 5.4, Zabbix and Percona toolkit packages are missing now, they will appear in the next few days)

That means that the support for these packages will be discontinued in Wheezy :

  • MySQL 5.5. The Debian project will be in charge of the 5.5 branch. Transition is seamless.
  • PHP 5.3 (you’ll have to stick to Squeeze)

About Squeeze & Dotdeb

Squeeze will be supported by Dotdeb as long as it is supported by Debian (one year), with the current lineup :

  • PHP 5.4 and PHP 5.3 (as long as it’s supported by the PHP Group). No PHP 5.5.
  • MySQL 5.5. No MySQL 5.6 or equivalent.
  • Nginx stable
  • Redis
  • Zabbix
  • Percona toolkit

41 Responses to “Debian 7.0 “Wheezy” has been released”

  1. thomas

    same mysql problem here:

    lannik:/etc/apt# apt-get -f dist-upgrade -y
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Correcting dependencies… Done
    Calculating upgrade… Done
    The following packages will be upgraded:
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    600 not fully installed or removed.
    Need to get 0 B/1,717 kB of archives.
    After this operation, 6,671 kB of additional disk space will be used.
    Reading changelogs… Done
    (Reading database … 82302 files and directories currently installed.)
    Preparing to replace mysql-client-5.5 5.5.30-1~dotdeb.0 (using …/mysql-client-5.5_5.5.30+dfsg-1.1_amd64.deb) …
    Unpacking replacement mysql-client-5.5 …
    dpkg: error processing /var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_amd64.deb (–unpack):
    trying to overwrite ‘/usr/share/man/man1/mysqlcheck.1.gz’, which is also in package mysql-client-core-5.5 5.5.30-1~dotdeb.0
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. Barbaros

    I had the same problem about Mysql. Looks like Debian’s official repo is trying to overwrite dotdeb’s mysql.

    The easiest solution for me was removing mysql, and re installing it after upgrade. Then it was fine!

  3. Anthony Somerset

    are there some issues with the mirror at the moment – only seeing nginx and redis in wheezy dist pool and nginx dir is giving 403’s on our mirror (i just manually synced to double check)

  4. Guillaume Plessis

    @d6rkaiz, @thomas : sorry for the mess. You can circumvent the problem with

    apt-get -f install -o Dpkg::Options::="--force-overwrite"
  5. normadize

    I did pretty much the same and posted the full solution on github, but here it is as well:

    The problem is that `mysql-client-core-5.5` is not upgraded because it does not exist in Debian Wheezy so the Dotdeb one conflicts with Debian’s new `mysql-client-5.5`.

    I removed mysql completely, upgraded and then installed it again, i.e.

    apt-get remove mysql-client-5.5 mysql-server-5.5 mysql-server mysql-server-core-5.5 mysql-common mysql-client-core-5.5 libmysqlclient18 libmysqlclient16 libmysqlclient15off
    apt-get dist-upgrade
    apt-get install mysql-server-5.5 mysql-client-5.5

    Replace `dist-upgrade` with `upgrade` depending on your preference.

  6. normadize

    The other problem I have though is that even after updating the sources.list to have:

    deb wheezy all
    deb-src wheezy all

    I’m still not getting any PHP 5.3 -> 5.4 upgrade from Dotdeb. APT is holding back the upgrade as it tries to upgrade to Wheezy’s PHP 5.4.4:

    # apt-get update
    # apt-get upgrade
    The following packages have been kept back:
    libapache2-mod-php5 (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php-pear (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php5-cli (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php5-common (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php5-gd (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php5-mcrypt (5.3.24-1~dotdeb.0 => 5.4.4-14)
    php5-pgsql (5.3.24-1~dotdeb.0 => 5.4.4-14)

    Any clues?

  7. Guillaume Plessis

    @normadize : as said in the blog post, PHP 5.4 packages will be available in the next few days. Thanks in advance for your patience.

  8. Guillaume Plessis

    @Anthony : PHP 5.4, Zabbix and Percona toolkit packages are missing now, they will appear in the next few days (not enough spare time these days to resolve all their minor issues).

    I just fixed some permissions issues, could you please re-sync?

  9. normadize

    Argh, sorry for having missed that bit in your post!

  10. Jools

    A simple “dpkg –remove mysql-client-core-5.5” then “apt-get -f install” worked here when the dist-upgrade broke.

  11. Carsten

    But it seems you broke nginx for squeeze! It requires libprce3 and libssl in versions that are not available for squeeze with last night update 🙁

  12. Carsten

    Oups, had “stable” instead of squeeze in my source.list. Sorry, forget about my comment above.

  13. d6rkaiz

    thanks for reply.

    my problem was solved.
    running as follows:

    apt-get -f install -o Dpkg::Options::=”–force-overwrite”
    apt-get remove mysql-client-core-5.5
    apt-get dist-upgrade


  14. Yohann

    # /etc/init.d # apt-get install nginx-full
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dĂ©pendances
    Lecture des informations d’Ă©tat… Fait
    Certains paquets ne peuvent ĂȘtre installĂ©s. Ceci peut signifier
    que vous avez demandĂ© l’impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n’ont pas encore
    Ă©tĂ© crĂ©Ă©s ou ne sont pas sortis d’Incoming.
    L’information suivante devrait vous aider Ă  rĂ©soudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    nginx-full : DĂ©pend: libgeoip1 (>= 1.4.8+dfsg) but won’t be installed
    DĂ©pend: libpcre3 (>= 8.10) mais 8.02-1.1 will must be installed
    DĂ©pend: libssl1.0.0 (>= 1.0.1) can’t be installed
    E: Paquets défectueux

    How can I resolve this ? Thx

  15. Yohann

    Ok same as Carsten, I had to change stable by squeeze. I just read new instructions 😉

  16. Nuno

    Hi, if I install php from debain now, do I need to reinstall dotdeb php or it will upgrade smoothly?


  17. Hunterpl

    Hello i have got problem from Debian 6 Squeeze and don’t know what to do:

    Your PHP MySQL library version 5.1.66 differs from your MySQL server version 5.5.30. This may cause unpredictable behavior.


    Database server

    Server: Localhost via UNIX socket
    Server type: MySQL
    Server version: 5.5.30-1.1-log – (Debian)
    Protocol version: 10
    User: root@localhost
    Server charset: UTF-8 Unicode (utf8)

    Web server

    Database client version: libmysql – 5.1.66 <—- here is the problem i installed mysql correctly why previously version still in use ?? how can i fix it help me.
    PHP extension: mysql Documentation

  18. Hunterpl

    Im forget to add, currently use the Debian wheezy 7.0 and same problem occur. Thanks if someone can tell me how fix that problem.

  19. Guillaume Plessis

    @Hunterpl : this is just a stupid warning from libmysqlclient, without any further consequence. Install php5-mysqlnd instead of php5-mysql, or adjust your error_reporting level, if you want to get rid of it.

  20. Hunterpl

    It’s strange error because Debian wheezy also was installed on PC. MySQL 5.5.30 and Apache 2.2.22 , no errors occured probably i have to install fresh copy. Could you tell me, which packages i have to purge and install fresh package MySQL and PHP5 to repair existing problem. I can’t use the mysqlnd because i use the phpmyadmin.

  21. Hunterpl

    Dear Guillaume Plessis

    I didin’t tell you everything, that error was when i did upgrade MySQL from 5.1.66 to 5.5 MySQL server and client, when i used Squeeze 6.0, currently use the wheezy upgraded from squeeze one day ago. This problem exist in my company server dedication and that information what i wrote before, i mean Mysql 5.5.30 server and client also the web engine Apache 2.2.22 didin’t show that error because was tested on my PC at home. I didin’t upgraded from squeeze to wheezy just made fresh install. Error what i wrote exist only in my company, yes i would rid of it, can i fix it without reinstalling the operating system ? The company system wheezy 7.0 use the new engine lighttpd 1.4.31 we won’t use the apache 2. Please help me.

  22. Hunterpl

    Hello Dear Guillaume Plessis !

    I resolved the issue by execute:

    apt-get remove mysql-server-5.5 mysql-server mysql-server-core-5.5 mysql-common mysql-client-core-5.5 libmysqlclient18 libmysqlclient16 libmysqlclient15off
    apt-get remove php5-common

    i didin’t wrote the package ” mysql-client-5.5 ” because was error info no candidate package something…

    apt-get dist-upgrade
    apt-get install mysql-server-5.5 mysql-client-5.5
    apt-get install phpmyadmin
    apt-get install php5

    Done problem was resolved now appear the line:

    Database client version: libmysql – 5.5.30 – Correctly I’m happy see ya.

    Best Regards

  23. george

    After upgrading everything I was unable to run mysql-server-5.5 setup:

    130512 19:18:28 InnoDB: Warning: io_setup() failed with EAGAIN. Will make 5 attempts before giving up.
    InnoDB: Warning: io_setup() attempt 1 failed.
    InnoDB: Warning: io_setup() attempt 2 failed.
    InnoDB: Warning: io_setup() attempt 3 failed.
    InnoDB: Warning: io_setup() attempt 4 failed.
    InnoDB: Warning: io_setup() attempt 5 failed.
    130512 19:18:31 InnoDB: Error: io_setup() failed with EAGAIN after 5 attempts.
    InnoDB: You can disable Linux Native AIO by setting innodb_use_native_aio = 0 in my.cnf
    130512 19:18:31 InnoDB: Fatal error: cannot initialize AIO sub-system
    130512 19:18:31 [ERROR] Plugin ‘InnoDB’ init function returned error.
    130512 19:18:31 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.
    130512 19:18:31 [ERROR] Unknown/unsupported storage engine: InnoDB
    130512 19:18:31 [ERROR] Aborting

    It suggests to use innodb_use_native_aio in my.cnf – no difference at all.
    Seems like mysql server bug

  24. george

    I was lucky and was able to fix this:

    I removed mysql to start clean:

    apt-get remove –purge mysql\*
    dpkg -l | grep -i mysql
    apt-get clean
    apt-get install mysql-client mysql-client-5.5 mysql-common

    Then changed the innodb_use_native_aio setting as the console suggested.
    nano /etc/my.cnf
    innodb_use_native_aio = 0

    apt-get install mysql-server-5.5

    And thus mysql installed correctly. However just to test if this was the issue i went back to nano /etc/my.cnf
    and removed the line “innodb_use_native_aio = 0”, reloaded mysql and guess what – again the sql server didn’t want to start.
    So this definately was the issue for me, could help if someone else has this issue.

  25. george

    With MySQL 5.5.31 my problems described above with innodb_use_native_aio
    are gone and it’s all working perfectly now. Thanks!

  26. Gary Dale

    I normally wait a couple of months before upgrading a server. Now that 7.1 is out, I figured I’d try upgrading to Wheezy from Squeeze. Unfortunately, MySQL refuses to upgrade. Everything else went fairly smoothly but MySQL doesn’t start. This happens even if I purge the installation and reinstall. Here’s what I get:

    [FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
    invoke-rc.d: initscript mysql, action “start” failed.
    dpkg: error processing mysql-server-5.5 (–configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mysql-server:
    mysql-server depends on mysql-server-5.5; however:
    Package mysql-server-5.5 is not configured yet.

    dpkg: error processing mysql-server (–configure):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:

  27. Jim

    Where is MySQL 5.6 (or equiv)? I can only get 5.5 on wheezy and above it says that 5.6 will be maintained?

  28. Darki

    Ok, thank you for your answer. Currently my biggest problem is to find an a 5.6 MySql client.

  29. vegiVamp

    Hey Guillaume,

    Many thanks for all the work you’re putting into this!

    Do you have an idea about when you’ll be able to release the MySQL 5.6 packages?


  30. Yoyo

    Take your time for Mysql5.6. 🙂 Hope it’s going well with no error when you’ll release it 🙂

  31. x500

    Similar problem here.
    It worked after removing setting: explicit_defaults_for_timestamp from /etc/mysql/my.cnf


  1.  Was bringt Debian Wheezy fĂŒr die LAMP-Box? | Privatstrand