Posted by & filed under PHP.

On April 3rd 2014, the PHP group has released PHP 5.4.27. 6 bugs were fixed in this release, including CVE-2013-7345. All PHP 5.4 users are encouraged to upgrade to this version.

The corresponding packages are now available on Dotdeb :

  • for Debian 7.0 “Wheezy” and Debian 6.0 “Squeeze”,
  • on both amd64 and i386 architectures.

As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

And if you find Dotdeb useful, feel free to show your support.

2 Responses to “PHP 5.4.27, for Wheezy and Squeeze”

  1. Eric

    Dependency problems in a special case (not so uncommon?)
    I am using dotdeb sources for php5 and mariadb (deb wheezy main).

    The recent update from 5.4.26 to 5.4.27 broke dependencies as follows:

    libmariadbclient18 depends on libmysqlclient18 (=5.5.36+maria-1~wheezy)

    mysql-common (5.5.36+maria-1 conflicts with 5.6..17~dotdeb.1)

    It can be resolved by sticking to the mariadb-versions, but please check, if there are caveats. Couldn’t dotdeb provide mariadb itself?

  2. Guillaume Plessis

    @Eric : Your problem does not come from the PHP upgrade, but from teh recent introduction of MySQL 5.6 in Dotdeb. It’s more recent than your MariaDB 5.5.36, so APT tries to upgrade the common packages. What you could do is pinning your MariaDB packages with an higher priority in /etc/apt/preferences.d/mariadb, something like

    Package: libmysqlclient18 libmysqlclient-dev # List here any MariaDB package you don't want to upgrade.
    Pin: release
    Pin-Priority: 900

    About MariaDB, that’s something I’m considering (with the 10.x version).