Posted by & filed under PHP.

On January 7th 2016, the PHP group released PHP 5.6.17.

This is a security release. Several security bugs were fixed in this release. All PHP 5.6 users are encouraged to upgrade to this version.

PHP 5.6.17 packages are now available for Debian 7 “Wheezy”, on both amd64 and i386 architectures, in ZTS and non-ZTS (default) flavors, along with the usual PECL extensions.

18 Responses to “PHP 5.6.17 for Wheezy”

  1. Standa

    Hi, thank you for your perfect services. I would like to ask you, if you will support even jessie with php 5.6. Latest debian version is 5.6.14.

  2. Guillaume Plessis

    @Standa, I don’t want to duplicate Debian’s effort. They will upgrade 5.6.14 when necessary from a security perspective. Is there any blocking bug in 5.6.14?

  3. huglester

    Hello,

    this does not include the php5-gearman?

    Because I get this message, when try to install php5-gearman:
    The following packages have unmet dependencies:
    php5-gearman : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.17-1~dotdeb+7.1 is to be installed

    Thank you

  4. huglester

    Hello,
    sorry for a delay! I thought I have sent a reply and seems I did not press the send button:)

    OS: Debian wheezy 7.9, x64
    # php -v ( I use php fpm)
    PHP 5.6.17-1~dotdeb+7.1 (cli) (built: Jan 7 2016 20:36:21)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

    # dpkg -l ‘php*’ | grep ‘^.i’
    ii php-pear 5.6.17-1~dotdeb+7.1 all PEAR – PHP Extension and Application Repository
    ii php5-apcu 1:4.0.7-2~dotdeb+7.1 amd64 APCu – APC User Cache
    ii php5-cli 5.6.17-1~dotdeb+7.1 amd64 command-line interpreter for the php5 scripting language
    ii php5-common 5.6.17-1~dotdeb+7.1 amd64 Common files for packages built from the php5 source
    ii php5-curl 5.6.17-1~dotdeb+7.1 amd64 CURL module for php5
    ii php5-dev 5.6.17-1~dotdeb+7.1 amd64 Files for PHP5 module development
    ii php5-fpm 5.6.17-1~dotdeb+7.1 amd64 server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii php5-gd 5.6.17-1~dotdeb+7.1 amd64 GD module for php5
    ii php5-intl 5.6.17-1~dotdeb+7.1 amd64 internationalisation module for php5
    ii php5-mcrypt 5.6.17-1~dotdeb+7.1 amd64 MCrypt module for php5
    ii php5-memcached 1:2.2.0-2~dotdeb+7.1 amd64 PHP extension for interfacing with memcached via libmemcached library
    ii php5-mysql 5.6.17-1~dotdeb+7.1 amd64 MySQL module for php5

    —–
    now when I try to install: # apt-get install php5-gearman

    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-gearman : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.17-1~dotdeb+7.1 is to be installed
    E: Unable to correct problems, you have held broken packages.

    maybe you have ideas what could have been wrong? I had php5.5 and wanted 5.6

    Thanks for any help!

  5. huglester

    apt-get install php5-gearman=1:0.8.3-2~dotdeb+7.1
    – this one installed gearman somehow. I did not see any warnings or so.. I will do further testings to see how the gearman works itself

  6. Igor

    It’s built against mysql 5.5 so if you have mysql 5.6, you will get this sad thing “Headers and client library minor version mismatch. Headers:50544 Library:50628”. I wasn’t getting it with your build of php 5.6 when I was on wheezy.

  7. Igor

    So I take it I’ll have to compile php myself if I want to have php 5.6 compiled against mysql 5.6 instead of mysql 5.5 to prevent “Headers and client library minor version mismatch” on jessie?
    If so, can you please provide your configure line for me to use it as base?

  8. Igor

    I tried but the version it showed freaked me out. It was “mysqlnd 5.0.11-dev – 20120503”

  9. Igor

    Handing version number is rather confusing but I’ll give it a try. Thanks.

    P.S. Something is wrong with your captcha. It always gives timed out error whenever you try to post comment.

  10. Mikhail

    Hi guys! Tell me when will php 5.6.17 for jessie? I can’t find repositories:( 5.6.14 version which is available in the debian packages many bugs that I can’t work. Help please.
    Thank you.

  11. Guillaume Plessis

    @Mikhail : I don’t want to duplicate Debian’s effort. They will upgrade 5.6.14 when necessary from a security perspective. Is there any blocking bug in 5.6.14?

  12. Mikhail

    I’m sorry, I still decided to put Wheezy until satisfied with his work, but still the performance is not comparable to Wheezy with Jessie