Categories
PHP

PHP 7.0.2 for Jessie

On January 7th 2016, the PHP group published PHP 7.0.2.

31 reported bugs has been fixed, including 6 security related issues. All PHP 7.0 users are encouraged to upgrade to this version.

Packages of PHP 7.0.2 are now available for Debian 8 “Jessie” on amd64 and i386 architectures.

Please note that :

  • You should remove any PHP5 packages before upgrading
  • Packages of the PECL extensions (Memcache, Memcached, Mongo, Redis, Xdebug…) are still missing.
  • The thread-safe version of all these packages will be published soon.

Please make sure that you understand the above PHP/Debian/Dotdeb changes and that you don’t need any of the missing features/packages. Your feedbacks are always welcome. Just make sure they are useful.

These packages have been published on the main repository for Jessie because they have new names because they shouldn’t conflict with any PHP5 installation. So to get PHP 7.0.2 , just follow the regular instructions for Jessie.

And as usual, feel free to show your support, it is always greatly appreciated… 🙂

34 replies on “PHP 7.0.2 for Jessie”

Hi,
I see this when trying to apt-get upgrade :

Setting up php7.0-cli (7.0.2-1~dotdeb+8.1) …
ucfr: Attempt from package php7.0-cli to take /etc/php/7.0/apache2/php.ini away from package libapache2-mod-php7.0
ucfr: Aborting.

phpmyadmin : Depends: libapache2-mod-php5 but it is not going to be installed or
libapache2-mod-php5filter but it is not going to be installed or
php5-cgi but it is not going to be installed or
php5-fpm but it is not going to be installed or
php5 but it is not going to be installed
Depends: php5-mysql but it is not going to be installed or
php5-mysqli but it is not installable or
php5-mysqlnd but it is not going to be installed
Depends: php5-mcrypt but it is not going to be installed
Depends: php5-json but it is not going to be installed
Depends: php-gettext but it is not going to be installed
Recommends: php5-gd but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi,

Any Ideas?

Setting up libapache2-mod-php7.0 (7.0.2-1~dotdeb+8.1) …
dpkg: error processing package libapache2-mod-php7.0 (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php7.0:
php7.0 depends on libapache2-mod-php7.0 (>= 7.0.2-1~dotdeb+8.1~) | php7.0-cgi (>= 7.0.2-1~dotdeb+8.1~) | php7.0-fpm (>= 7.0.2-1~dotdeb+8.1~); however:
Package libapache2-mod-php7.0 is not configured yet.
Package php7.0-cgi is not installed.
Package php7.0-fpm is not installed.

dpkg: error processing package php7.0 (–configure):
dependency problems – leaving unconfigured
Errors were encountered while processing:
libapache2-mod-php7.0
php7.0
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi, biggest thanks for the packages! Can you please include/package xsl extension which seems to be missing but otherwise works OK under php7.

I don’t know if it’s my single case scenario but all symlinks names in /etc/php/7.0/fpm/conf.d begin with “20-” on Debian Jessie. PHP info shows:
/etc/php/7.0/fpm/conf.d/10-apcu.ini, /etc/php/7.0/fpm/conf.d/20-apcu_bc.ini, /etc/php/7.0/fpm/conf.d/20-curl.ini, /etc/php/7.0/fpm/conf.d/20-gd.ini, /etc/php/7.0/fpm/conf.d/20-imagick.ini, /etc/php/7.0/fpm/conf.d/20-json.ini, /etc/php/7.0/fpm/conf.d/20-ldap.ini, /etc/php/7.0/fpm/conf.d/20-mcrypt.ini, /etc/php/7.0/fpm/conf.d/20-mysqli.ini, /etc/php/7.0/fpm/conf.d/20-opcache.ini, /etc/php/7.0/fpm/conf.d/20-pdo_mysql.ini, /etc/php/7.0/fpm/conf.d/20-readline.ini
apcu_bc should be loaded after apc and opcache should be loaded with priority 10 (as comment in opcach.ini says).
Can anybody also confim this?

Info from PHP that I’ve posted shows 10=apcu.ini – it has been fixed from 20- by myself, originally it was 20- as I wrote earlier.

Memcached such as Redis are still missing.
On January 11th you said that you would try to add both this month. Is this information out of date or can we still expect both to be released this month?

Thanks! 🙂

@Andreas : thanks for the reminder… php7.0-redis is now available, relying on the latest commit of the php7 branch. Please note that it’s not the latest stable version.

I’ll work on memcached this week-end.

Hi Guillaume,

Is there any way to use libmysqlclient with PHP 7?

Previously
php5-mysql would provide libmysqlclient
php5-mysqlnd would provide mysqlnd

However it seems php7.0-mysql provides mysqlnd and I can’t see a package that provides libmysqlclient.

Regards,
Mike

“You should remove any PHP5 packages before upgrading”

Package php-pear depends on php5-common, php5-cli, any chance of getting a PHP 7 version?

Comments are closed.