Categories
Nginx

Nginx 1.4.0, for Wheezy and Squeeze

Nginx 1.4.0 stable version has been released on April 24th 2013, incorporating many new features developed in the 1.3.x branch :

As a consequence, Dotdeb’s packages of Nginx 1.4.0 are now available for both Debian 7.0 “Wheezy” and Debian 6.0 “Squeeze” (amd64/i386) with the following changes :

  • (Wheezy only) SPDY support has been enabled in nginx-extras and nginx-full.
  • (Wheezy only) the nginx-passenger flavor has been removed. You should use unicorn or uwsgi-plugin-rack-ruby* instead.
  • nginx-extras now supports HTTP Gunzip.
  • Naxsi has been upgraded to 0.50.
  • chunkin-nginx-module (useless now) and nginx-upload-module (incompatible with 3.1.8+) are no longer supported.
  • The headers-more, echo, lua, Push stream, Pinba and Passenger modules got minor upgrades.

As usual, if you want to know which module has been included in each Nginx flavor, you just have to look at this document.

41 replies on “Nginx 1.4.0, for Wheezy and Squeeze”

Anyone having issues with this update?
My nginx starts but refuses connections after the upgrade, no log entry to indicate anything wrong.

@Dyneslott: If you use IPv6 address in “listen” directive, you need to add “ipv6only=off” to also listen IPv4 addresses. Eg:
listen [::]:80; will become listen [::]:80 pv6only=off;

When I restart Nginx, I get the following warning message :

[warn] nginx was built without OpenSSL NPN support, SPDY is not enabled for [::]:443 in …

In fact, SPDY is unusable with most Nginx configurations :/

I hace problem with SPDY in nginx.
I installed nginx-full and add “ssl spdy” to server listen directive.
When I test / restart nginx I receive info:

[….] Restarting nginx: nginxnginx: [warn] nginx was built without OpenSSL NPN support, SPDY is not enabled for 0.0.0.0:443 in /etc/nginx/sites-enabled/mysite

I have OpenSSL 1.0.1e, so with NPN.
What’s wrong?

@Jonathan Leroy : Oh sorry to hear that, I missed that point. I’ll see what I can do, but I think we’ll have to wait for the upcoming Wheezy packages (if the OpenSSL library has been built with NPN support, I have to check this).

@lukasamd : you have OpenSSL 1.0.1e, but you use Squeeze packages. They were built against OpenSSL libraries without NPN support, so I guess SPDY was disabled during the build process. I think we’ll have to wait for the upcoming Wheezy packages (working on it).

This ipv6only=off -option seems like a new thing needed since the last stable versions. I added this to the default config and now every other virtual host works very well. No need to add it to every {server}-Container, just to the first. So its good to create a default config named 000-default so it is the first config that is used.

@Guillaume Plessis
But I have Wheezy.
Default, VPS had Squeezy, but I did upgrade to Wheezy about month ago.

I will check this on virtualbox with debian testing rc, but it’s strange.

Hi,

It’s not a big issue.
But I noticed that the upgrade has overwritten the index.html file in /usr/share/nginx/html.
I already restored the file from a backup. 🙂

Why on Squeeze, after I install nginx I always get:

insserv: warning: script is corrupt or invalid: /etc/init.d/../rc2.d/S99local
insserv: warning: script ‘firewall’ missing LSB tags and overrides

?

As I mentioned before, with the release of version 1.2.7, I can’t run any version later than 1.2.6 without breaking ssl.
I am running squeeze with openssl 1.0.1e
Please give me a hint of what changed between version 1.2.6 and 1.2.7, that breaks the system since.

Hey,

first I want to thank you for all your effort and hard work you put into this project 🙂

In your nginx-extras flavor it seem you included ngx_pagespeed, or what does (WIP) mean? I tried to use ist (pagespeed on) but it doesn’t seem to work.

Hope you can help, thanks.

Why was nginx-passenger flavour removed? Was it for some technical reason? Although you list alternatives, that means a bunch of reconfiguration, and everything was working just fine with passenger. Thanks.

I re-added support for the passenger package and built from source. I changed dependency version to use passenger from wheezy. All works. As it’s not a major issue (or one I don’t know of), ro have an extra package, I would like to request it is put back in.

why was passenger support removed – this effectively breaks the upgrade path for a couple of servers for me as we have been using the dotdeb nginx-passenger packages for some time, and its not going to be a trivial matter to fix the rails apps to work with unicorn et al very quickly due to being older codebases

Anyone have issues once they’ve enabled spdy?

I get no errors but connection refused in a web browser.

Comments are closed.